Jump to content
AutoDesSys Forums
Tech

formZ v9.0.3 Now available

Recommended Posts

12 hours ago, Shibui Design said:

The last and this latest version of Layout does not work for me. I've reported this with earlier builds and my problem persists.

 

We can not find any emails from you in our support system regarding this issue (but sometimes correlating forum names to email addresses is not always easy). You seem to be experiencing a problem that no other user has encountered. Please contact us via email (support@formz.com) so we can properly diagnose the issue.

Share this post


Link to post
Share on other sites
8 hours ago, Bo Atkinson said:

I do not use Layout; however with "blank display" problems in MultiView in 3d projects, I simply open a new additional project and then switch back to the previously blank project which now restored it's display. 

Bo, 

We have seen this on certain combinations of graphics cards and machines. What machine and OS X version are you using? 

Share this post


Link to post
Share on other sites
22 hours ago, Richard Fairbanks said:

With the update to version 9.0.3 (Build A123), I seem to have lost some critical palettes.

 

Richard,

We have reached out to you via email to investigate this issue.

Share this post


Link to post
Share on other sites
1 hour ago, Tech said:

Chris,

This is working properly as far as we can tell. See video from 9.0.3....

Definitely not working the same here.  Will test on my other computer.

This one is: Mac Pro 5,1

2 x 2.4 GHz 6-Core Intel Xeon 

ATI Radeon HD 5770 1024 MB

12 GB 1333 MHz DDR3

https://www.dropbox.com/s/ssodmkzuc0o18l1/Components.mp4.zip?dl=0

 

Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Tech said:

We can not find any emails from you in our support system regarding this issue (but sometimes correlating forum names to email addresses is not always easy). You seem to be experiencing a problem that no other user has encountered. Please contact us via email (support@formz.com) so we can properly diagnose the issue.

Hey Tech

It struck me that you guys keep defending yourselves and giving us (me) customers any mistakes!

I feel the same way as the other forum members: 
Very often I have written very detailed bug reports and also uploaded the corresponding documents to a file server so that you can check them.
Unfortunately without any answer.

When I have made suggestions, you ask me for the «why» and when I explain it, you don't answer…

Edited by AHDD Designer

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/24/2020 at 11:09 PM, Tech said:

“Give Guide Snaps Priority” is a new option in the snap options Palette. When selected, Guide Snaps are given priority over object snaps

Can't get this to work. What I want is to be able to lock to an ortho guide by pressing shift, while moving an object that overlaps another. "Guide lock" should not need to have priority over anything. It should always be possible. Still I need to move the object into the clear, then lock to the ortho guide, then move it back to were I need it. This is so fundamental!!

Edited by palarsen

Share this post


Link to post
Share on other sites
7 hours ago, Tech said:

We can not find any emails from you in our support system regarding this issue (but sometimes correlating forum names to email addresses is not always easy). You seem to be experiencing a problem that no other user has encountered. Please contact us via email (support@formz.com) so we can properly diagnose the issue.

Thank you for your reply Tech. Perhaps I've posted the problems in the wrong place on the forums. Here's a post I made on Jan. 14 regarding build 9.0.0.1. There was another similar post in response to another user post, here:

 Again, probably not the correct place to post such problems. As an aside, I did make a call to Tech support perhaps 6-8 weeks back about this problem and others. There wasn't a fix or workaround at that time. I shall email support to submit a proper support ticket.

 

 

Thank you!

 

Share this post


Link to post
Share on other sites
6 hours ago, AHDD Designer said:

It struck me that you guys keep defending yourselves and giving us (me) customers any mistakes!

 I feel the same way as the other forum members: 
Very often I have written very detailed bug reports and also uploaded the corresponding documents to a file server so that you can check them.
Unfortunately without any answer.

 When I have made suggestions, you ask me for the «why» and when I explain it, you don't answer…

Sorry if you feel that way. We recognize that you have given a lot of good feedback over the years and if something was missed its unintentional. 

In 2018 we deployed a professional CRM system to manage tech support emails to make sure nothing gets missed. This system assigns each new email a ticket number that allows for us to track the back and forth communication on requests for assistance and reported issues. Shortly after you submit an email you will get an confirmation email that contains the ticket number for your reference. We checked the system and found all of the tickets that you had initiated since we started using this system have been answered and closed. We will need a bit more time to look through older emails to determine what was missed.

Please continue to give constructive feedback as it is important for us to hear the the things that we can do better.

Share this post


Link to post
Share on other sites

For me the new Give Guides Snap Priority is working great.  Mac OS.   It locks on right as I hit shift and the guides display above all objects.

Share this post


Link to post
Share on other sites
15 hours ago, Tech said:

Bo, 

We have seen this on certain combinations of graphics cards and machines. What machine and OS X version are you using? 

I'm on 2012MacPro w/RadeonHD5870, and that occurred in the Beta, which fixed it back then 98%, but still happens very rarely, no problem here...

I mentioned it just in case it might help with the earlier stated display issue in Layout, (which I do not use).

Share this post


Link to post
Share on other sites
On 4/28/2020 at 7:00 AM, Tech said:

Hugo,

We have not been able to reproduce the issue you are describing regarding the dimensions or 2D graphics moving. Can you please send a file to us (support@formz.com) that exhibits the problem so we can investigate? 

We are working on the update speed for layout. from. v9.0.3 actually had some improvements, but we are working on more!

Tech,

The update speed, actually it was not updating at all, had to do with synchronizing the file in Dropbox to the MacBook. The files only stored in the cloud, will not update automatically. You have to store the files ALSO on the computer. 

The other issues I could not reproduce yesterday either. It's strange, anyway. Today I sent you an answer with issues ADS said they should have been solved. Unfortunately...

 

Share this post


Link to post
Share on other sites
On 4/27/2020 at 12:40 AM, Chris lund said:

This has a delta of .01 in it's build.    ADS is making changes as they can and getting those out to us.

Or, we can wait 10 times longer for a delta of .1    I am happy for the .01

 

 

Thanks ADS!

 

¢£

This is understood but no excuse for not responding to Bug reports. This is real shame because users will stop sending reports. I hope ADS will do better.

Share this post


Link to post
Share on other sites

My personal experience is I got always a respond on what I send to the support. It doesn’t mean the issue is immediately solved. ADS is doing their best I conclude about their answers. 

Share this post


Link to post
Share on other sites
Posted (edited)

After seeing that you added a minor feature to the underlay function, which is always good, the question raises again:  can we expect any real improvement to the workflow of this tool? This was one of my many unfulfilled expectations for V9, a well working underlay management... The best thing we ever got was the Pylon plugin years ago, but with the discontinuation of it, we never got an alternative to number typing. Right in these days I am again struggeling with lots of image underlays which need to be aligned. Just frustrating.

What I would expect from a professional application is at least that level of functionality: place, scale and rotate with the mose the underly until it is matching, so we can match any imported image in less than a few seconds. Honestly, the current way to type in data by trial and error is something which i would accept 30 years ago.

Sorry for being so harsh, it's just that I still had hopes for FZ9 and expected also other important improvements which I/we requested over years. Not sure if it was even worth the upgrade price at this point. I'm still working with 8.5 because of stability issues on my system. Also, I agree with some other remarks here in the forums. I'm not reporting bugs much more for a longer time already because I have the impression reports are not followed up well since Paul's sad departure.

Edited by 3dworks

Share this post


Link to post
Share on other sites

I would email support directly with bug reports.  They have a ticket tracking system and I have had very good success in reporting and solving many v9 bugs so far.

Share this post


Link to post
Share on other sites
On 4/28/2020 at 6:56 AM, Tech said:

This is simply not true. Many of the issues that you reported have been addressed. Most of the other issues we could not reproduce. Sorry it took longer than normal to answer your email but please understand that we are all working in less than ideal circumstances these days! You did receive a response today.

 
hello
Can you confirm that the malfunctions on the list below that I posted on March 30, 2020 have been corrected?
sorry but here this not the case !
Naturally I understand very well that the current circumstances do not allow working in good conditions.
But I assure you that for me the reported bugs are still present ...
But if you want I am ready to check them one by one with you
It will be the best solution to find out.
Let's go ?
 
*************************************************************************
 

FORMZ Draft Layout

 

PREFERENCES

 

1-Preferences > keep list tighly spaced does not work

 

2-Preferences > formz classic layout does not work

 

3-Preferences > all options in interface/palettes/list palette are not saved in the preference file

 

PALETTES (interface)

 

4-The following palettes cannot be detached from the dock by default:
action
inputs
projects
They close instead of coming off
the command "close" by right click does nothing

 

5- Grid settings are not stored correctly between session

(at what level is this parameter stored? preference project? )

 

6- colors palettes

6.1 impossible to delete colors

6.2 in the menu “colors... top bottom sort purge” item does not works

 

line weight palette

7-line weight management palette is missing (no item in the line weight palette)

no way to reorganise the line weight

 

weight palette

8- first line weight is lock off (ok)

(but also all of its parameters)

 

9- Status bar top : “move dock down” does not work

status bar bottom : “move dock up” does not work

 

 

PROJECT SETTINGS

 

10-project settings appearance

displays colors : Axis Lines is missing

 

11- project settings appearance

X Y Z indicators are not displayed in the viewport

 

12- Layers

following options are missing :

Draw Active Last

Draw in order shown (is the draw in layer order in display option?)

(also in the menu in the palette layer)

 

 

 

13-it is not possible to set the number of decimal places lower than the numeric accuracy
(number of decimal places always corresponds at least to numeric accuracy)

the reverse is possible when it is useless

 

WORKSPACE

 

14-after the creation of a new workspace and the modifications in the interface; in the workspace menu, the new item is grayed out as well as the option "update default"

 

************************************************************* 

Share this post


Link to post
Share on other sites

1: work

2: work

3: work

4: work

5: work

6.1: work

6.2: work

7: work... to reorganize the line type you have to rename and re sort them

8: yes, like always

9: both work

10 & 11: you can change the colors of the axis lines

12: yes

13: in my memory, it's always been like that... I use 6 for both, decimal accuracy and decimal places, without including trailing zeros… the only problem that I have with that is that I can't use anymore 6 decimals in the angle acuracy, the maximun is 4 but it's ok

14: I use my own customized workspace for modeling and it work great for me

Best, Marcelo

 

image 1.jpg

image 2.jpg

image 3.jpg

Share this post


Link to post
Share on other sites
On 5/6/2020 at 3:20 PM, jldaureil said:
Can you confirm that the malfunctions on the list below that I posted on March 30, 2020 have been corrected?
 

You emailed this same list to the support team and we answered you on Apr 27 (@13:08 EST) via email. In our answer we detailed what has been fixed and asked for clarification on a few of the issues. We have not received a response from you to our email. 

ZTEK thank you for your detailed response which is in essence  is the same as our emailed response to the questions.  

Share this post


Link to post
Share on other sites

Tech and Ztek

I found the email

I RUN WIN 10

latest built

I don't understand the first sentence of this answer:

"In the new release, 9.0.3, a majority of these issues have been resolved. Unfortunately it appears that your current operating systems do not support version 9. Our system requirements state that version 9 can run only on Windows 7, 8, and 10, so it is possible that you may have some hiccups due to compatibility:"
 

Is FormZ 9 incompatible with my version of windows 10?

"1) Keep List Tightly Spaced is working at default text size (10-11), but increasing the font size will cause some overlap. I have a ticket open for this issue."

image.thumb.png.962f8c3c5db536b7c5febcc0934258c2.png

image.png.9d628abe18ef99096759a4ce33df9ab5.png

As you can see

1-Preferences > keep list tighly spaced does not work

2-Preferences > formz classic layout on or off same result

Brandon "2) The formZ Classic Layout is working properly. If this is still an issue on your machine it's possible it may be due to the OS incompatibility. If you do still see issues, let me know and I will try to diagnose them".

WIN 10 recent

 

3-Preferences > all options in interface/palettes/list palette are not saved in the preference file

Brandon 3) All preferences should save to the preference file now. If yours is having any issues, check in the General section to see if you have Do Not Save Preference File enabled.

image.png.7c3eac382d77ef8b32ea65b3ee570b55.png

 

PALETTES (interface)

 

4-The following palettes cannot be detached from the dock by default:
action
inputs
projects
They close instead of coming off
the command "close" by right click does nothing

Brandon 4) Palettes no longer disappear when removed from the dock.

Sorry here the case !

 

5- Grid settings are not stored correctly between session

Brandon5) Grid settings are saved in the project. There was an issue with the grid size being stuck at a certain size but that has since been fixed. If you want to set a default grid size for all future projects, you can do so by creating a Template file with your preferred grid size then plug that file into the Project section of your Preferences.

OK !!!!

 

6- colors palettes

6.1 impossible to delete colors

6.2 in the menu “colors... top bottom sort purge” item does not works

Sorry but it still doesn't work here

image.thumb.png.06fc536acf2b5492d8b91afeddb7075f.png

brandon 6) In the Color palette, you can override colors by clicking the color box where you want your custom color stored, then setting the color you want and clicking the Add to Custom Colors button. Unless you mean Materials, which can be deleted, sorted, purged okay now. You should no longer have issues with the Materials palette, but the Color palette might not have full functionality due to the OS.

OS is  WIN 10 !! and that dosen't works

 

7: work... to reorganize the line type you have to rename and re sort them

pfff

8- works (not like always ztek)

 

9- Tool dock and Status bar top : “move dock down” does not work

status bar bottom : “move dock up” works now

brandon 9) Move Up/Down on the Status Bar works okay now. If it's not working, it may be tied to the OS incompatibility. 

OS is  WIN 10 !! and that dosen't works

 

10-project settings appearance

 

brandon 10) The axis color indicators can be found in File > Project Settings, Appearance > Display Colors. Is this what you're referring to?

ztek

have you read

"FORMZ Draft Layout"

your screen shot is the modeler interface !!

 

11- project settings appearance

X Y Z indicators are not displayed in the viewport

Sorry but it still doesn't work here (as you can see :

image.thumb.png.839166e6c8e90bc7b7accf685c131e97.png

 

12- Layers

following options are always missing :

Draw Active Last

Draw in order shown (is the draw in layer order in display option?)

(also in the menu in the palette layer)

brandon 12) Are these v.6 settings that you say are missing? [YES] I believe these have been worked into the Layers palette. What is it that you're trying got accomplish with these settings?

precise display of layers one above the other (decisive for displaying vector lines over images

 

13

Brandon13) There was an issue with the numeric accuracy that has been fixed.

NOT here.....

Ztek

Oh no
in v6 used daily here you can set the accuracy to 10 power -16 and display only 2 digits after the decimal point
In v9 it's not possible if you put 0.0001 da, s the accuracy you must have 4 in number of decimal places

 

image.thumb.png.f0e3ec50d40bf8648b1aa61e1c876094.png

 

 

14: I use my own customized workspace for modeling and it work great for me

 ztek  : again DRAFTING ...

14) The Workspaces are now working well and you should have no issues. If you have a custom workspace active, you will be able to Update Default. But if you have one of the default Workspaces active then the Update Default option will be greyed out.

If I can work around the dock problem (point 9) I will try to build an interface close to the one I have been using for 10 years and I will tell you if point 14 is set

 

 

 

image.png

image.png

Share this post


Link to post
Share on other sites

Hi

Ztek

Do you understand that we are talking about Formz 9 Draft layout?

I found the support email

Brandon

"In the new release, 9.0.3, a majority of these issues have been resolved. Unfortunately it appears that your current operating systems do not support version 9. Our system requirements state that version 9 can run only on Windows 7, 8, and 10, so it is possible that you may have some hiccups due to compatibility"

I don't understand why Formz9 should be incompatible with my system
Is Formz 9 not WIN 10 compatible?

1.png.8e4c033f03f61f6e1b1d6524af02d14f.png

2.png.3eccad62b8b611f49c25d68df4519180.png

 

FORMZ Draft Layout

 

PREFERENCES

 

1-Preferences > keep list tighly spaced does not work

Sorry but as you can see it still doesn't work

 

2-Preferences > formz classic layout does not work

Sorry but as you can see it still doesn't work

 

Point 3

Brandon / All preferences should save to the preference file now. If yours is having any issues, check in the General section to see if you have Do Not Save Preference File enabled.

I will test in more depth
but I have an active preference file

 

 

Share this post


Link to post
Share on other sites

4-The following palettes cannot be detached from the dock by default:
action
inputs
projects
They close instead of coming off
the command "close" by right click does nothing

Brandon 4) Palettes no longer disappear when removed from the dock

Sorry but here
action input projects pallets cannot be detached from the dock containing them

they close

 

Share this post


Link to post
Share on other sites

5- Grid settings are not stored correctly between session

(at what level is this parameter stored? preference project? )

 

Ok that works if correctly stored in the template

solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×