Jump to content
AutoDesSys Forums
Tech

formZ 6.7.3 "Hot Fix" for OS X 10.13 High Sierra

Recommended Posts

It appears that Apple dropped support for certain formats of legacy bitmap graphics in OS X 10.13 High Sierra. form•Z 6 uses this format for some of its palette graphics. To fix this you will need to replace the resource file in your current installation with a new one that contains updated graphics that are supported by OS X 10.13. 

 

Please follow these Steps:

 

• Be sure that you have form•Z 6.7.3 installed. This fix will only work for form•Z 6.7.3. If you don't have it, you can download it here:  http://www.formz.com/products/formz/update/formz_6_Upgrade_Professional.html
• Download "formZ_RenderZone_Plus.rsrc.zip" below if you have a form•Z RenderZone Plus installation or "formZ.rsrc.zip" if you have a regular form•Z installation. If necessary, extract the zip file. You should now have a file named “formZ RenderZone Plus.rsrc” or "formZ.rsrc".
• Locate your formZ 6.7.3 Application folder (Usually in Applications/formZ/)
• Right-click on the "formZ RenderZone Plus" or "formZ" application icon and select "Show Package Contents" from the menu.
• Open the "Contents" Folder.
• Open the "Resources" Folder.
• Replace resource file in the "Resources" Folder with the one that you downloaded.
• Launch form•Z 6.7.3!

formZ_RenderZone_Plus.rsrc.zip

formZ.rsrc.zip

Share this post


Link to post
Share on other sites

Thanks for the fix, I saw this bug and figured it would be the end of 6.7....

 

Can I request one other fix? Ever since 10.10, the standard pick icon - "+" crosshair - won't change with the background color. I generally work with a dark background, which is tough when the cursor is black. It should switch to white when the background is dark.

 

Not sure if that is a simple resource/icon fix, or a deeper OS thing....

Share this post


Link to post
Share on other sites

Z,

 

I'd like to reinstall V6 but the link above provides access back to V7, "Click Here for updates for versions 6 or earlier." doesn't seem to have a download link, just update instructions.

 

Did I miss it?

 

Thanks,

 

Joe

Share this post


Link to post
Share on other sites

Thanks jsiggia! We have corrected the link in the original post. Its possible that the DVD is damaged or the installer on the DVD is no longer compatible with the OS you have.

Share this post


Link to post
Share on other sites

It worked. I had to go to WIBU's website to find the latest runtime for the key, but I was able to export a 8.6 to a 6.7.3 file and render it perfectly. Now I can access some legacy work and also send some creative work to one of my colleagues.  This is invaluable and I appreciate ADS for doing it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×