Jump to content
AutoDesSys Forums
AsOne

Shaded full shadows through glass

Recommended Posts

I would love to see if the Shaded Full render engine can be updated to cast shadows through transparent materials.  

For example currently Shaded Full with the transparent glass layer turned on (Transparency Linear 85%):

1180492912_ScreenShot2020-09-19at4_31_49PM.png.b573e04a22becff81d7c78fdf17a0893.png

 

Shaded Full with glass layer turned off completely:

1066641127_ScreenShot2020-09-19at4_31_43PM.png.b0a21d14ecce40dcb436f13e97d8d572.png

 

It would be great to get the light/shadow quality of the lower image, but through an actual transparent material.  Sometimes rendering it with no glass at all makes it seem a bit too clear.  It presents an unrealistic picture to some clients if the actual glass comes with a tint on the exterior.  

 

If there is a way to do this now with Shaded Full, please let me know.  (I know it can be done with Renderzone or Vray)

Share this post


Link to post
Share on other sites

You can place the glass on a separate layer, use layer override so the layer does not cast shadows but is still visible..

Share this post


Link to post
Share on other sites

Glad it worked for you AsOne.

It would be nice if this could be done at material level while working in Shaded Full.

What would be really cool would be visible reflections on glass/mirror materials.

Des

Edited by Des

Share this post


Link to post
Share on other sites

I think this is technically capable in our OpenGL based Shaded Full mode, but it is not implemented.  OpenGL can also show Self Illumination, but it is also unfortunately not implemented in FormZ.

Our Shaded Full is pretty powerful as is, but it needs some upgrades to be taken to the next level if we are going to compete with other modern 3D packages. 

 

Share this post


Link to post
Share on other sites

Justin,

Self illumination can be achieved by setting the material's reflection to constant. I believe this is default when you use the billboard tool.

Share this post


Link to post
Share on other sites

AsOne, another option to have objects not cast shadows in full shaded as well as in Vray, is to uncheck "cast shadows" under the object's attributes. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×