Jump to content
AutoDesSys Forums
DKellitt

New user of FormZ 7 with a couple of issues, can anyone help?

Recommended Posts

Hi all,

 

I am a relatively new user and am finding a couple of issues which are annoying me and wanted to know if i'm doing something wrong.

 

1. Whenever i'm sizing a shape and I want to type in the exact size, as I type the number, FormZ only picks up say the first one or two numbers then automatically accepts that size. So for example if i wish to type in 2500mm, I click on the box for width, then as i type it in,  FormZ automatically accept on 25 then the remaining inputs of 00 get ignored, and i'm left with an input of 25mm. I know this is a small thing but it happens every time and it is highly irritating.

 

2. I am finding it difficult to center the camera around one specific shape so that I can rotate around that shape. I read somewhere to click center wheel on mouse twice when highlighting shape, but that doesn't seem to work. Can anyone help me with this?

 

Thanks all and look forward to hearing from you

Share this post


Link to post
Share on other sites

Hi DKellitt, welcome to the forum.

Regarding the inputing of sizes, you may have to adjust the sensitivity of your mouse, sometimes if the mouse slightly moves the input changes. I find in the windows version, this seems to happen more often than on my macs.

If that is not the problem, check your working units in Project settings and make sure your data scale and units are suitable for your model size.

Otherwise ADS will help.

 

Regarding the camera, if you select the object you are working on and "fit" (command F on Mac/ctrl F on PC). Then your camera will re-centre to that object. Also, make sure your model is not very far from the origin, sometimes imported data from other apps can be way off the origin, in that case move everything closer to the origin. I usually fit all to screen and "Set Home" in the view menu, then using "shift command H" brings me back to that view, it's kind of a reset.

 

If I haven't hit the right note here, others will probably have a better solution for you.

 

Des

Share this post


Link to post
Share on other sites

Thanks Des. Yes I can see the issue being moue sensitivity, although my mouse isn't set to a high sensitivity it does seem to be the issue that when the mouse moves it effects the value i'm inputting. I will just have to make sure the mouse is completely still when inputting values!  and thanks for the answer regarding camera rotation that has worked perfectly.

 

I have one other issue I forgot to mention I wonder if you can help me with, or anyone else out there.

 

I am struggling to find a way to precisely cut out an element form another shape. Example: I want to cutout a small circle at 15 radius and 10mm deep from a door shape I have made, to create a handle indent. I want to place the circle centre 200mm from top and 50mm from edge. How do I mark this point so I can add the circle precisely? I have tried using guides but there doesn't seem to be a way of offsetting a guide from edge by a value, which would be useful. I can use offset segment but this creates a line which I don't want and can't seem to get rid of once i've created.

 

thanks again for your help!

Share this post


Link to post
Share on other sites

Hi DKellitt,

 

Yes, Welcome to the forum!

 

1.  formZ v7 did have an issue on certain systems where the Tool Tips could cause the numeric input to "auto-complete."  This was fixed quite awhile ago, but if you only have v7, you can avoid this problem by going into the Preferences: Interface -- and setting a longer delay for the tool tip (perhaps 5-9 seconds).  We have found a case where the Reshape and Offset tools can still have this issue, and this will be fixed for the future.

 

3.  When you offset a segment, you can check a box to control whether that segment is inserted (or not).  Not inserting will allow it to be deleted easily.  To offset a Guide, use the Move tool.  Or use the Delta (Relative) Input Method.  From the Migration Guide:

 

Pressing the F4 key will automatically set the location of the curser to 0,0,0, and switch the input mode to 3D Delta, which makes relative transformations quick and easy. Also, when drawing vector lines, you can just move the cursor in the desired direction and enter the distance if you want. If you Tab to the next field,

this value will be “locked” and you can then move the cursor around the screen 

 

If you are new to formZ 7 or 8 but are familiar with earlier versions (or perhaps even if you are not), the Migration Guide will have lots of useful information for you.  I would highly recommend studying this for at least a few hours, as described in this post:

 

http://forums.formz.com/index.php?/topic/19-formz-v7-8-migration-guide-interface-improvements-from-formz-6/

 

And these Tips and Tricks can also be helpful learning some of the many useful features of the current versions:

 

http://forums.formz.com/index.php?/topic/1994-formz-tips-and-tricks-page-released/

 

Please let us know if you have any further questions, we would be glad to help!

 

Share this post


Link to post
Share on other sites

D Kellitt.

 

Late additional response for future ref. To place your circle precisely, you could as suggested use guides, or you could first draw a sacrificial rectangle for snapping-to purposes, or another way, snap your circle or cylinder to a corner of your door, then move it afterwards along an orthogonal automatic guide, assuming the door is already orthogonally placed, by first clicking anywhere empty on screen, but not too far from the origin, dragging the cursor a little in the general direction, looking out for the red blue or green guide which should appear, keeping in line with it, and typing the distance for the (self only) move, and hit Enter. The last suggestion may be quickest, you may need to select referenceplane and lock it first if not already set. Isolate objects if the work area is too busy.

Share this post


Link to post
Share on other sites

Thanks everyone for your replies. I'm finding the amount of support received through this forum a massive surprise, really thank you all for taking the time to help me. Yes setting the interface to longer delays has sorted my auto-complete issue and I didn't realize you could move the guides! doh!! haha great that's sorted that issue out. Thanks again to everyone :)

Share this post


Link to post
Share on other sites

"1.  formZ v7 did have an issue on certain systems where the Tool Tips could cause the numeric input to "auto-complete."  This was fixed quite awhile ago, but if you only have v7, you can avoid this problem by going into the Preferences: Interface -- and setting a longer delay for the tool tip (perhaps 5-9 seconds)."

 

sorry tech,

 

but i am working with version 8.0.2 and still have the same issues  with the input.

And changing the delay for tooltips works, but i dont know why i have to change it again  every time when I open formZ. (save preferences at quit option is chosen)

 

best regards,

thorsten

 

 

Share this post


Link to post
Share on other sites

"1.  formZ v7 did have an issue on certain systems where the Tool Tips could cause the numeric input to "auto-complete."  This was fixed quite awhile ago, but if you only have v7, you can avoid this problem by going into the Preferences: Interface -- and setting a longer delay for the tool tip (perhaps 5-9 seconds)."

 

sorry tech,

 

but i am working with version 8.0.2 and still have the same issues  with the input.

And changing the delay for tooltips works, but i dont know why i have to change it again  every time when I open formZ. (save preferences at quit option is chosen)

 

best regards,

thorsten

 

Yes, I have to agree that it's not resolved completely.  I'm on 8.5.0.1 with the delay set to 10 seconds, and it still occurs.  It's happened across 2 computers - laptop/desktop, different versions, I switched the keyboard on the desktop to a mechanical keyboard - just in case (and I wanted one).  It didn't help.

 

formZ is the ONLY software installed that has this issue, and it makes keying in difficult, most times needing multiple attempts to achieve the required result.  Turning off the 'Interface - Show tips option' still doesn't correct the problem.

 

John

 

 

Edited by wjo53

Share this post


Link to post
Share on other sites

Hi John & Thorsten,

 

Ok, yes, as noted above, this was fixed for the majority of cases, but we have found some computers where the Reshape and Offset tools can still have this issue, so we will get this corrected.

 

Hi DKellit,

 

Great, glad to help!   ;)

Share this post


Link to post
Share on other sites

Hi John & Thorsten,

 

Yes, as noted above, we have identified an issue on some computers with Reshape or Offset.  (Setting a longer delay in the Preferences: Interface: Tool Tip (perhaps to 8 or 9) will help avoid this for now.)  

 

And as noted, we will get this corrected.  

 

Are there any other tools or actions where you encounter this?  If so, please let us know as this will need to be solved on a "case by case" basis...

Share this post


Link to post
Share on other sites

Thanks everyone for your replies. I'm finding the amount of support received through this forum a massive surprise, really thank you all for taking the time to help me. Yes setting the interface to longer delays has sorted my auto-complete issue and I didn't realize you could move the guides! doh!! haha great that's sorted that issue out. Thanks again to everyone :)

 

 

Hi, 

 

Even though I have been a member on here for a while unfortunately I only get to work in Form Z a few days in each month.

This is a fab forum and everyone is always friendly and helpful - I always have what seem to be silly questions yet no one loses their patience with me  :)

 

Sammi

Share this post


Link to post
Share on other sites

Hi John & Thorsten,

 

We have been investigating this and we did find one computer where this worked fine with moving and drawing but could occur with Reshape or Offset.  Thanks for bringing this to our attention, we will get this corrected.  Are there any other tools or actions where you encounter this?

 

If so, please let us know as this will need to be solved on a "case by case" basis...

 

I'm not on it right now, but IIRC, it's most prevalent with reshaping.  Not able to test other things at present.

 

I do hope it's resolvable, it has been responsible for causing me to string many many bad words together one right after the other.  :-)

 

Thanks in advance for your efforts,

 

John

Share this post


Link to post
Share on other sites

Hi John,

 

Ok, thanks for the feedback.  If you just string a few nice words our way indicating the issue, we can do something about it -- and now we will...

Share this post


Link to post
Share on other sites

I just checked, I get it on Reshape, and Offset segment.

 

When it happens, there's a distance readout that shows up below the cursor location.  If it's going to happen, that readout will flicker - once or twice.  After the second time, you can type numbers and not have an issue, but if you start typing before those flickers, that's when it acts up.  Don't know if that makes sense, but that's what happens here,

 

John

 

Share this post


Link to post
Share on other sites

Hi John & Thorsten,

 

We have been investigating this and we did find one computer where this worked fine with moving and drawing but could occur with Reshape or Offset.  (Setting a longer delay in the Preferences: Interface: Tool Tip (perhaps to 8 or 9) will help avoid this for now.)  

 

Thanks for bringing this to our attention, we will get this corrected.  Are there any other tools or actions where you encounter this?  If so, please let us know as this will need to be solved on a "case by case" basis...

 

Ok, thanks for confirming it is only those two tools.  Did the "work around" noted above help?

Share this post


Link to post
Share on other sites

Ok, thanks for confirming it is only those two tools.  Did the "work around" noted above help?

 

I can't say that it's ONLY those two tools (Reshape, Offset (both Outline and Segment), they're just the ones where it's occurance has been most annoying. 

 

As noted in an earlier post above, No, the workaround doesn't do it for me.  It still occurs with the delay set to 10 secs, or turned off completely.  It occurs on the two computers I run it on (desktop, and laptop), making it surprising that it's not affecting more people than the few who responded.

 

John

Share this post


Link to post
Share on other sites

Dear John,

 

If this issue is occurring on your computer, it WILL still affect it if you turn off the Tool Tips.  IF you set the Delay to 8 or 9 seconds, the problem should not occur unless you take more than 8 or 9 seconds to type your desired distance.  Are you seeing something different?

Share this post


Link to post
Share on other sites

I can't say that it's ONLY those two tools (Reshape, Offset (both Outline and Segment), they're just the ones where it's occurance has been most annoying. 

 

As noted in an earlier post above, No, the workaround doesn't do it for me.  It still occurs with the delay set to 10 secs, or turned off completely.  It occurs on the two computers I run it on (desktop, and laptop), making it surprising that it's not affecting more people than the few who responded.

 

John

 

Happens on my Acer computer, the Dell is ok and so was the HP before I replaced it with the Dell. Especially happens if I am imputting a negative value, the negative mark tends to need to be typed twice.

Share this post


Link to post
Share on other sites

Happens on my Acer computer, the Dell is ok and so was the HP before I replaced it with the Dell. Especially happens if I am imputting a negative value, the negative mark tends to need to be typed twice.

 

Hi Alan,

 

To what do you have your Tool Tip: Delay set for the Acer?

Share this post


Link to post
Share on other sites

1 second manifests the problem, 4 seconds overcomes it but 1 second seems more appropriate for tootips. Just tried again, nothing else going on on the computer, other than normal background things like webroot protection, empty model other than the cube I am reshaping. When first input is the negative sign it reliably needs second input, ordinary positive first digits vary between success and not, about 50/50, partly depending upon how quick the input is. I always use custom shortcut [P, as in sketchup push-pull] to activate the reshape command. Sometimes the first digit gets missed, other times the first 2 digits are missed. The box shows the first digit or 2, flashes, turns blue and it is hit and miss what might turn up in the blue box.

 

I use the I [as in 'eye'] key to activate the offset segment tool. That manifests the same problem just as badly, except rarely starting with a negative input of course.

 

The most reliable work-around for me is to input the negative sign as first digit every time, which always fails, but creates an empty blue box for whatever next digit, whether it is another negative for a negative number or normal positive number.

 

It ought to be fixed really because both tools are some of the most commonly used in FormZ.

Edited by Alan Cooper

Share this post


Link to post
Share on other sites

When I say 'The most reliable work-around for me is to input the negative sign as first digit every time, which always fails, but creates an empty blue box for whatever next digit, whether it is another negative for a negative number or normal positive number.' I mean when using the reshape tool, not the offset segment tool. Sometimes negative first input for the offset segment tool actually sticks.

Share this post


Link to post
Share on other sites

Alan,

 

Do you have that behavior if you enter 8 for the tool tip delay, and enter your numbers with less than 8 seconds between each one?

 

And yes, as we have noted above 3 times, this will be fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×