Jump to content
AutoDesSys Forums

Recommended Posts

I just upgraded my computer and I now have a 4K monitor. I think it'd be cool if formZ could make a 4K UI.

 

In the mean time could anyone help me find out if it's possible to have 4K on the main work window while still retaining Window's scale?

I know it's possible for programs to bypass the scaling by right clicking the launch icon and selecting the "Disable display scaling" under the compatibility tab. However that makes every icon unreadable so I'm just interested on the main work window.

Share this post


Link to post
Share on other sites

Nope, it doesn't help but thank you.  As I said on my first post: "I'm just interested on the main work window". Everything else is actually scaled by Windows (+125% in my case). It'd be great to have 4K with no scaling on the modeling window while still having +125% on everything else to make things readable.

I'm glad to hear that formZ will take 4K monitors into account for the UI design. 

Share this post


Link to post
Share on other sites

Hello Asone, I do beleive it's worth it but it's not without it's flaws. In the end is all about the software and some programs haven't bumped up the resolution yet. However 4K is not the future anymore -- 4K is here and now with Windows 10 UI scale settings you can fix the problem of tiny interface elements, making them appear larger but still sharper than they’d look on a lower-resolution display. For the extra detail that you get on pictures and video it's totally worth it but you need to fine-tune your software to be able to work with it. I am really hoping that formZ develops a 4K UI sometime soon so that I can profit from this upgrade.

 

I wouldn't go back to my 1980x1200 monitor if that helps.

Share this post


Link to post
Share on other sites

FormZ high dpi scaling ;-(

Takes long long time to solve this huge problem.

Take a look at open source programs like blender and gimp the look great on 4K monitor.

Even SketchUp is better. The biggest problem is the formZ cursor (completely invisible) you need a lot

of imagination while drawing thats for sure.

my monitor 3840x2160 by the way.

post-16528-0-30434100-1450585479_thumb.jpg

Edited by Pedro

Share this post


Link to post
Share on other sites

While I'm not a fan of the 4k for workstation movement just yet, mostly due to poor interface scaling in OSX, and not wanting to sit inches from the screen ( I like to spread out on my (3) 1920x1200 24" monitors )... I have helped several other FormZ users work through the weird interface issues with FormZ... All palettes still should be able to snap together and stay put on relaunch... but that's another thread. :/

 

There's an option under "Window" called Extended Cursor.  This can be used to increase the visible cursor size, but it can really slow down the cursor movement in some cases.  Your experience may vary...

Share this post


Link to post
Share on other sites

There's an option under "Window" called Extended Cursor.  This can be used to increase the visible cursor size, but it can really slow down the cursor movement in some cases.  Your experience may vary...

 

I personally prefer to scale the whole UI using Windows 10.

 

I'm really excited about formZ working on a real 4K UI and hope to see some changes on the next update including the palette-snap option. 

Share this post


Link to post
Share on other sites

We have just added a new preference option for the size of the cursor for higher resolution displays.  Please update to v8.5.3 as discussed in the link below to add this option:

 

http://forums.formz.com/index.php?/topic/3518-form•z-853-update-released/?p=11733

 

(More will be added to the interface in the future, but this should fix the major issue...)

Share this post


Link to post
Share on other sites

Hi Andre,

 

Is it automatically using the larger cursor?

 

If not, if you Quit formZ, go to USER: App Data: Roaming -- and rename the autodessys folder, does it then use the larger cursor when you relaunch?

Share this post


Link to post
Share on other sites

It's not using the larger cursor automatically. I renamed the old autodessys forlder to "autodessys old" and relaunched formZ. It created a new folder and everything went back to stock but the option is still grayed out.

Share this post


Link to post
Share on other sites

Hmmm.  Ok, please send an email to support@formz.com and include information regarding your system, your video card and the date of its driver, as well as the resolution of your monitor and any other "4k settings" you have adjusted so we can help...

 

EDIT -- Alternately, there has also been a thread set up with another using having this same issue here:

 

http://forums.formz.com/index.php?/topic/3524-large-cursor-option-dimmed-in-prefs/&do=findComment&comment=11794

Share this post


Link to post
Share on other sites

Great, glad that worked for you.  We will have to run some more tests with the online patches to see if we can determine that didn't give you the cursor options...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×