Jump to content
AutoDesSys Forums
rmulley

Transparency in front of reflective surface issue

Recommended Posts

So this has driving a bit crazy because I work like this quite often.

Is I place a transparency map in front of a non-reflective surface it's fine, but as soon as I make that rear surface reflective the transparent parts of the front material changes whats behind it

the transparency map is definitely solid black because you can't see it when the rear material isn't transparent.

Anyone have a work around for this ?

Screen Shot 2020-03-19 at 5.01.27 PM.png

Screen Shot 2020-03-19 at 5.02.09 PM.png

Share this post


Link to post
Share on other sites
50 minutes ago, Justin Montoya said:

Have you tried to turn off shadow casting for the plane object that has the transparency map?

I have yes, still the same

Share this post


Link to post
Share on other sites

That should work. 

I'm curious of your V-Ray settings then.

I suspect you may have come across a transparency map bug.  Are you using the Use GPU option? If so, Try turning that off and see if it has a different result.  I have had them stop working for me when the Use GPU option is turned on.

Share this post


Link to post
Share on other sites

That's sounding familiar, Dome light or GI settings..  Wait where did the rest of your message go?

Try this, go into the V-ray raytrace settings and boost the min number of recursive rays to 6 or 8 or more.  The default is 5 I believe and that isn't high enough for many reflections in scenes.  

Does that help?

Share this post


Link to post
Share on other sites
9 hours ago, Justin Montoya said:

That's sounding familiar, Dome light or GI settings..  Wait where did the rest of your message go?

 

haha, I thought I solved it by turning off the dome light.... then I realized I still had the reflection turned down on the material. Once I realized I deleted my post.

I'll try the recursive rays idea.  Thanks.

Share this post


Link to post
Share on other sites

Recursive rays didn't help. However, I think I hit on something.  Not sure where it came from but I had a feeling it might be something to do with face normals. I rotated the plane around and lo and behold the problem disappears....

 

Screen Shot 2020-03-20 at 9.15.18 AM.png

Share this post


Link to post
Share on other sites

Here it is with the texture map rotated 180 degrees.

For the record the face normal is facing backwards towards the rear part.

Screen Shot 2020-03-20 at 9.18.26 AM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×