Jump to content


Photo

8.5.x kill FSL?

sdk fsl python dreaming pleading begging frustrated lonely hermit

  • Please log in to reply
6 replies to this topic

#1 Chris lund

Chris lund

    Advanced Member

  • Members
  • PipPipPip
  • 567 posts
  • LocationWestcliffe Colorado

Posted 04 April 2016 - 08:49 PM

Got tired of waiting for the new SDK/API set for 8.x+

 

thought to at least workout some algorithms, and get my head around the process again, since it has been 8 or 9 years.

 

Albeit, it would be preferable just jumping into Python (as that has uses elsewhere)  rather than re-learn FSL.

 

HOWEVER, can't get any of the scripts (any Scripts, not just mine) to load into 8.5.3

 

Thought it was stated here that the 7.x  SDK would still work.   ???

 

 

Funny thing though,  loaded the 7.0 SDK,  and the script editor still says it is 6.7.x   All documents note that they are 6.x or older.

 

Is the link bad, or does 8.x?.x?  kill FSL?

 

Thanks!


Edited by Chris lund, 04 April 2016 - 08:52 PM.

  • ritawex likes this

Christopher Lund

Neurascenic - Industrial Design


#2 Chris lund

Chris lund

    Advanced Member

  • Members
  • PipPipPip
  • 567 posts
  • LocationWestcliffe Colorado

Posted 06 April 2016 - 05:50 PM

???


Christopher Lund

Neurascenic - Industrial Design


#3 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 06 April 2016 - 09:06 PM

Chris,

 

Any scripts for formZ 7 and earlier will be 32 bit so they will need to be upgraded to work with the 64 bit version of formZ 8 and later.

 

Also, the program will need to be upgraded to support scripting, and that will happen in the future.



#4 Chris lund

Chris lund

    Advanced Member

  • Members
  • PipPipPip
  • 567 posts
  • LocationWestcliffe Colorado

Posted 07 April 2016 - 12:43 AM

http://forums.formz....being-released/


Christopher Lund

Neurascenic - Industrial Design


#5 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 07 April 2016 - 06:59 AM

Hi Chris,

Sorry for the delay / confusion.  The SDK beta has been available for awhile now -- but you have started a lot of different threads, so you may have missed or forgotten our reply where you can download this here:
 

http://forums.formz....ins/#entry12861

 

Was that what you needed?



#6 Chris lund

Chris lund

    Advanced Member

  • Members
  • PipPipPip
  • 567 posts
  • LocationWestcliffe Colorado

Posted 07 April 2016 - 03:37 PM

I don't think the beta has scripting, as I did download it.


Christopher Lund

Neurascenic - Industrial Design


#7 jwiede

jwiede

    Member

  • Members
  • PipPip
  • 14 posts

Posted 19 June 2016 - 05:49 AM

There seems to be a clarification needed about precisely what does and does not work in the SDK provided.  The previous "SDK" included both scripting and API-level bindings for the app, so it isn't so surprising that folks seeking scripting expect the SDK to contain that functionality.

 

For the record, while I'm interested in API-level access and plugin development, as a hobbyist user I definitely am also more than a bit disappointed that after so long we still have no scripting functionality.  Witnessing both Rhino and MoI3D users adding visual dev environments on top of their extensive scripting environments hasn't improved my feelings.  Autodessys need to hurry up the process of re-enabling scripting -- at the current rate of progress, by the time Form-Z again supports regular scripting, the others will sport user-to-app direct neural interfaces.

 

1/2  ;) but 1/2  :o too.


Edited by jwiede, 19 June 2016 - 05:51 AM.

  • Chris lund likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users