Jump to content


Photo

model issues


  • Please log in to reply
14 replies to this topic

#1 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 16 June 2015 - 03:29 PM

I have been struggling with a new model that a client sent to me.  I would love to use Maxwell to render it out but I can not seem to get it to render at a decent speed even in Fire.  It is a 128 meg file that I have tried to clean up as best as possible but Fire takes about 20 minutes to render a snapshot.  Simple materials (best possible match) and one simple Sky Dome light.  That image is cropped oddly as well.  FYI I am using Dual 2.6  Xeon 10 core processors with 64 megs of ram and a good video card.  Form.z 8.5 beta pro using the latest driver from this morning.  I also found that Form.z 8.0.2 is considerably faster but still way too slow.  What would be the best way to send this file to you to see if it is corrupted somehow?

I need to figure this out so that I can work with this client on a regular basis as all their models will be created in this way.


  • 7635nrksaM, RichardKep and Jeremyhady like this

#2 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 16 June 2015 - 03:32 PM

Hi Andrew,

 

You can use Dropbox, Transmit, or many other programs to send large files.  If you have an issue that does not involve Maxwell Render (the file is slower in v8.5 than 8.0), please send a link to the file to support@formz.com.  

 

Pylon can let you know what they need to diagnose the Maxwell Part...



#3 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 16 June 2015 - 03:39 PM

I was just trying to send it to Pylon but I will send it to you as well so that you can confirm the speed issues between 8 and 8.5. 



#4 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 16 June 2015 - 04:11 PM

Here is a link to the file for Pylon to evaluate.  Please note the render time in Fire to see the issue.

https://www.hightail...qQ0NGOFExZXNUQw

Just paste that into your browser.



#5 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 16 June 2015 - 05:12 PM

I moved the light in your file so it faced the front, set the exposure to the "Bright Exterior" preset (Maxwell Display Options, Camera Tab), and set all the materials to use the Matte Autotranslate Shaded. (You can switch that in each material, or set all at once using the "All Material Hints Matte" button found in Extensions> Maxwell Render> Project Settings)

 

formZ 8.5 beta 2, Maxwell 3.1.1.0, Maxwell for formZ plugin 3.1.1.6

 

This is a HD-size rendering, rendered for exactly 1 minute in Maxwell, on a machine with a 64-bit multicore geekbench score of about 16500:

west.png

 

In plugin Fire, it took about 10 seconds to translate the file, another 10 to voxelize, and it got to SL 12 after 49 seconds had elapsed (with the default resolution).

 

If Fire preferences, is Fire is set to use 0 threads? This will force maximum rendering efficiency. http://support.nextl...pageId=16810298

 

If the changes suggested above do not help, can you post a version of the file set up exactly as you would like it that exhibits the 'slowness' issue you are describing?

 

Also- you did not provide the image map textures used in your file, so this rendering used the smaller maps embedded in your formZ project. If you provide another project, please include the image maps as well.



#6 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 16 June 2015 - 07:21 PM

I set it up exactly as you had and my computer spent 4 minutes to get to a voxelization of 2% through Fire.  It would take over an hour to get a Fire snapshot.   my geekbench score is 2973 for the single core and 34069 for multicore. 

Here is a link to the model again. https://www.hightail...vWlRRR2NFSzhUQw

 



#7 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 17 June 2015 - 07:45 AM

Hi Andrew,

 

Ok, so the only issues are with the speed of Maxwell Fire?  (If so perhaps Pylon can help with that.)

 

There are LOTS of problems with the geometry in this file (like zero area faces, duplicate points, etc), many of which can be fixed with the Object Doctor automatically.  Perhaps fixing those problems will help the Maxwell Fire performance?



#8 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 17 June 2015 - 09:00 AM

Adrew,

 

We are still not having any problems rendering your file in Fire. In plugin Fire, it took about 10 seconds to translate the file, another 10 to voxelize, and it got to SL 12 after 49 seconds had elapsed (with the default resolution).

 

Is "Resolution" set to the default 320 in Fire Preferences? Set it to 320 is it is not already.

 

Please attempt you render again with the project file you posted on hightail. Do not use another project which may have any additional geometry, even if layers, etc. are turned off. (It looks like you did a save-a-copy with your example, perhaps only saving some of the geometry from a large file.) Then, attempt to to render in Fire, time each step. Turn off fire, then go to the Maxwell Log, save it and send it so we can see if we can help further.

 

The cropping in the Maxwell rendering differs from the modeling viewport because you are approximating a 2D Perspective view, using the Approximate '2D Perspective' Views feature. When enabled, formZ "2D Perspective" views will be approximated using Maxwell's Shift Lens. Due to inherent differences between "2D Perspective" and "Shift Lens," this does not provide an identical match, but rather a starting point for cropping, which can be readily refined in Fire. ( http://support.nextl...pageId=16810286 )

 

For exact view matches, use 3D Perspective views, axonometric, or orthographic projections.



#9 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 17 June 2015 - 11:53 AM

I used the same file that I posted.  Fire resolution was set to 320.  I went in and used the object doctor on a lot of geometry to clean it up some.  I also fixed the perspective view to 3 point. 

Here are my times:

Translate file: 65 seconds

Voxilization: 31 minutes

Rendering to SL 17: 90 seconds.

Attached is the log

Attached Files



#10 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 17 June 2015 - 12:59 PM

(The log reports that your translate step was 23 seconds.)

 

I just tested your file on the closest system we have to yours-- Windows 7 64 bit, geekbench 3440 single-core 64-bit/ 14300 multi-core 64-bit-- with the same versions of all programs involved. Here is the result:

 

Translate file: 19 seconds

Voxelization: 15 seconds

Rendering to SL 10: 117 seconds

 

Try closing other apps so there is plenty of RAM available for the voxelization step. (How much RAM is available?)

 

Try moving your formZ project and dependencies to the C: drive and render again. Please report back if this helps.

 

In your task manager, are there other processes hogging the processor? You are not rendering other things in the background?

 

Try disabling virus protection and rendering again. Any difference?

 

If you render in Maxwell, does voxelization also take a long time on your computer?

 

 



#11 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 17 June 2015 - 04:49 PM

I moved it to the C drive and the voxilization went from 30 minutes down to 95 seconds.  Translate was 20 seconds.  I also got an SL of 18 in 2.5 minutes.  

My C drive is a SSD. 

I did not have any other programs running and I have 64 gigs of the fastest ram. 

Turning off virus protection and firewall did not have any affect. 
I still feel that the voxelization is not fast enough.  How is it possible that your machine could voxelize it 6 times faster but your single processor geek bench score is only slightly faster.

If I render the image in Maxwell studio the voxelization happens in about 5 seconds so the issue for me seems to be in Fire within Form.z.

On another note when I opened up this file again all my palettes were gone.   I had to reset my workspace once again and reconfigure my screens.   Why does this randomly happen?



#12 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 18 June 2015 - 11:29 AM

Do you have any insight into why Fire would voxelize so much slower on my machine than yours?  Is Fire using only one processor or getting hung up on my video card?  It would be very helpful to use Fire to preview an image without having to launch Maxwell.



#13 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 18 June 2015 - 12:52 PM

Voxelization is single threaded. Your video card is not involved.The rest of the render is multithreaded and will use all cores.

It sounds like moving your project to your C drive has helped significantly, so it would make sense to continue your work there. Is the D drive a network drive?



#14 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 18 June 2015 - 06:07 PM

Voxelization is single threaded. Your video card is not involved.The rest of the render is multithreaded and will use all cores.

It sounds like moving your project to your C drive has helped significantly, so it would make sense to continue your work there. Is the D drive a network drive?

 

Moving it to C helped a lot but I am not sure why.  It is my primary boot drive and is a 500 GB SSD.  My D drive is shared on my home network as a 10,000 rpm 3 TB storage drive for all my files.  I just don't understand why that would matter if I have 64 GB of Ram that the program and model should load into. 
As for Voxelization I have tried the same model on a faster single threaded machine (3.6 quad core  vs dual 2.6 10 core) and it voxelized a bit faster but it  translated a lot slower (73 seconds vs 23 seconds).  

On another note why is there such a long lag time when previewing a maxwell material when it is being translated as best possible match from Form.z?  I have had this issue with both my computers.  At first I thought it was a graphics card issue but my new card is pretty fast.  Waiting 15 seconds for each material preview seems awkward.



#15 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 18 June 2015 - 07:10 PM

The root of all your issues may be that D drive. The drive may be conflicting somehow with the license server (do you have a floating, or node-locked license?), or perhaps Maxwell dependencies are stored there, and there is some unusual latency or drive spin-up issue.

 

As a test, completely disconnect your main computer from the D drive. If possible, physically unplug it so you are 100% certain it is out of the mix. Make sure all programs involved are running off the C drive, and that your test formZ project and all its dependencies are also on the C drive. Use the Resource Manager to make a link to the new dependencies folder location so you don't have to manually re-link any textures of MXMs. (See http://support.nextl...pageId=16810300 )

 

When this is set up, try the render again. This is a very important test in diagnosing your issue, so please follow these instructions to the letter. Hope this helps.

 

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users