Jump to content


Photo

Maxwell freezing when using GPU for calculations


  • Please log in to reply
10 replies to this topic

#1 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 17 August 2017 - 08:41 AM

Hi Pylon,

 

got me new machines for work..

 

Here is my current configuration:

Maxwell for formZ 4.1.0.3 (Win 64) | form·Z® v 8.0.2 (Build 9413) | Windows 8 v 6.2 Build 9200  Intel® Core™ i7-6700 CPU @ 3.40GHz

 

My Graphics component is a Nvidia Quadro M2000 (bought this to speed up rendering by GPU).

 

Maxwell Fire works fine with the GPU option within FormZ.

 

But, when I open Maxwell render, the application freezes almost immediately.

No preview, timer is counting, some 166 hours left for a simple cube.

The only way out is killing Maxwell and FormZ in the task manager.

 

I have allowed FomZ and Maxwell to use the GPU within Nvidia´s settings software.

No other adjustments were done here, all settings as preset.

 

Any suggestions?

 

Thanks in advance,

Dirk.

 


Edited by Suedpol, 17 August 2017 - 08:44 AM.

  • Minaabilk, Kiethwrold and Eleniempob like this

#2 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 17 August 2017 - 09:34 AM

Hi Dirk,

Please update your installation to the latest version of Maxwell (currently 4.1.1.1) and report back if this fixes your issue.



#3 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 17 August 2017 - 09:58 AM

Thanks, Pylon.

I am on version 4.1.1.1 now and am still getting the same result.



#4 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 17 August 2017 - 12:28 PM

Does it work if you switch the engine to CPU?

 

Can you post your simple cube file so we can test here?



#5 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 18 August 2017 - 02:52 AM

CPU works fine.

 

I noticed that with GPU, Maxwell does not even create MXS/MXI files.

I suspect that the graphics card is somehow stressed when Maxwell is invoked.

Maybe some adjustments in the Nvidia driver will help?

 

Will PM as of the "simple cube file".

 

Thanks,

Dirk.



#6 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 18 August 2017 - 08:38 AM

Make sure your Nvidia graphics driver are up to date.

Does the Console in Maxwell show any useful information?

For help resolving this issue, you will need to contact Next Limit support directly. Please submit at support ticket through the Customer Portal: https://portal.nextlimit.com/
Make sure to include your system information, version of Maxwell, and steps to reproduce the problem.

#7 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 18 August 2017 - 09:39 AM

All my drivers are the latest ones.

Also, I installed the additional Nvidia software suggested by Maxwell in the documentation.

 

Console returns:

 

[18/August/2017 16:32:54] >> Info: checking license type 'formz'...
===================== New session opened at 18/August/2017 16:32:54 =====

MAXWELL RENDER (M~R). Engine version 4.1.1.1
© 2004-2015. Licensed to Next Limit Technologies

C:\Program Files\Next Limit\Maxwell Render 4\maxwell.exe -mxs:C:\Dirk\test noview Maxwell\test noview 1.mxs -mxi:C:\Dirk\test noview Maxwell\test noview 1.mxi -o:C:\Dirk\test noview Maxwell\test noview 1.png -licensetype:formz -root:C:\Program Files\Next Limit\Maxwell Render 4

--------------------------------------------------------------------------

//  Private data //

--------------------------------------------------------------------------
SYSTEM INFO
Num processors: ( logical: 8, physical: 8 )
Maxwell Root folder :C:\Program Files\Next Limit\Maxwell Render 4\
This machine Host ID: // Private data //

--------------------------------------------------------------------------
GPU INFO
Graphics Card 0
Name: Quadro M2000
Microarchitecture: Maxwell
Device Memory: 4096 MBytes
CUDA Compute Capability: 52
CUDA Driver Version: 8.0
CUDA Runtime Version: 8.0
Below Normal Priority Enabled

--------------------------------------------------------------------------
Found 5 procedural extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
MaxwellHair
MaxwellParticles
MaxwellVolumetric
MGrassH
MGrassP
Found 6 geometry loader extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
AssetReference
MaxwellMesher
MaxwellSea
MWObjectAlembic
RFMeshes
RWMeshes
Found 4 geometry modifier extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
MaxwellCloner
MaxwellGrass
MaxwellScatter
SubdivisionModifier
Found 12 texture extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
Brick
Checker
Circle
Gradient3
Gradient
Grid
Marble
Noise
Voronoi
MultiPointGradient
TiledTexture
WireframeTexture
Found 9 material modifier extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
AGS
Opaque
Transparent
Metal
Translucent
Car Paint
Hair
TableBrdf
Xrite AxF Material
Found 2 camera lens extensions in C:\Program Files\Next Limit\Maxwell Render 4\extensions-x64-v140
Lat-Long Stereo
Fish Stereo
--------------------------------------------------------------------------


[18/August/2017 16:32:54] Reading MXS:C:\Dirk\test noview Maxwell\test noview 1.mxs
[18/August/2017 16:32:54] MXS file read successfully

[18/August/2017 16:32:54] fromCommandLineArgumentsToScene
CPU ID set randomly: 9328
CPU ID used: 11938

[18/August/2017 16:32:54] Checking scene dependencies..
[18/August/2017 16:32:54] Checking Data
[18/August/2017 16:32:54] Preprocessing scene...
DEBUG: - Cuda render engine enabled.
[18/August/2017 16:32:54] Preprocessing data.
[18/August/2017 16:32:54] Memory used before preprocessing: 1151 Mb
DEBUG: - Preprocessing scene modifiers.
[18/August/2017 16:32:54] Loading geometry extensions.
DEBUG: - Preprocessing MXS references.
DEBUG: - Pretessellating meshes with displacement.
DEBUG: - Checking spot/IES lights.
DEBUG: - Initializing data.
DEBUG: - Preprocessing geometry.
DEBUG: - Preprocessing materials.
DEBUG: - Preprocessing additional parameters.
[18/August/2017 16:32:54] Memory used after preprocessing: 1153 Mb
DEBUG: - Initializing render engine.
DEBUG: - Cuda render engine enabled.
DEBUG: - Interactive mode enabled.
WARNING: - Reflection/Refraction passes are still not supported in the GPU engine and will be disabled for rendering.
DEBUG: - Initializing multilight data.
[18/August/2017 16:32:55] Starting voxelization.

Scene Info:
Image output: C:\Dirk\test noview Maxwell\test noview 1.png
MXI output: C:\Dirk\test noview Maxwell\test noview 1.mxi

Geometry:
- Num Objects: 2
- Num Meshes: 2
- Num Triangles: 14
- Num Vertexes: 12
- Num Normals: 7
- Num Materials: 2

Camera: Current View

Render settings:

- Engine version : 4.1.1.1
- Using RSC engine
- Desired rendering time : 10000
- Desired sampling level : 12.000000
- Using 8 threads
- Multilight type: Disabled
- Save lights in separate files:No
- Motion blur: disabled
- Displacement: enabled
- Dispersion: disabled
- Denoiser: disabled
- Illumination layers:
. . direct layer: true
. . indirect layer: true
. . direct caustic reflection layer: true
. . direct caustic refraction layer: true
. . indirect caustic reflection layer: true
. . indirect caustic refraction layer: true

[18/August/2017 16:32:55] Start Voxelization
[18/August/2017 16:32:55] End Voxelization
[18/August/2017 16:32:55] Voxelization done.
[18/August/2017 16:32:55] Memory used after voxelization: 1242 Mb
[18/August/2017 16:32:55] Start Rendering


Edited by Suedpol, 18 August 2017 - 09:41 AM.


#8 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 18 August 2017 - 11:13 AM

Having the Nvidia GPU utilization monitor open,

I can clearly observe that Maxwell stresses the GPU too much, the meter goes to the top rapidly.

The graphics card even denies service for a fraction of a second.

Is 4GB not enough GPU memory?


Edited by Suedpol, 18 August 2017 - 11:14 AM.


#9 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 18 August 2017 - 11:54 AM


For help resolving this issue, you will need to contact Next Limit support directly. Please submit at support ticket through the Customer Portal: https://portal.nextlimit.com/

#10 Suedpol

Suedpol

    Member

  • Members
  • PipPip
  • 21 posts

Posted 22 August 2017 - 03:38 AM

Support Case opened and a first suggestion brought some progress.

 

Scaling the image output by 50% in the Maxwell Render Options palette makes the simle box render in 45 s (4 min with CPU).

The result is a rendering with 800 px in width, of quite lttle use.

At 75% scaling Maxwell freezes again.

 

Another hint by the support was to turn off multilights bit thatw as already the case.

 

My impression is that GPU render is still in its experimental phase.

 

Will switch back to CPU for time being.

If support comes up with new suggestions, I will report here.



#11 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 24 August 2017 - 02:06 PM

Suedpol

I ran into the same issue when trying GPU render.  I upgraded Maxwell and bought an 8GB GTX1080 just to use this feature.  Unfortunately it is only useful for very small images at very low resolution.  Hopefully some day they will make it a useful feature of the program.

AW






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users