Jump to content
AutoDesSys Forums
cobrien

Materials not visable

Recommended Posts

Hello,

I'm having a bit of trouble with materials since moving to a new PC. I'm assuming it's something to do with the file search paths but it's got me stumped.

When opening files created on my old PC some materials don't show up in Shaded view. They render fine in the VFB so it's finding the files?? If I select a different file in the Material Parameters then change back to origional file it shows up (like the counter below). Its no bother for the model below but pretty annoying for one with dozens of materials.

screenshot.thumb.jpg.0f23f23232876d3a8b2923d3d747cc0c.jpg

 

If I re-link all materials, some that show fine in Shaded view won't show up in Edit Cone of Vision. This doesen't really matter but I thought I'd mention it.

screenshot2.thumb.jpg.207fe95c7ddf86ab66b7c03699c0e0b5.jpg

 

Some objects no matter what I do I cant get to render in shaded view, like the people below.

screenshot3.thumb.jpg.3aa0fce7e7b8a5a3b93f355bf1e66877.jpg

 

Old & new systems have the same FZ 9.2.0.1 & v-ray 3

Any ideas?

Thanks.

 

Share this post


Link to post
Share on other sites

Have you checked the face normals? Although if you display the face normals (Inspector>Attributes>Show face normals) on those high res people it'll slow your machine to a crawl (thousands of arrows) so I suggest moving your camera in perspective view inside one of those wire people to see if the texture shows. If it does on the inside then use the Reverse tool. I find this sometimes happens on some imported geometry.

If that's not the case, go to the material parameters, select a problematic material and select shaded to see if the transparency is set to 100% or something like that. Some imports come in like that and have to be set to "None".

Another thing to consider if none of the above works, is to check the image file for the texture. Some are png files and have transparency. When I have imported people for example (heavy geometry), I create lower res jpegs (Baseline Standard and not Progressive) of the supplied image textures.

I use Maxwell and I'm sure there is an equivalent in Vray, but I create MXS files of the people so they are not actually in the main model file and are displayed as Boxes or dots. This helps to keep the model snappy and workable (slightly off topic).

Des

Share this post


Link to post
Share on other sites

Thanks Des.
You were right about the people models, the shaded transparency was set to 100%. I'm not sure how this happens it's opening fine on my old system.

This model is doing the opposite, it's finding the right files for the Shaded view but using the wrong files for the v-ray render. The files it's using have the same name but are pulled from random folders.

screenshot.thumb.jpg.7412bc8fa2973a6cdaacab1aaeebf65f.jpg

 

Share this post


Link to post
Share on other sites

If you go to the FormZ preferences>File Search Paths>Plus (new path). Then navigate to the folder with the texture files, that should fix it if you set it to Absolute Path.

By setting it to Absolute Path you'll know it won't grab textures from anywhere else.

Share this post


Link to post
Share on other sites

Hello,

I've seen this as well after changing computers.  It's easy to cause when you have textures saved in many different places, and from just copying and pasting from other files, it happens.  The best solution I have found is to consolidate your maps in a single folder that lives next to your FMZ files for that project.  I create a 'maps' folder there that I fill as I create a new project, but all the stuff I copy and paste into the project like 3D people, furniture, etc, ends up with map links in other folders.  To fix this, I use the File > Save A Copy As... feature.  I tell it to save in the maps folder with the Options to Save Image Files, usually Referenced Files Only.  This creates an appended Copy file with all the maps consolidated in one place for the project.  Now if you ever open the FMZ file on another computer, the first place FormZ looks is the folders next to the FMZ file, so it should find them automatically, every time.

If you still have your old computer, try taking an existing project and doing a Save a Copy As... with the Image files in a folder next to your FMZ project files.  Then send it over to your new computer, and let me know if that doesn't work out for you.

 

image.thumb.png.ce0ef61855ccace9cde3abad6734c450.png

 

Cheers!

Share this post


Link to post
Share on other sites

Thanks Des & Justin.

I think the main problem is everything was saved on C drive on my old PC & my new one has the OS/programs on C & data on D drive.
For some reason FZ will find the correct file path for Shaded view, D:\Work Files\... but for V-ray it will search C:\Work Files\... or vice versa!

Justin, I'll give your Save a Copy As... suggestion a go, thanks.

Share this post


Link to post
Share on other sites

Hi!

I use same method as Justin. Old days I used to save materials to the server in one location just to save hard disk space, but not any more. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×