Jump to content
AutoDesSys Forums



Recommended Posts

I tried to work a bit with version 9 to work on an .obj (Xfrog tree)
So just to tell you
the import works after it's just a series of endless problems.
Here is a small list:
on windows
separate objects: but where are the options?
The separation leaves little bits of geometry everywhere (FZ 6 does this without problem
In my object palette I cannot select objects from a group (with or without the general ungrouping option) then if I select in the window and then the objects become selectable in the palette
if I select the group it also highlights a whole series of objects above (not selected but highlighted in blue)
Sometimes the list skips: problem on windows I think
Then I tried the new mapping tool: result it offers a completely unsuitable mapping
suddenly I switch to the legacy tool: but where are the texture proportion options depending on the map?
I also wanted to correct a material whose transparency had not been imported.
Why are these tiny loading incone
Where is the option for match color map?
The display in the window does not refresh correctly ...
In the end I folded all this I went back to Z where I could do everything correctly and I reopened in Z9 just to do my datasmith export (at least it works)
In short, that fun!

Frankly I do not know if one day you will release a stable and complete version of FZ 9 under windows ...

Link to comment
Share on other sites

I tried a random xFrog plant from the Oceanic library and the 'separate objects' tool worked just fine. I tried again on a European tree as they are heavier and still OK.

My XFrog plants are in LWO format though. I did not get them in OBJ format. 

xFrog plants are very old and produce problems in lots of other software too. Namely Modo and Cinema4D in my case.

Initially, with v7 and 8 I found it a constant pain going back to v6.7.3 for almost everything. More recently I only go back to v6.7.3 to access LWA materials and the occasional old fmz file that won't open in v9.2. 


Link to comment
Share on other sites

Hi Brian
We were talking about it with my colleague on exactly the same theme: maybe we just can't get used to it ...
But definitely when I see the number of things that work badly or that are so annoying with Z9 each time we decide to give this version a chance, we come to the same conclusion: it is software that does not is not finished on windows. Frankly the interface is screwed up (compare to what exists around, starting with Blender ... It's a pity)
At the limit the interface problem I pass ...
May I see the few tools that I used in this little work on Xfrog, it's a mess.
The separation tool has no more options, it left little bits of geometry for everything that Z6 did not do ... The group system has no advantage over that of Z6
When I wanted such a group, it was not clean ...
The selections behaved strangely: it was necessary to select on the screen for the selection in the palette to work ... etc.
The only trick is the object and face selection from a material in the materials palette.
I will be curious to talk about it with some power users from the 2000 era like Craig Williams and others because really here on windows we find that the workflow on z9 brings almost no advantage ...
If not which ones?

The xfrog are sometimes imperfect but they import very well on Twinmotion (the native trees are Xfrog) like .obj
Xfrog is redoing part of the library by improving geometry and textures)
For us, the geometry is sufficient for most of our projects and we redo the textures with Pixplant and fall to Sampler sometimes we have to correct the mapping (hence this very disappointing Z9 test)

For me Fz has lost its dynamism and the quality of its organization and tools
We also have the impression that the windows platform is no longer of interest to Autodessys ...

Link to comment
Share on other sites

@jldaureil  The problem is most likely caused by the textures. There are two things that you can try:

First, import the xfrog model into another app, remove the textures, export as a clean mesh OBJ file and then import into FZ. If the import is good, the problem is the file format of the textures.

Second, go back to the other app and check the texture file format. I think that you will find that they are in TIF format. If so, change to PNG and try again. Good luck!

Link to comment
Share on other sites



hi santa
Just for the work on Xfrog:
In fact I have no problem importing the .objs from our bundle 3000 (all xfrog) including for the textures and that in Z6 as in Z9
Except in Z6 the + Z axis switches under the + y axis which is corrected on import
On both versions the textures are imported except the alpha channel of the leaf texture.
This is why it must be reinserted by hand.
10 seconds on Z 6 because you just have to clicker match color shader and set "use alpha channel"
on the other hand, on z9, let's go to search for the original texture (the exploration window does not use the win 10 standard so you cannot copy the path, in short you are pissed off ...
Once the texture is found you snap on the alpha channel and ... well it's not sure that it works ... you have to tinker: change shaded mode stuff like that ...

After the problem that sometimes happens with Xfrog trees is that the UV mapping on the branches does not follow the correct proportion of that on the trunk. As in Twinmotion the object arrives as a single object you cannot correct ...
So you have to open in FZ then separate then correct the mapping of the branches or and of the trunk then send everything back to TM ..
Here the FZ 9 datasmith export is very useful and it is indeed the only thing that works without any problem and very quickly ...

It is for this little remapping job that FZ6 is much more efficient than Z9
On Z9 you have to use the texture mapping tool legacy !!! (frankly it makes you laugh)
And you can see that the Z6 options have not been imported such as the proportioning of the mapping according to the texture!
Why not have been at the end of the reintroduction of this tool?
In addition, the window which is already too small and impossible to enlarge on Z6 (which had been requested in the past) is exactly the same on Z9 ...
Maybe our developers are still working on 1984 macintosh screens

It's tinkered ...
What would have been complimentary is the creation of a complete tool in the main window with for example a dedicated pallet like a Ben Dean would have done with a Pylon plug

etc., etc ...

Frankly how do you explain that we have more difficulties working with the software in its current version than with the version of 10 years ago
Put yourself in the shoes of the people who approach the program today and you will understand why it will be difficult to convince them to come to Formz

Edited by jldaureil
Link to comment
Share on other sites


If someone can explain to me how I can copy the texture maping settings from one object to the others ....
I don't understand why multiple selections with Shift don't work the first time ...
The tool pallets come out intepestively ...
When I select everything then pick + shift to remove the source object from the selection it's not smooth ...
Well I get there then I take the "copy attribute" tool and hop it reselects the source object that I have just deselected
It drives me crazy with unnecessary clicks and ultimately not to copy the parameters which is a very simple operation on Z6

Edited by jldaureil
Link to comment
Share on other sites

Hi JL,

Luckily I don't have to do this - so forgive me if its not suited to your specific problem - a few things to try:

( I only tested this on a bunch of simple objects though)

Shift picking (pick tool) multiple objects and then using "copy attributes" from another object  works for me. (But maybe due to it not being imported geometry)

- There also is a copy attributes options window which is not seen in your screencast - maybe check what is set there, see pic

Usually in V9 I would just select all, hit color and then use map texture to map them all in one go.

(this has worked for me using data smith aswell)

If you really need UV and the V6 tool (I never used it again) my guess is you have to go and join your desired branches into one object first, and then use "map Texture classic" on it.

Finally - isn`t placing trees one of the major strengths of Twinmotion ? (just a thought)


copy att classic.png


Link to comment
Share on other sites


I understood what does not work!
We do NOT  select everything with ctrl + A or menu Edit + select all
If you do that it doesn't work
On the other hand if you make a frame selection in topological object then you can deselect the source object.
and in this case the copy attribute tool woks correctly (in accordance with its options hidden in my video)

I think there is a bug with ctrl + a and select all ...
(and it's not the first time I've seen shit with that)

Is there a way to choose not to work the addition and removal of sections with shift in Z9 as it exists in Z6?
It's really painful because it's not very stable (as we see in my video: suddenly it displays the "+" but for the "-" you have to wait and sometimes it does not display it ..
pfff ....

otherwise since it works, there is no need to go through a join + legacy map tool ...

finally :
Placing trees in TM is really very easy especially with the trees from the base library (you can populate a surface with several different kinds of trees or position it more individually.
In short, a lot of solution that works formidably ...

Of course all additional trees (from Xfrog or any other soft) as mesh do not take wind ... But you just have to find the needed tree...

see pics: (real time) (not beta)

We are currently participating in the beta ...
I can't talk about it but it's a killer!

and the development is ultra dynamic

Image20 BIAS 010.jpg

Image49 BIAS 010jpg.jpg

Edited by jldaureil
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...