Jump to content
AutoDesSys Forums
Sign in to follow this  
Bo Atkinson

Mirroring Objects

Recommended Posts

Is there a sure way to mirror an object about one of its faces? I have noticed a tool labeled somewhat similarly, but never could see how that tool should function. Does a formZ video show that?

The attached fmz opens with Layer 2 containing an object and its copy "mirrored" but I had to take multiple steps to get the copied object attached at its face.

Is there an easy way to mirror the second object?

Layer 1 of the fmz show how the object was differenced from spheres.

 

SphericalDifferencingObjectCopy.fmz

Share this post


Link to post
Share on other sites

Bo,

I can do it in 3 steps Using the Mirror-A Tool.

  • Draw a rectangle over the plane you wish to mirror the object about, using the auto plane feature and allowing the rectangle to fall off the face. so it is easy to select later.
  • Using the Mirror-A tool, select desired object then click on the rectangle from above to apply.
  • Delete rectangle.

 

This may be easy to do in a script.  I would have to explore that to find out.  Sadly, I am occupied for a few days.

If I get some moments and think about it, I will dig in.

 

Cheers!

¢£

 

Share this post


Link to post
Share on other sites

Ahah, so that is it. Always check for possible ambiguity, as in the word-name- 'face'. Make a new face, and don't plan on mirroring from the face of the object to be duplicated. They ought to add this explanation to the manual.  

Thanks Chris, I was trying to show this to an informal institute online, but got stuck, and the formzFree version doesn't have that tool anyway, (for them to try); and embarrassingly, Autocad had a free version which did the mirroring!

Furthermore, the Autocad seemed to allow the smooth Booleans to remove the isoline-display, and therefore to look smoother. Whereas, even with the formZ menu/edit/preferences/modeling/always smooth option on, plus the Display Options, iso lines unchecked, formz still shows the facets as in this image.

SphericalDiferencingTetrahedrally-iso.png

Share this post


Link to post
Share on other sites

You can also derive the face(s) you want to use first with the Derive Faces tool as another method.

Of course, the ideal would be to use existing faces without intermediate steps. I have it written down in my list of pending requests, which I will send someday!

In your file, the "spherical difference" objects are polygonal (faceted) because formZ Free only offer polygonal tools I think, not including smooth object generation or maybe very limited, I don't remember. That explains the facets if you were using the free version.

I did the same exercise in formZ Pro using the tetrahedron and the spheres, and there are no facets, and everything is smooth, obviously, as you can see in my images.

Over the years, working in architectural and cabinet design on macOS, I often export my designs, including the smooth 3D geometry, between formZ, AutoCAD, and recently BricsCAD, without any problems. I use the DWG format with ACIS, and the geometry flows smoothly back and forth while maintaining type and geometric accuracy.

1273022857_SphericalDifferencingObjectCopy1.jpg.fb94831b90f07623d51886df3d9266ac.jpg815095813_SphericalDifferencingObjectCopy2.jpg.9c5b6822b6b6fc2f20f2c4cc69c7b64a.jpg

Share this post


Link to post
Share on other sites

Yes Ztech! That is the look I was hoping for, (when I was recommending formZ at my meeting some weeks ago). Your post does sound promising , however I made the first model in formZ Pro 9.1.0, (and I was trying to encourage my associates to test my model in formZfree which does many useful functions well besides mirroring), and all of which begs the question, what other option should I check, to get the smooth surfaces in your image?  

Which settings, in addition to:  formZ menu/edit/preferences/modeling/always smooth option on, plus the Display Options, iso lines unchecked ... formz still shows the facets as displayed my images.

I just now modeled a version which has made the start-up-tetrahedron smooth, by slightly rounding its edges. The original tetrahedron was facetted, and was not smoothed. The spheres were all smooth too...The result still appears facetted.  So please let us know what else can be done in formZ to avoid the facetted results in todays, attached fmz smooth object?

Smoothed Spheric-Voids.jpg

Smoothed Spheric-Voids.fmz

Share this post


Link to post
Share on other sites

Bo, your object is smooth and the faceting is only visual, because in the object attributes you have the Override Project Smooth Shading option selected. If you deselect it, it will look smooth as you want.

Also, if you change the Display Resolution parameter from 50%, which is the default value, to 100% the outlines will look smoother too.

Be careful with this value if you have a lot of smooth objects in your project, because it changes the underlying polygonal resolution of the smooth objects, increasing the number of facets considerably. In this example it went from 797 at 50% to 2525 at 100%.

image 1.jpeg

image 2.jpeg

image 3.jpeg

image 4.jpeg

image 5.jpeg

Share this post


Link to post
Share on other sites
On 11/11/2021 at 8:31 PM, ZTEK said:

Bo, your object is smooth and the faceting is only visual, because in the object attributes you have the Override Project Smooth Shading option selected. If you deselect it, it will look smooth as you want.

[...]

image 1.jpeg

 

Thanks so much ZTECH, that is the very key solution needed! 

Seeing the dialog-box-screen-shot makes more sense than reading the text in the box.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×