Jump to content
AutoDesSys Forums
Andrew West

Scene FIles and Proxy objects.

Recommended Posts

I need to finish a project that is due Monday and I have hit a wall.  Figuratively that is.  My model has a lot of furniture and as such it is taking upwards of 5 minutes for the program to save each time.  Kind of insane if you ask me.  Yes I have super fast SSD drives and I have Keep Textures turned off.  I have limited the sizes of my textures a lot.  The model as a whole is about 630,000 KB and I have 128 GB of Ram.  So I thought I would explore V-ray scene files again which I have used successfully in the past.  Unfortunately, it now seems to be completely broken in V9.  Has anyone else had a chance to work with this lately?  I even back saved to 8.6 to see if I could get that to work.  The scene files save properly but when I bring it back into a new model the scene file is completely corrupted and blown apart into thousands of triangles.  It is also worth noting that the sofa was 56K KB and the sofa scene file was 650K KB.  I have tried all the V-ray settings on export and import to no avail.  So now sene files, components and proxy images are all non functional.  Any suggestions would be very welcome at this point.  
Thanks in advance.

Andrew

scene.jpg

Share this post


Link to post
Share on other sites

Hey Andrew,

Quick thought, on your large project, do you have the Open Fast File Optimization enabled or Smaller Files?  

image.thumb.png.b2fb93f9817f77e72dab7a42fd76213a.png

I prefer the Open Fast setting as it also means Save Fast because it doesn't have to compress the formZ file when it saves it.  I think this should be the default setting for formZ files, but Smaller Files is unfortunately set as the default.

Share this post


Link to post
Share on other sites

Justin, I find that Open Fast does indeed do what it says it does.  However,  it does not affect how fast my files save.  At least not in my case.  I really wish I could use Scene files again.  That did affect how the program acts and responds since the data is not stored within the project.  Upon trying to use Scene files I also found that not only is it broken, but it now corrupts the texture maps on whatever you are trying to create.  The maps just show as solid black now.  So I had to go back and fix all 18 maps on a model that I tried to convert to a Scene file even though it didn't create the file.  This is very unfortunate.  

Thanks for your help though.  Lets keep pushing the limits of Form.z and Vray and hope that they can get this all sorted out sooner rather than later.  

Share this post


Link to post
Share on other sites

That's certainly a bummer.   In the past I've found it to significantly decrease my save times as well as open times.  I wonder if this changed in v9?  I know you are as much of an expert as anyone on formZ, and I only hope that I can somehow find a way to help you with your issue here while we wait for AutoDesSys to respond.  

It sure sounds to me like your file is saving more than geometry, or trying to compress the file, or something else is going on with the hard drive itself.  Saving should be pretty fast for a 630mb file, maybe 10-15 seconds max.   I was curious so I just did a quick test.  Here is one of my only examples of a file that size with a large amount of outside geometry (furniture, 3d plants, TVs, gaming room stuff like action figures and a fully detailed gaming computer, detailed hardware, chairs, cabinets, etc):

image.thumb.png.4252c130c8621c3af84b644dd6f9be9a.png

It's 584,747 KB in v8 as where it originated, but reopening now in v9 and saving as another file it's down to 525,633 KB.  So smaller than your example, but it only takes about 5 seconds to save for me in v9!  Something strange is happening in the matrix...

image.png.a7da6c7821611809b81429a398178c5f.png

Maybe there's another setting you might have missed that could be affecting this.  It's confusing, but there are 2 places in formZ where we need to Turn OFF Keep Textures.  First is in the File > Project Settings > Project Files > File Optimization:  Use Open Fast and Unselect Keep Textures options.

image.png.b4cbdf50fac6964c69ce889249f4afb3.png

Another place to look is under Preferences > Project > Project Files > Keep Textures:  Unselect that if it's not already.

image.png.f4ce323cdff219b488455903ce40e13f.png

 

If that doesn't do it for the Saving speed, then there must be some explanation why, as the math simply doesn't add up.  Any way I could test that file for you here?

 

That being said, VRSCENE files sound like the long term solution you need.  I would have thought that Components would have worked as well to reduce the file size, but it looks like they add to it just like regular geometry?!?  Haven't used those in a while since they used to not work very well in v8, but had heard in v9 they were working better.  It would be great if these were just block place holders as setting them up visually in the Component manager is a much nicer way of dealing with a large catalog of models than just browsing for the files.  Still, it's not the solution you need if they add to the file size.  Hopefully ADS will chime in here...

VRSCENE files are an important feature, and we need to make sure this works correctly in the future.  I have to say I have not tested it much since the BETA days and it did work OK for me at one point, so I would assume it's just another update that broke it.  Testing here shows a similar situation to your example where my VRSCENE file had a sofa, chairs, tables, and upon Importing the file it gets triangulated and looks like garbage.  HOWEVER, when I render it with VRAY, it renders as it should: 

image.thumb.png.ab963c573fb769ed11b59ac877181011.png

So that tells me that this VRSCENE file worked but it's Shaded and Wireframe representation is broken.  Did you happen to try and render your example to see if it was just broken in Shaded/Wireframe preview?

Hopefully this is all moot and we have a NEW VRAY 5 plugin coming very soon!  :)

Sorry for the long post, but hope this helps.

Share this post


Link to post
Share on other sites

Well after finally talking to David I found out that what we are looking at with the triangulated geometry is a REPRESENTATION of the final geometry.  It can be represented as a bounding box in the model or a reduced geometry mess that looks like a bug but it isn't.  The way to get it to look like the original model is to go to the Inspector- Parameters- Preview- Normal.   Now why didn't I think of that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×