Jump to content
AutoDesSys Forums
Sign in to follow this  
setz

Beginning Hiccups

Recommended Posts

Just starting.  I don't know what I'm doing at all.  Using a Mac 10.11.6 so Python should be installed right? (how can I find out which version of Python is installed?)  I ran "cube.py" utility from the Extensions menu and I got this error msg:

1573047482_ScreenShot2020-05-19at5_56_15PM.png.0ae61e0aefcaccce3e5c53efc4e49be6.png

I thought there may be a permissions error so I moved the script to the desktop and got the same error message implying that it was trying to open the same file, not the one on the desktop so I renamed the one on the desktop to cube2.py retried and then got this msg:

11141928_ScreenShot2020-05-19at5_59_10PM.png.af3842b714f4b22b3ba837b38b020f81.png

...and no .pyc file was created.  What is going wrong here?

 

 

Share this post


Link to post
Share on other sites

I ran "python ––version" in Terminal and it returned this:

1051395635_ScreenShot2020-05-19at6_13_05PM.png.f3a8a2705b986ea3aec7d41d8fae62de.png

and then I downloaded Python 2.7.18, ran the installer. It created a Python folder with this in my Applications folder:

629040110_ScreenShot2020-05-19at6_12_47PM.png.ab6bdb7c085f7c6cbce9c9c08d774a6f.png

So it looks like I have 2.7 in /Library/Frameworks but the No module named cube2 is still displayed when I run the cube2py script.

Is the 2.7 enough 2.7.? or do I need to get the 2.7.18 installed and how?

Share this post


Link to post
Share on other sites

Setz.  Python 2.7 is installed on all Mac OSs up to Catalina.

 

The problem doesn't appear to be with python.

I get the same error when I run the cube.py script.

By looking at the code, there is an error in the "formzPythonInterface"  This worked before, so it appears to be somewhat recent.   I let dev know.

Share this post


Link to post
Share on other sites

Scratch that.   It is just a typo in the script.     In line 5     cube should not be plural.

should read.

fz.cube([0.0,0.0,0.0], [5.0,10.0,20.0])

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×