Jump to content
AutoDesSys Forums
3dguy

How to export OBJ to Blender and Maya?

Recommended Posts

Hi - quick question that's been giving me a bit of a headache today: why can't I export simple geometry (in .obj format) into Blender or Maya? Even starting with a basic cube in Form Z V8, I can't find the right export settings which will allow me to successfully import an object to either software package. No matter what settings I try, the following happens:

Maya: it "imports" the file successfully (no errors), but no geometry is actually imported - I can verify this by looking in the Outliner and seeing nothing listed.

Blender: Again, it "imports" successfully, and I can see the name of the object in the Scene Collection box, but...selecting it there and checking it's properties reveals that it there's no geometry. Everything is zeroed out.

What am I missing?

Thanks for any help!

cube.fmz

Share this post


Link to post
Share on other sites

Try triangulating the model.

It is easier to help if you attach a screenshot of your export settings along with the file.

One problem with FormZ that has always been present is that the file dialogues allow you to enter settings that don't work.

This results in a file without geometry or other problems. If possible reset FormZ preferences and try again. The default settings for file export work for almost every situation. 

If you need to change something such as scale or orientation make sure you keep a reference to the default settings. Autodessys PLEASE add a reset to default option to the file dialogues. It would save users a lot of unnecessary grief.

Share this post


Link to post
Share on other sites

@jldaureil - is that a screenshot of settings that are working for you? Unfortunately, it's too small and I can't read the individual settings.

Attached is a screenshot of the latest settings I've tried - however, I spent about 2 hours yesterday trying all kinds of different settings and nothing worked... 

cube.png

Share this post


Link to post
Share on other sites
44 minutes ago, Shibui Design said:

Try changing "Smooth: AS Trimmed Surfaces" to "faceted." and then check the "Faceted" radio button directly below that.

Yes!

Share this post


Link to post
Share on other sites

Thanks for the tips! It still doesn't work though. Maybe it's a version 8 thing? I'm on 8.0.2 btw.

Oh well. 

Share this post


Link to post
Share on other sites

Thank you! Yes, those models imported into Maya and Blender perfectly.

And thanks for posting the screenshot of your export settings. I discovered my problem: I was selecting "Macintosh" as the platform, but when I switched it to "MS-DOS" it works. I have no idea why, but oh well. I'm just glad I can export OBJ files to Maya and Blender now!

Thanks again to everyone in this thread who helped me sort this out.

Share this post


Link to post
Share on other sites

Not positive, but there was a day when the "endien (sp?)"  between the two platforms was different.

Basically meaning that the byte or bit order of the values at a machine level was reversed.   Not sure if they still are, but some programs may still take this into consideration.  Since the processors are now the same (intel) they should be the same.  But Apple for once in their existence may have kept backward compatibility.  Naw, what the hell am I talking about? They would never do that!🙄

This is probably an oversimplification, as it is a µprocessor issue and I haven't studied that in 30 years.

Share this post


Link to post
Share on other sites

I admit that I had never asked myself the question seriously ...
It is always good to know..
But actually I would not have thought of modifying this parameter since the screen shot was on Mac

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×