Jump to content
AutoDesSys Forums
Tech

formZ v9.0.3 Now available

Recommended Posts

 

form•Z v9.0.3 (#A123) highlights

New stuff
“Superimpose” is a new option in the Underlay options of the Reference Plane Parameters palette. When selected, the underlay is Superimposed in shaded views instead of depth sorted. This is most useful when combined with the transparency slider to see the undelay image through a shaded image.

“Give Guide Snaps Priority” is a new option in the snap options Palette. When selected, Guide Snaps are given priority over object snaps (when both are enabled). If the cursor is close to both a guide and a snappable point/edge/face, the location will be snapped to the guide rather than the point/edge/face. When this option is disabled, the opposite rule is applied. This option is now on by default by popular request as it makes the guides more functional in shaded rendering modes. The option can be controlled with a key shortcut as well (Key Shortcuts manager).

General improvements
Export of hidden line images to pixel based formats (TIFF/PNG/JPG etc.) now works properly.
Underlay images no longer disappear when switching from wireframe to shaded full and the back to wireframe on machines with certain graphics cards.
Components with Flat/Cubic/Spherical texture map controls now render properly in RenderZone. 
Using Reduce Mesh tool no longer crashes on certain objects.
Files with mirrored components now show the components properly when saving and re-opening the file.
Curve and Surface Formula tools now show all the formulas in the Interface.
View navigation in the Decals and Classic Texture Map dialog now works properly. 
The “Pick By” and “Assign” options in the Classic Texture Map dialog now work properly. 
Door/Window component’s are now are placed at the proper depth.
The Section tool now properly honors the Status of objects (Ghost or Delete).

Windows specific 
The Transform tool no longer crashes when entering a second value for the Scale option. 

Draft/Layout
Printing or exporting to PDF no longer misses some elements.
Printing or exporting to PDF now includes title blocks properly.
Printing from draft space now works as expected.
Image elements no longer have a border when printed or exported to pdf.
The Layout content tools no longer become randomly dimmed.
Layout frames now update properly when the model is changed.

 

Share this post


Link to post
Share on other sites

Layout is a bit better, but not great...

- dimensions disappear and after reopen the 2D file again, some of the missing dimensions are placed far outside the sheet in an empty area.

- takes minutes before layout updates the 3D model.

- 2D graphics move within the frame after reopen the 2D file.

+ printing is better to PDF, nice lines. 

+ 2D looks better. Less missing lines.

ADS, thank you for the update. I will continue testing...

Share this post


Link to post
Share on other sites
4 hours ago, jldaureil said:

"Check for update" menu don't work here...

WIn 10

What I made wrong?

Use the download link they e-mailed to after you purchased Form Z v.9. 

Share this post


Link to post
Share on other sites
11 hours ago, Hugo said:

ADS, thank you for the update. I will continue testing... 

thank you Hugo
I too will continue to test
to start with the multiple things that I have already reported
I guess this is the "zeta" test
ah ah

Share this post


Link to post
Share on other sites
10 hours ago, jldaureil said:

thank you bernie
i will do that
the menu is not supposed to work?

From what I recall, Autodesys hasn't overcome some of the security issues the Update tab faces when we try using it. 

Share this post


Link to post
Share on other sites
22 minutes ago, BernieB said:

From what I recall, Autodesys hasn't overcome some of the security issues the Update tab faces when we try using it. 

well they are deleting this menu!
And as long as to do the preferences with!

Share this post


Link to post
Share on other sites

I am extremely disappointed by this new built.
All the bugs that I have reported regarding formz 9 draft layout for example have not been fixed.
I reported these problems to tech support by email first then on this forum then
I got no feedback
Not even to tell me that the problems are confirmed
Even less to say that these problems will be adjusted later if they are not priority
In short, it really gives the impression of making fun of our observations
Besides, I really wonder what it is to piss off testing
It takes a lot of time and frankly what is it for?
I have sent sample files as requested
I told myself that it was just to make me believe that the developers were interested in what we could bring them ...

I'm sorry, but we are really far from the time when the support responded regularly (Paul Helm probably)

Well we understood that when we put our finger on a software defect it was disturbing and we were sometimes entitled to politically correct answers but through which we understood that what we said left the editor cold

But today is clearly no answer at all!
Frankly it is not worth giving us speeches on the investment of the team and blah blah blah!

I remind you guys that formZ 9 is a commercial version, you have to pay to get it and that in return for lack of a perfectly functional software you could at least answer those who (like me) effort to help you improve it.

Now I don't do anything anymore because anyway you don't seem to care

Share this post


Link to post
Share on other sites

This has a delta of .01 in it's build.    ADS is making changes as they can and getting those out to us.

Or, we can wait 10 times longer for a delta of .1    I am happy for the .01

 

 

Thanks ADS!

 

¢£

Share this post


Link to post
Share on other sites

I'm with jldaureil on this one. If something needs to be done, for goodness sake put on more manpower and get it done now, not in years to come. Complacency by the developers coupled with the never ending pleas of loyal users is a recipe for disaster. Remember QuarkXpress?

Share this post


Link to post
Share on other sites
3 hours ago, santa said:

I'm with jldaureil on this one. If something needs to be done, for goodness sake put on more manpower and get it done now, not in years to come. Complacency by the developers coupled with the never ending pleas of loyal users is a recipe for disaster. Remember QuarkXpress?

I remember when graphic design used to actually mean something. Now it's just a bunch of people getting their hands on software and they think they just need to make flashy graphics. 

Share this post


Link to post
Share on other sites
Posted (edited)

Greetings, folks!

With the update to version 9.0.3 (Build A123), I seem to have lost some critical palettes.

The first screen shot, grabbed back in January (The Missing Palettes, Highlighted.jpg) shows the expected palettes, outlined in a red frame.

The second screen shot (Missing Palettes in 9.0.3 (Build A123).jpg) shows the hole at the bottom of the image, where the above-noted palettes used to be, and were, until version 9.0.3 (Build A123). Also shown is the Palettes menu, that doesn’t seem to have any way of geting those palettes back.

Any suggestions!

;-)

Blessings, and thank you!

The Missing Palettes, Highlighted.jpg

Palettes Missing in 9.0.3 (Build A123).jpg

Edited by Richard Fairbanks

Share this post


Link to post
Share on other sites

The last and this latest version of Layout does not work for me. I've reported this with earlier builds and my problem persists.

When creating a new layout file, the work window will not display. It's simply the light grey background color edge-to-edge. No zooming, panning, resetting of workspaces, etc. will display any window whatsoever. This renders this version of Layout useless. I have no option other than working with V8.6. This problem has been reported since early versions of v9 release and persists still. Interesting note that seems unique to me is that v9 FormZ has a persisting bug wherein upon launch or file open, the working window also does not display. The only way to see a working window (model environment) is to enter EDIT CONE OF VISION and upon exit, the model window displays. I suspect these two display glitches are related. 

Do any other users experience this?

 

Reverting back to v8.6 for both model and layout. Hopefully this gets corrected soon...1708805584_layoutenvironment.thumb.png.4bb897e9db41f31e831faed6dc6d35e9.png

Share this post


Link to post
Share on other sites

I do not use Layout; however with "blank display" problems in MultiView in 3d projects, I simply open a new additional project and then switch back to the previously blank project which now restored it's display. 

Share this post


Link to post
Share on other sites

With all due respect, such a hack should not be necessary in software approaching 30 years of age! Sometimes I wonder where we would be now, had the old Form.Z (6.7.3) been further developed instead of Bonzai? In my opinion, our present difficulties all seem to stem from that Illfounded decision.

Share this post


Link to post
Share on other sites
On 4/26/2020 at 3:03 PM, jldaureil said:

All the bugs that I have reported regarding formz 9 draft layout for example have not been fixed.

This is simply not true. Many of the issues that you reported have been addressed. Most of the other issues we could not reproduce. Sorry it took longer than normal to answer your email but please understand that we are all working in less than ideal circumstances these days! You did receive a response today.

Share this post


Link to post
Share on other sites
On 4/25/2020 at 4:27 PM, Hugo said:

- dimensions disappear and after reopen the 2D file again, some of the missing dimensions are placed far outside the sheet in an empty area.

- takes minutes before layout updates the 3D model.

 - 2D graphics move within the frame after reopen the 2D file.

Hugo,

We have not been able to reproduce the issue you are describing regarding the dimensions or 2D graphics moving. Can you please send a file to us (support@formz.com) that exhibits the problem so we can investigate? 

We are working on the update speed for layout. from. v9.0.3 actually had some improvements, but we are working on more!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×