Jump to content
AutoDesSys Forums
joepro262

Animation - changing attributes

Recommended Posts

I am trying to change the attributes of an animated object. The attributes revert as soon as the timeline advances. How can I make this stick?

The attributes themselves are not animated.

Share this post


Link to post
Share on other sites

Hi Joe,

 

If we make a cube, click it with the Keyframe tool, move the time line, and move the cube, we create a simple animation of a moving cube.

 

If we then change the color of the cube, and move the timeline again, the color change of the cube is maintained.  (We also tested with other attributes and animations.)

 

Can you please be more specific about exactly what you have animated, and what you are trying to change, and include a simple file that shows the issue so we can look into this further?

Share this post


Link to post
Share on other sites

We were able to reproduce the problem you describe. It appears that Decal parameters are locked into an animated object. We shall get this corrected. In the meantime a workaround would be to delete the animation track, change the Decal parameters, then re-assign the animation track. Please note that in the Animation Editor you can copy/paste your old animation graph, (for your Position Z track), back into your new animation graph so you don't have to completely redo the animation again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×