Jump to content
AutoDesSys Forums
AsOne

Key shortcut to select tool options

Recommended Posts

I used to use Option key (Mac) since v7 to scroll through the tool options (self, copy, multi copy, etc.)  It isn't working in v9.

Anyone know how to set this?  

I can't locate the choice to set this in Key Shortcuts.

Edited by AsOne

Share this post


Link to post
Share on other sites

Thought I recall something like that too, however the closest thing I can see in the manual is in the Transform tools,  the option key will toggle between self and the most recent other copy mode.

 

¢£

Share this post


Link to post
Share on other sites

Ok you are right.  In 8.6 is toggles between the self and most recent other copy mode. 

I also had Option set to switch between Pick topological levels and there is did go one by one through the levels.

 

I can't get it to work for either in v9

Share this post


Link to post
Share on other sites

I think there’s some kind of bug associated with the Tool Option palette in the last release 9.0.0.3.

In previous beta versions this shortcut worked more or less well, just with some lag at times.

If I close and reactivate the palette from the Palette menu it start to work normally until I do ANY operation.

I work on MacOS 10.13.6.

Share this post


Link to post
Share on other sites

It's not just the Alt key... the Shift and Command keys also suffer from the same behavior.

Even weirder... if you minimize and reopen the Tool Option palette from the small dark grey triangle, these keyboard shortcuts partially work again while you hold the cursor over the Palette Dock. If you move it into the working window, they stop working again even if you don't take any action.

MacOS 10.13.6 + MacBook Pro Retina 15" 2012

Share this post


Link to post
Share on other sites

I have also experienced Option key working at times, briefly, for toggling between Move/Copy state.  It has not worked for Topological state at all.  Mac OS

Share this post


Link to post
Share on other sites

We have only observed this on some Mac OS systems. If you make a text field active (like the "X' field of the input palette), then the key should work. Not ideal but its a workaround for now. We have not encountered this on Windows. The same issue happens with the ARC 3 tool to change direction with the key and the same workaround works as well. 

We are working on a solution for this!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×