Jump to content
AutoDesSys Forums
Tech

Catalina (MacOS 10.15) compatibility

Recommended Posts

form•Z 8.0 and later (ie 8.0.x, 8.5.x, 8.6.x and v9 beta) will work with Catalina (a.k.a. MacOS 10.15). Catalina only supports 64-bit apps so older versions of form•Z prior to v8.0 and all bonzai3d versions will not work. Unfortunately this is beyond our control as these are 32-bit applications which Mac OS no longer supports. We also can not rule out the possibility of compatibility issues with specific features or plugins in formZ v8.x on Catalina.

Note that if you try to update a system to Catalina and you have a version of form•Z 7.0 or earlier on your system you will get a warning before the update installs that form•Z is not compatible with Catalina, even if you all have a newer compatible form•Z (v8.0 or later) installed as well. 

Share this post


Link to post
Share on other sites

RE Vray- Just installed Catalina last night. Opened up formZ and all of my Vray menus are gone. Help!

Edited by jalicea

Share this post


Link to post
Share on other sites
3 hours ago, chrisjk said:

When launching FormZ Pro, I get a few error messages. Is it possible to tell Catlina these are OK (assuming they still are).

1788390184_Screenshot2019-10-17at5_36_08pm.thumb.png.a51a61623117905c1b8e0939c4d530b5.png1628807752_Screenshot2019-10-17at5_36_33pm.png.1bc0f5edfbe4f21e8b634015af77063d.png630345270_Screenshot2019-10-17at5_36_40pm.png.fdd804551282714b953b7a8a7f669969.png

The Lab plugins are not compatible with Catlina at the moment. We are working on new builds of these that are compatible...

Share this post


Link to post
Share on other sites
1 hour ago, jalicea said:

RE Vray- Just installed last night. Opened up formZ and all of my Vray menus are gone. Help!

Please check the Search paths for plugins (Extensions Menu -> Extensions manager -> Search Paths button). You are likely missing the path to /Applications/formZ 8/Plugins/. Wh have had reports that this path may be missing by default on Catalina.

To Add the path: click on the "+" icon and in the folder selector, navigate to "Applications"->"formZ 8"->"Plugins" and choose Open. Restart formZ and this should fix the issue.

If you are still having issues, please try reinstalling after upgrading to Catalina as the OS is "happier" with things that are installed after the upgrade (ie Catalina blessed the installation as opposed to something that was there first). You will need to remove the previous version as the installer will not do anything if its already there. We recommend renaming "Applications"->"formZ 8" to "formZ 8-bu". Perform the installation of formZ (and V-Ray for formZ if needed). Once everything is confirmed and registered and working, you can delete the "formZ 8-bu" folder. 

Screen Shot 2019-10-17 at 4.44.19 PM.png

Share this post


Link to post
Share on other sites

I tried doing the above and now I am getting the issues that chrijk is getting. I left a VM as well.

Edited by jalicea
spelling

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×