Jump to content
AutoDesSys Forums
archigraphica

Fit All = view change

Recommended Posts

Posted (edited)

This has been happening ever since I first switched to V8.6.  This is a dumb thing but it has annoyed me for years and I just figured out what causes it. Now to figure out how to fix it:

I have the "fit all" icon in the upper horizontal tool bar assigned the "F" shortcut key. I've had this same shortcut from as far back as I remember.  Sometimes when I hit "F" it works correctly by executing the "FIT ALL" command, other times it switches the view to Axonometric and "LEFT".  I assumed this was random but today I noticed something:  if I do anything in the "LAYERS" palette then hit "F" it switches to the Axonometric and "LEFT" view instead of executing the "FIT ALL" command.  Any interaction with the other palettes and the "F" key works correctly. Here's what I know:

- the "FIT ALL" icon works correctly.  It's only the shortcut key that doesn't work when you interact with the layers palette first.

- Changing the shortcut key to a key other than "F" doesn't seem to matter.  

- IT doesn't matter if the "LAYERS" palette is floating or docked in the "Palette Dock".

- Same effect if you're in Iso, Axo or 3-pnt perspective to start. It always ends in Axonometric.

After experimenting some more it looks like interaction with any palette that has the stripes causes the error. I just usually use the Layers palette.

thoughts?

 

FYI - I am using a dual monitor setup.

Edited by archigraphica

Share this post


Link to post
Share on other sites

Mine works as expected, even when I have text highlighted in the Layers Palette.   I use a modifier key with mine.   Cmd-F.

I did test it without the modifier key, and it still works, albeit not when text is highlighted.

 

You on Mac or Windows?  I am on Mac.

 

¢£

Edited by Chris lund

Share this post


Link to post
Share on other sites

Working fine here on Windows 10 with a triple screen setup.

Ctrl+F is the Default shortcut for Fit All, and I see no reason to change it or ever touch the toolbar icon for it.  If you reset your Shortcuts to default and try Ctrl+F on Windows, CMD+F on Mac, does that work better?  There's a chance you've got some sort of issue by changing the shortcut to a duplicate shortcut.  

Another thought, because of your striped palette comment, is that your graphics driver and/or preferences file needs to be reset.  Do this:

Simply delete or rename the 'autodessys' folder after closing FormZ.

On Windows it's located at C:/Users/(Username)/AppData/Roaming   (you will have to show hidden items and folders)

On Mac it's located at HOME: Library: Preferences

On relaunch FormZ will rebuild your preferences and reset everything to defaults.  As a word of advice, after you get your Workspace set the way you want it, and close FormZ.  The next time you open FormZ, make sure you disable 'Save Between Sessions' under the Workspaces Manager.  Doing this will help make sure you don't mess up your workspace again if FormZ crashes.  

In FormZ Preferences, also make sure you have Advanced OpenGL turned ON.

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×