Jump to content
AutoDesSys Forums
Spannerhead

Glass Opaque when using Alpha Channel Background in RenderZone

Recommended Posts

It's not file-specific.  It happens on all files.  But I've attached a test file.

Been doing this forever, and I've been working around it by erasing the opaque areas in Photoshop, but I have a new project with a ton of renderings needed and I would like to know if there's an in-formZ solution.

 

Thanks!

opaque-glass-alpha-channel.png

opaque-glass-alpha-channel.fmz

Share this post


Link to post
Share on other sites

I have asked this question before a while back, maybe more than twenty years ago.  As I can remember what ztech answered was that glass shader in renderzone was not support alpha.  You might need to change to generic shader, and play with the setting to make it looks like glass.

Share this post


Link to post
Share on other sites

Well that's disappointing.  I've tried playing with the transparency shaders on a standard material to approximate glass, but nothing really comes close.

If any one has settings they'd like to share, I'm all ears...

Share this post


Link to post
Share on other sites

Did you send this into tech support. The only solution I came up with is to use Metal Accurate or Generic as Reflection with Simple Transparency. Made all lights Hard in case you wanted to cast shadows.Not a great solution but may work for you.

Share this post


Link to post
Share on other sites

While I have not used Renderzone now for years since Maxwell and Vray came out I still remember the good old solution that I used to use.  This is really quite simple.

Create a solid 1/2" thick plane.  Use material Glass Accurate in the  reflections channel.  Within the Reflection channel set reflection to 90%.  Set the transparency to 0.  Leave the other settings alone.

Then below the Reflection channel you have your transparency channel.  Open that and set it to your desired amount.  I use 85% for most windows. 

Make sure you to to your glass objects and turn off shadow casting and shadow receiving. 

Now go to your Display Options palette and under Renderzone options go to Scene and change your background tab to Alpha Channel. 

Now export out your renderzone image as a TIFF file.  Open it in Photoshop and under your Channels tab you will see your alpha channel. 

Does that do what you want it to? 

Andrew

PS. For those of you who might say that I am  creating a double transparency object I say so what.  It has never given me any issues over 30 years.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×