Jump to content
AutoDesSys Forums
snow

what does keep textures even do??

Recommended Posts

I have "Keep Texture" enabled in the project settings.

All my textures are present in formZ, but they don't show up when exporting to FBX for render.  Now I have to re-link a couple dozen textures in formZ because even though they show up in the project, when I click to "load texture" in the Material Parameters it goes to the default texture.

I would think if I move the file from computer to computer with "Keep Textures" enabled it would, you know, keep textures with the file.  

Share this post


Link to post
Share on other sites

I think the texture files are stored in the native fmz file when "Keep Textures" is selected for easy transportation but not in an export format.

If it is not selected, the file is smaller but the paths to the textures can't change otherwise you have to relink.

From my experience any FormZ file which is exported to another format such as FBX will have to be relinked when imported again but the materials will be there for all the objects so re-assigning the textures to those materials will need to be linked again to the textures. I also think this is normal as I have to relink textures even in another 3d package after an import.

 

Des

Share this post


Link to post
Share on other sites

With a clear mind this morning, I thought to try "Save A Copy As..."  to save all the textures with the .fmz file.  I did this saving directly onto a flash drive to open on another machine but only the .fmz is saved.  I assume the "Save Textures" option just bakes them WITH the .fmz file, which is not helpful in my case.

I think formZ needs to have a "Package" option where the formZ file is saved with a folder of textures and re-links them.  I believe this would solve this exporting problem when moving to different locations.

And an ability to automatically re-link textures in a given directly after one file is re-linked would be more than welcome.

Share this post


Link to post
Share on other sites

'Keep Textures' needs to be taken out to the pasture and 'retire'...

It's trying to copy a silly SketchUp like function where all your texture maps are stored inside your .FMZ file.  This is really awful as soon as you add any decent sized modern map, and will cause issues ranging from missing maps to general slowness and sluggishness of the project.  I really wish FormZ would stop including it, or at very least do not have it enabled by default.  It was a bad idea to copy and implement in v7 and is a bad idea to use in practice unless you are using only very basic geometry and low resolution maps.  Disable it and also move the 'File Optimization' slider all the way to the left 'Open Fast' which also means 'Save Fast', and you'll find a much faster saving and working FormZ since its not trying to use unnecessary compression that makes no sense in 2019 when GB are cheap.

Learning 3D initially in other programs like Rhino, taught me to always create a set of 'Project' folders with all of my various maps, and renderings, SEPARATE from my FormZ file. This makes exporting, editing, sharing, etc those files much easier when the time comes.  Save A Copy As... is great for collecting maps you pasted with objects from other projects or overwriting your textures in your maps folder, but can lose maps if they are using the silly 'Keep Textures' option.  SNOW, I believe this is your problem as you have 'Keep Textures' enabled.  Try creating a new project with Keep Textures turned off.  Then Copy and Paste everything from your old file into this new file.  Now Save a Copy As ...with Referenced Maps enabled.  That may help you to automatically gather and relink all your textures!

If that still doesn't work, you can also try using the 'Recreate Missing Textures' under the File>Project Info>Linked Files.  

And Finally, you can try and add a Folder directory where FormZ will search for the texture files.  Edit>Preferences>File Search Paths  Use the + button, and pick your project folder (or higher) where the texture maps should be located.  Enable Search Nested Folders, Full Search if you are using a fast SSD, that way the slowness will be mostly unnoticeable.  If you are using an old 'normal' platter disc hard drive, You may not want to enable this, as it can take a while to crawl through all your folders depending on where you picked for your start path.

Hope this helps someone! 

Share this post


Link to post
Share on other sites
On 4/30/2019 at 5:42 AM, snow said:

they don't show up when exporting to FBX for render

Hello snow.

Did you check export options?1868236225_FBXExport.png.b133b0bce3d8e923d05936e39e9312f6.png

Share this post


Link to post
Share on other sites

Yes this was checked.  The overall problem is that the formZ file was no longer linked to my texture maps even though they showed up in the model.  If they aren't linked they won't export... at least that's the problem I'm having.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×