Jump to content
AutoDesSys Forums
santa

Image Options

Recommended Posts

Does the display menu include "Image Options" in non-renderzone installations? I'm looking for a way to control image size with the shaded full display.

Share this post


Link to post
Share on other sites

I think there is a limit of 2048 x 2048 when you save out from Shaded full and shaded work.

Share this post


Link to post
Share on other sites
7 hours ago, Des said:

I think there is a limit of 2048 x 2048 when you save out from Shaded full and shaded work.

Yes, I remember that dialog. I seem to recall that it is a limitation of your graphics card and it's open GL driver. I believe that it can be disregarded though.

Share this post


Link to post
Share on other sites

Yes, the size does seem to be dictated by the video card. I regularly save out very large Full Shaded images with AO and shadows.  On my current project I am exporting 8192x4096 images, far beyond the resolution on my display. 

Share this post


Link to post
Share on other sites

setz, sounds like you have a beefcake of a graphics card! How do you control the jagged shaded full shadows at such large sizes? Is your card helpful in taming them, or do you simply avoid any that are up close? I have all the shadow settings up to 11, but those jaggies simply won't budge!

 

Share this post


Link to post
Share on other sites

Santa,

Make sure you don't have large plane objects casting shadows, such as the ground plane. Select the object and make sure that you deselect shadow casting see below. Also, Idk where you get 11 for shadow settings.  

crisp shadows.jpg

Share this post


Link to post
Share on other sites

Thanks for the suggestions allanjl, but I have already done both of those things. Distant shadows look acceptable, but ones close to the viewpoint are very jagged. In your example, move the camera close to the object, and see what the shadow looks like! Not nice, I can tell you.

The reference to 11 was my attempt at humour! People usually refer to things on a scale of 1 to 10, with 10 being the maximum, or the ultimate etc... Well, 11 is even beyond that. Anyway, I'll stick to my daily job, which, thankfully is not being a comedian!!

Share this post


Link to post
Share on other sites

What is the scale your working with? It sounds like you're dealing with very small objects? If so, are there other objects in the scene very far away or very large? That may contribute to the problem. Why do you need the camera to be so close to the object and its shadow?

I deal with architectural projects of various sizes; and very seldom are the shadows a problem like you describe. If and when they are, and I need an image of crisp shadows, I do not use full shaded display; I render in Vray. It usually takes as little as seconds to render the image.

Share this post


Link to post
Share on other sites
Posted (edited)

santa-

Have you tried exporting a JPG image of your Shaded Full view?  I've noticed that the shadows get smoother when you export the image than they are on the screen preview...

Also, what kind of GPU do you have?  Some low end cards will not be able to handle modern Open GL smooth shading...  Anything Intel will not work well, and it should be a dedicated GPU with more than 4gb of VRAM.

If your GPU meets these standards, make sure you have 'Use Advanced OpenGL'  turned ON under Edit>Preferences>OpenGL>Use Advanced OpenGL

Let us know how that works out for you.

Cheers.

Edited by Justin Montoya
more info

Share this post


Link to post
Share on other sites
On 4/13/2019 at 1:54 AM, santa said:

Thanks for the suggestions allanjl, but I have already done both of those things. Distant shadows look acceptable, but ones close to the viewpoint are very jagged. In your example, move the camera close to the object, and see what the shadow looks like! Not nice, I can tell you.

The reference to 11 was my attempt at humour! People usually refer to things on a scale of 1 to 10, with 10 being the maximum, or the ultimate etc... Well, 11 is even beyond that. Anyway, I'll stick to my daily job, which, thankfully is not being a comedian!!

"...these go to 11."

this plug was not lost by all lol.

Share this post


Link to post
Share on other sites

Thanks snow! I am glad that my attempt at humour didn't go over everyone's head! Thanks also for my very first like, if it was left by you! I was beginning to feel like the runt of the litter!

Share this post


Link to post
Share on other sites

I use Soft Shadow, Massive Map, and I turn off shadow receiving and casting on as many objects as possible to maximize the quality of the map.  Sometimes shadows get thin where small objects touch the ground but I live with that.  Turning off visibility of objects not seen in the view can also help with quality.  Whatever issues are left are quickly cleaned up in Photoshop.  It's also to be noted that I use these images for getting design approvals rather than as finished Client Renders.

Using a GeForce 980TI so decent, but not crazy hi-end video card.

Share this post


Link to post
Share on other sites

Justin, up until a couple of days ago I was trialling Form.Z on a HP ZBook with a 4GB Quadro graphics card. After an 18 year absence, I am once again returning to Form.Z, and am in the process of registering with sales.

As soon as I get the chance, probably over the coming Easter break, I will install Form.Z  on "the beast", which is my Dell T7910 workstation with two 18 core Xeon processors (72 threads in all), 128 GB of ECC RAM, and two Quadro graphics cards containing 12GB of RAM each (24 in all).

I do not expect that this will resolve the shaded full shadow issue, however. Shaded full is a rasterizer, not a raytracer and in all probability, the jaggies will persist. Only a complete rewrite of the code will fix it, which I do not see happening. Other rasterizers, such as Eevee, do a much better job I'm afraid!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×