Jump to content
AutoDesSys Forums
David Lemelin

interface lag on MacOS

Recommended Posts

I'm posting this in hopes someone else has experienced a similar issue. I am running FZ 8.6 on MacOS, with 16Gb ram and a quad-core i7 processor MacBook Pro. It's not the most powerful machine as it's a few years old, but it has always managed all my 3D needs with decent reliability.

I'm having a frustrating experience with a file. It's not an especially large file, but it is one that has been evolving from job to job over a number of years as my client adjusts his design twice a year. There are a few outside models of stools and some billboard plants, but otherwise, the model is all generated in FZ over a sequence of about 3 years.

 

At this point, I'm simply trying to draw a rectangle from a snapped corner to another... and every time I move the cursor I'm staring at that bloody spinning wheel. The task manager alternates between "not responding" to 99.9% of CPU use... but ALL I'M DOING is creating a basic rectangle. From the first click trying to snap to a point, to drawing out the rectangle, to the final click to complete the shape... each step gives me the spinning ball. Needless to say, it's getting extremely frustrating.

 

I've turned off every layer and item not in use, to no avail. Even panning around the scene is jerky and imprecise. I'm using shaded display mode. Wireframe is a bit better, but it's hard to model with every vertex visible.

Do I need to re-model every legacy model every time I need to work in order for FZ to behave at a professional level? The issue is even worse on my Windows machine. Despite using a 16 core Threadripper CPU and 2 Titan X video cards, navigating around the model is like playing flight simulator on a 386PC from the 90's.

 

Any ideas would be welcome before I completely lose patience.

Edited by David Lemelin

Share this post


Link to post
Share on other sites

I will give the Object Doctor another shot... I typically run every imported model through it, but it's worth a try.

As for the snaps, I have turned off all except the one I need... Unfortunately, that's not the secret :(

Share this post


Link to post
Share on other sites

It sounds like your file has gotten mangled over time.  When all else fails... 

Open a new project and Copy and Paste all of your objects to the new file, save as a new file name.  Close the old project.  Then use the open command with the 'Add to Project' option to select your lights and views from your original file.  

I haven't had to do this in a while, but it used to happen all the time with 'older' FormZ files, so it might be worth a shot!  Good luck

Share this post


Link to post
Share on other sites

I have also noticed a decrease in performance with small models. Just rotating the view in shaded work causes jerky motion. It seemed to start after upgrading to Mojave.

I am @ Build 10163 on an iMac 10.14.1, 4GH Intel Core i7  32GDB Ram.

 

Anyone else?

 

Joe

 

Share this post


Link to post
Share on other sites

Have you checked Activity Monitor to see what's eating CPU cycles or memory? Sometimes apparently random slowdowns can be caused by things like Spotlight indexing. Try turning this off for a while to see if there is any improvement. Other stuff like  Apple Photos can do things in the background which hog resources and if you have a large sync job going on with the cloud that too can affect speed.

Share this post


Link to post
Share on other sites

Since he said it also happens on his Windows workstation, I highly suspect the file has something wrong with it.  Unfortunately, you will likely need to try rebuilding the file like I mentioned above.

Also, make sure the file does NOT have 'Keep Textures' enabled, as is stupidly enabled by FormZs default installation.  To check, with the file open, go to File>Project Files> Keep Textures box should be unchecked and the File Optimization slider should be 3 notches from the 'Open Fast' side.  I was told this is the best position from AutoDesSys themselves...

Share this post


Link to post
Share on other sites
23 hours ago, Justin Montoya said:

Since he said it also happens on his Windows workstation, I highly suspect the file has something wrong with it.  Unfortunately, you will likely need to try rebuilding the file like I mentioned above.

Also, make sure the file does NOT have 'Keep Textures' enabled, as is stupidly enabled by FormZs default installation.  To check, with the file open, go to File>Project Files> Keep Textures box should be unchecked and the File Optimization slider should be 3 notches from the 'Open Fast' side.  I was told this is the best position from AutoDesSys themselves...

You are right - I missed that!

Share this post


Link to post
Share on other sites
1 hour ago, Justin Montoya said:

Looks like MacOS Mojave should be avoided for most 3d users, especially if you are using an Nvidia GPU...

https://www.forbes.com/sites/marcochiappetta/2018/12/11/apple-turns-its-back-on-customers-and-nvidia-with-macos-mojave/amp/

All the more evidence that Apple could care less about it's 3d professionals.  

I suppose that it is possible that Apple will surprise us all in 2019 assuming they give us a new Mac Pro as promised. However, I have been rather p'eed off with the way desktops have been treated and as a result, I have been looking at building a Windows machine. The trouble is, I gave Windows up in 2006 and I basically still hate it but there is no doubt that more software of the kind I want, available for Windows. 

I do have both Parallels and a Vmware VM of Windows 10 but I find that CAD programs do not run very well on them, the graphics hardware in my iMac 2015 5k machine isn't sufficiently powerful.

Share this post


Link to post
Share on other sites

I am experiencing similar issues. I find that turning off snaps vastly improves performance. I always use object doctor and project doctor these days. I find that even after fixing a model or assembly and saving, making changes to the file or scale will create new problems in an object that need to be re-fixed. I've also found that with Mojave, Apple related issues such as saving a simple JPEG rendering is unstable. The app will crash after exporting the file. I started saving TIFFs a week ago and its been way more reliable.

One thing about JPGs for Support. After all these years, why cant FormZ use a JPG with Progressive compression as an image maps. MANY folks save images with that JPG scheme these days. It just seems like that should have been dealt with a long time ago.

For Apple users, I think some of the blame goes to Apple. They been messing with so many parts of the OS, I dont know how developers can deal with the mess.

Share this post


Link to post
Share on other sites

Snap to Intersection can cause serious speed issues due to the millions of possible intersections in complicated files.  The solution to be able to use this invaluable feature is to (with key shortcuts cmd+I and cmd+R) Isolate objects to be snapped and then Reveal all when the operation is complete.

Justin - I always save files using Open Fast, I autosave large files often and I don't like the delays while FZ is saving.  Is three notches over working well for you?  I will try it for awhile to see how it goes.  What was ADS' reasoning for that position on the slider?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×