Jump to content
AutoDesSys Forums
pipo

obj import issues

Recommended Posts

why do obj files importing with all the fz materials showing as 100 per cent transparent ?

I am needing to go through large and complex models with many materials on import and change the transparency back to zero percent to see the model in any

shaded mode

 

Share this post


Link to post
Share on other sites

This has been an issue for many years now.  Translations of materials from other programs has always been an issue in FMZ.  I wish there was a simple solution to this problem but I am afraid that it may never get solved.   Are you receiving models from clients or downloading models from websites like TurboSquid?  If they are coming from clients have them send it in a different format like 3ds or fbx.  If they are coming from a website see if they have them in FBX.  Then there is also this free online file converter that I have used in difficult situations:

https://www.yobi3d.com/3d-file-convert

The file size has to be below 40MB which is unfortunate for larger models.  My other go to solution is to import it into a different program first and then into form.z.  I keep around an old version of MAX for this purpose as well as a few others.

Curiously I have found on occasion that some models  I get in OBJ translate perfectly into FMZ with all materials properly mapped and no transparency issue.  I guess it is how that person texture mapped the object or how they saved the maps.  I really should study those models to see what it different about them. 

 

Share this post


Link to post
Share on other sites

Thanks Andrew

Yes , it has indeed been an ongoing issue

Sad to hear it can't been rectified

Obj files come from many sources , admittedly this is not a concern with every file , unfortunately a majority though !

Share this post


Link to post
Share on other sites

Sounds like you just need to adjust the material parameters for the large number of materials that came into FormZ with the OBJ import?  I understand that is an annoyance, but it really shouldn't take you more than a few minutes to adjust if you leave the Material Parameters window open and click on each material in the Materials palette, adjust, then click on the next material.  

It would be nice if our Import had an option to set the shading to our default values for the imported materials, but it would still require adjusting the materials for our rendering engines though, so I'm not really sure how much time you would really save. 

Unless the people providing the imported files are working in the same rendering engine, it's unlikely that you will ever NOT have to adjust the materials when you bring them into FormZ, or any other 3D program other than the originally used program.   Working with the new VRay vrmat materials has helped this, but ultimately all these various programs use their own proprietary material handling, so it's just going to be a part of life it seems.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×