Jump to content
AutoDesSys Forums
swaim

Turning off shadow "casting and receiving" in Maxwell.

Recommended Posts

This is a subject we have touched on briefly last spring but now it's a little more important. I need Maxwell to render with full global illumination with out the shadows. RenderZone does this absolutely beautifully, however, with the size of the project and number of objects in my scene, I can not wait for 4 days for RZ to render the scene. I need to use Maxwell so I can send it on to a Farm to render in an hour or so. Last spring Pylon gave me this option....."In Maxwell, disabling shadows is per-object, not per-light or per-scene. With the Pick tool, select an object which you do not want to cast shadows. In Pick Tool Options, Attributes Tab, select Maxwell Attributes... from the pulldown menu. In the resulting dialog, select Hide From > Global Illumination.

If you want to apply the same Maxwell Attributes to multiple objects, you can set them up on one object, and then use formZ's Copy Attributes tool to propagate to other objects."  

This did the trick on turning off the shadows, but unfortunately eliminated all the great bounced lighting and the scene renders in flat shades similar to how RZ would render with out Final gathering and Ambiant Occlusion. 

 

In short: How do I get Maxwell to render with global illumination with out shadow casting?

Share this post


Link to post
Share on other sites

Hi Swaim,

 

Yes, disabling GI for an object will eliminate that object's bounced light as well as shadows. Therefore, disabling GI for all objects will effectively eliminate all bounced light in the scene.

 

Please post an image of what you are trying to achieve (perhaps a lower-res version of the Renderzone render), so we can see the "look" you're after and advise.

Share this post


Link to post
Share on other sites

I think you could get something similar by opening your light parameters and unchecking "sun", you will still get the ambient occlusion effect you are looking for.

Also, select the shadow channel in maxwell display options (even though the sun is off) and you can bring that into photoshop in a separate layer to adjust it's strength.

 

Des

Edited by Des

Share this post


Link to post
Share on other sites

I agree with Des.

For an physical rendering that approximates the look of a biased 'ambient occlusion' rendering, use a Sky Dome with the sky top set to white, with the sun disabled. (You could also use any other sort of diffuse light source.)

For more control, enable the 'Shadow' checkbox on your object material, enable the shadow channel in Maxwell Display options, and then composite to suit in photoshop.

 

Share this post


Link to post
Share on other sites

Thanks guys. I tried the Sky dome, that seemed promising until I realized the light source changed from my original Physical sky lighting. So that was a no go. Then I scratched my head over the channels option and never could figure that out. I rarely use channels in PS. so I didn't know where to start to learn how that worked. but it sounded real promising. BUT THEN..... THEN.... out of a complete click fluke... In the lighting parameters I right clicked on my physical sky light and a drop down menu popped up... and there it was, the option to turn shadows on or off. So I think I may be in business.

post-9626-0-49696300-1503602360_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×