Jump to content
AutoDesSys Forums
Sign in to follow this  
ktejlgaard

Shadows through "HighGradeGlass"

Recommended Posts

Hi Ive spend hours trying to figure out why I cant see shadows cast from "HighGradeGlass" properly when looking through "HighGradeGlass" (see image)
The shadows cast from the glass get all black when wieved through the glass. I can get around it by using AGS but Im loosing detail on the shadows and reflections by doing so.
How can i get proper shadows when looking through the glass?

Kristoffer

post-16872-0-28113700-1503509918_thumb.png

Share this post


Link to post
Share on other sites

High Grade glass objects need to be solids modeled to the correct thickness, just like glass in the real world. (i.e, not a surface as you would use for AGS.) Is your model set up this way?

Share this post


Link to post
Share on other sites

Each sheet in the dome is modelled as a solid with a thickness of 6mm. (like the real thing)
I tryed the same render with simple blocks, and got the same problem

Share this post


Link to post
Share on other sites

Hi,

 

In Maxwell Object Attributes, enable the Hide From -> Global Illumination on the glass objects. Does this help?

 

(If not, please export your scene and send your MXS and MXM to Next Limit support; perhaps they will have an alternate solution for you. https://portal.nextlimit.com/ )

Share this post


Link to post
Share on other sites

Hi,
Hiding from GI is part of the "work-around" and then having an additional object with AGS that is hidden to the camera, casting the shadows.
But it seems wrong that I cant use the proper shadows cast from "HighGradeGlass" because they cant be seen through the glass itself?

Kristoffer

Share this post


Link to post
Share on other sites

I agree. Please contact NL support (see link above) and provide your MXS and MXM as examples. This is not a formZ-plugin specific issue, so don't include your formZ project, or they will kick it back to me. ;)

Share this post


Link to post
Share on other sites

post-36-0-58989000-1503618968_thumb.jpgHello,

Adjust the transparency setting in your MXM to a higher number and a greater amount of light will pass through your glass (and then, in effect, the glass will not cast a shadow). If you enter a transparency value greater than the size of your object, I believe 100% of the light will pass through it.

 

Gary

Edited by Gary

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×