Jump to content
AutoDesSys Forums
Spacer

Merginng Problem "CPU ID s are the same"

Recommended Posts

Info on MXI Merging in the Maxwell docs:

http://support.nextlimit.com/display/maxwell4/Cooperative+rendering.+The+Merging+process

 

By default the render is initialized to a random value when the rendering starts. It is useful for rendering the same MXS file on different computers that are not networked together. The resulting MXI files of each render can be copied manually to the same computer and merged in Maxwell using File> Merge MXI. Each resulting MXI must have a different starting seed for the noise pattern to be slightly different in each MXI, otherwise the merging of MXI files will not work correctly.

 

 

As a random seed for each rendering is required for MXI Merging, this is the default behavior. it is not possible to have the same seed on two different renderings unless you invoke the command line flag -idcpu. (Again, there is no need to set this, it provided for advanced use only.)

 

As to how you have two MXIs with the same seed, I can only speculate unless you provide further information about your rendering context: Most likely, it's actually the same rendering- a copy under two different names. Or if the SL is different, perhaps it was rendered to a lower SL, a copy was made, then allowed to render to a higher SL. Or, perhaps you set the -idcpu parameter in the command line, in which case this would be the expected behavior?

 

If none of these sounds right, can you provide some more context?

 

So, to your question: Since the CPU ID is responsible for the specific noise pattern in the generated rendering, it's not something that can be changed after the rendering is complete. To make a new rendering with a different random seed, just open the MXS in Maxwell and render. Note the displayed CPU ID just below the "Multilight" pulldown menu. (If you want to confirm that each render is assigned a random seed when the file is opened, close the MXS, then reopen it and inspect the CPU ID field again.)

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×