Jump to content
AutoDesSys Forums
Sign in to follow this  
Kimdo

Please help, how to export file to DWG in scale?

Recommended Posts

Hi,

 

May I know how to export a formZ file to DWG in scale please?

 

I have built a 3D exhibition model in formZ 8.5 and want to export different views with dimension to Ai. I tried to export the top view in DWG format and it worked. However, it was not working for front, side and iso views.

 

May I know any setting or advises for me to fix this problem? Thank you so much.

 

Kimdo

Share this post


Link to post
Share on other sites

Kiddo,

 

As formZ is a 3D modeler, the data that is exported to DXF/DWG formats will be 3D. You will find that you actual have 3D data if you open the file in AutoCad (the default view in AutoCad is "top" or plan, so it may not be obvious at first). We are not sure how AI handles the 3D data, you may in fact have many overlapping lines.

 

The best way to export different views of a model as 2D data is to use the formZ Layout app (included with formZ pro). In layout you can create sheets wth the views that you desire (side and iso views). You can then export to DXF/DWG from layout and you will get the 2D data you desire in AutoCad or AI.

 

Another approach is to export from the formZ modeling environment to a vector image format (eps, pdf or DWF). These export formats are available in the Export Image menu in the File menu. This method will give you 2d data based on the view on the screen at the time of the export.

 

If you need further assistance, please email support@formz.com

 

Thanks!

Share this post


Link to post
Share on other sites

Kimodo,

 

I do this all the time.

 

Build a box around your data that you know what the size is.   Then in AI, you can use that to build your scale.

eg.   the box is 20' x 30' on edge.

 

in illustrator,  select everything, then make it 20"   or 20cm or what ever you want your scale to be, and it will be so.

 

¢£

Share this post


Link to post
Share on other sites

Dear ALL,

 

Thank you so much for your reply and advices. I tried the Layout mode and it worked. However, the dimension, dots and units were converted in lines while imported into AI. Hence, I could not change the figure. 

 

May I know if formZ can keep the unit while exporting to DWG? Thanks a lot.

 

Kimdo

Share this post


Link to post
Share on other sites

Hi Kimdo, 

 

Try this: Create Frames of your file in Layout at the desired scale.  Go to File > Print, set scale to 100% and check Vector Output.  Click on Print Settings and adjust your paper size and click Save.  Now click Print, click on the drop-down menu that says PDF and select Save as PDF, click Save.  Open the PDF in Illustrator (you will probably have to release the clipping mask).  Granted, this isn't DWG, but it should allow you to export to a vector format at your desired scale for editing in Illustrator.

 

Does this help?

Share this post


Link to post
Share on other sites

Dear Tech,

 

I tried to print it as PDF format and select Vector Output but the units are displayed in lines. Please see the attached screenshot. May I know if I have did any wrong?

 

Thanks

 

post-889-0-77437200-1491368176_thumb.png

Share this post


Link to post
Share on other sites

Kimdo, 

 

Which display type are you using, wireframe or hidden line?  Can you post this file and a screenshot of the options you used when printing so we can reproduce the problem here? (or send it to support@formz.com)

Share this post


Link to post
Share on other sites

Hi Tech,

 

I haven't used hidden line. I imported the formZ file by frame in the Layout mode. And the units/dimensions are changed to lines once the formZ file was imported. 

 

May I know if there is a video tutorial or step by step tutorial for this? Thanks for your help.

 

Kimdo

post-889-0-56329400-1491441096_thumb.jpg

post-889-0-51677500-1491441117_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Kimdo, 

 

Are you able to dimension your objects using only Layout?  This will prevent text from coming in like that and it will also prevent unwanted artifacts from other views (you can see the dimensions in the front and side views, which probably aren't ideal when making these kinds of drawings).

Share this post


Link to post
Share on other sites

Hi Tech,

 

Do you mean all dimensions should be done in the Layout frame page, in stead of formZ mode or Drafting mode? And I should not import the drawing with dimensions into the Layout frame?

 

It is a bit misunderstanding. For a professional drawing software, I guess all objects with dimensions shall be able to export with text and dimension. :-(

 

May I know if the future versions of FormZ will improve that?

 

Thanks 

Share this post


Link to post
Share on other sites

Hi Kimdo, 

 

The dimension text should not look like it does in your screenshot and this issue needs to be fixed, there is nothing wrong with your workflow here.  We will get this corrected, thanks for your report.

 

As a workaround, all dimensions of your objects should be done within formZ Layout after you import the views of your geometry via Layout Frame.  This is ideally the purpose of formZ Layout--to take certain views of 3D models and seamlessly import them into a fully-functional drafting environment.

 

Also, the Drafting mode/workspace in the formZ application is a way to simplify the toolset should  you choose to do any drafting in the formZ modeling application.  However, because of the issue at hand, we recommend that if you decide to do this that you do not import these views with dimensions in Layout to prevent the improper text from appearing in the Layout Frame.

 

Does this help?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×