Jump to content
AutoDesSys Forums
archigraphica

unselectable geometry

Recommended Posts

Here's a pretty common (once a day minimum) problem. The attached screenshot shows a piece of unselectable geometry that's generated after any number of operations. I used Cntl-A to select everything to show it was indeed not selectable.  This one was came from using the reshape tools. I haven't pin pointed which tools cause it and which ones don't but the reshape tools are pretty common causes.  The only way I've found to fix it is close the file and reopen it.  Then you can select the geometry and delete it.  Not a huge problem just a workflow speedbump.  

 

thanks

post-177-0-50761100-1481640769_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Archigraphica,

 

Sorry you are having trouble, but  we have not heard of this before.  If it ever happens again, Undo to make the object selectable again, save and close the file, then reopen it and try to do the same operation again.  If you reproduce this, then please send the "before" file and the steps causing it so we can investigate this further and help.  ;)

Share this post


Link to post
Share on other sites

MacPro 2010

OSX 10.9.5

FZ 8.5.6

 

Make a cube, begin a reshape inwards.  Mid operation CMD click to change direction (surface-ref pane) and then hit escape prior to committing edit.  A non-seletctable solid is created. Save and reopen to make new object selectable.  I too often create these types of objects.

post-176-0-23322900-1481645501_thumb.jpg

Share this post


Link to post
Share on other sites

In addition to the above, If you make a cube, Reshape and change the direction mid-edit, commit the edit with a click , an then Undo the operation, a new non selectable object is created as well.

Share this post


Link to post
Share on other sites

I also confirm it and I think it happens since version 7. It's not very frequent but it's pretty annoying.

 

My temporal workaround, to not save, close and reopen to delete, is select all and isolate to hide temporary these unselectable objects.

Share this post


Link to post
Share on other sites

Gentlemen,

 

Thanks for the notes that you have seen this before, and especially thanks to Setz for submitting a report as to how to make this happen, since this is exactly the info we need to be able to identify and fix it...

Share this post


Link to post
Share on other sites

Good deal. Since you can reproduce it we can finally get it fixed. Let me throw another issue in that would be great to have fixed in the next patch:

 

I'm going to email you a zip file. This has also been happening since 7.  And since it happened again today now's a good time to bring it up again. When exporting to 3DS (and other formats) smooth geometry is not always exported in the file. I have to select everything in FormZ, convert it to faceted/plain geometry and then export it.  And yes, I've reported this before. In the zip file I will include the original FMZ file, an exported file missing the smooth geometry and a converted model that includes all the geometry. thanks!

Share this post


Link to post
Share on other sites

Hi Archigraphica,

 

Well, if you have reported something before, you don't need to report it again, but it is good to make sure we have an example where this occurs, so please send it and we will check it out. ;)

 

(Note that we should only need a file with the smooth object(s) that are not working to test it here...)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×