Jump to content
AutoDesSys Forums
R2D2

GPU error while rendering

Recommended Posts

Suddenly my GPU drops while rendering in darkroom / FZ, leaving only the Cpu. (So from Devices=2 to Devices=1)

This happens after roughly 30seconds - 1 minute. ( I have tried using higher time limit and sample limit for Presto MC - this does not work anymore)

 

From that point I only get 1 device when starting darkroom again.

Quit and restart formZ on first rendering GPU/CPU (2 devices) appear again - but only for short time as described above

 

It also is persistent when I export the scene to Studio, just stops.

Other scenes (i.e. meccano plane sample) keep rendering on 2 devices fine in Studio.

 

Everything worked fine using Darkroom in FormZ before, I just set 5 minutes and it rendered all the way.

 

Question is how can I fully restore Thea prefs - or did I accidentally tick a wrong checkbox somewhere...?

OSX 10.11.6 Thea V1447

 

Log output:

 

Presto Engine: using cpu driver /Applications/formZ 8/formZ Pro/Plugins/TheaRender/presto-x64.cpu.dylib

Presto Engine: using driver with revision 1447
Presto Engine: using gpu (cuda) driver /Applications/formZ 8/formZ Pro/Plugins/TheaRender/presto-x64.cuda.dylib
Presto Engine: using driver with revision 1447
Device #0: GeForce GTX 980
Building Environment... done. (0.129 seconds)
- Polys: 109898, Objects: 666, Parametric: 0
- Moving: 0, Displaced: 0, Clipped: 0
- Instances: 0, Portals: 0
- Nodes: 25881, Leaves: 25882, Cache Level: Normal
Device #1: Intel® Xeon® CPU           W3680  @ 3.33GHz
Device #1: memory 240/?/24576 Mb
Device #0: memory 238/982/4095 Mb
Error: Device #0 encountered an error during rendering
Device #0: 22x4 s/p
Device #1: 13x4 s/p
Finished in 53 seconds!

post-1027-0-80368200-1480339987_thumb.jpg

Share this post


Link to post
Share on other sites

Reinstalled FZ an Thea - no luck.

Can anybody point me to the Thea prefs files I have to delete to really reset everything ?

Somewhere in OSX/  ...preferences/caches/application support ... hidden files  ?

 

Share this post


Link to post
Share on other sites

Hi, 

 

We are in contact with R2 regarding this issue through e-mail. I will update this thread with our findings.

 

 

 

This has happened to me periodically, but a reboot always fixes it.  

 

You will get a faster response emailing them - 

 

formz@thearender.com

 

 

Hi Justin,

 

From past experience with other plugins we know that this could be related to the presence of certain elements in the scene. If there is a thea scene file that gives that message (Device encountered an error during rendering) that you could share with us it would be greatly appreciated.

 

Share this post


Link to post
Share on other sites

Hi Manolis!

 

Will do.  I seem to remember the last time this happened, I tried opening another basic test file which I knew should work correctly but did not.  Since the issue existed there, I figured a reboot was required and that's all it took.  I'll keep an eye out for it again though since I am currently working with Thea on my new design projects.

 

Thank you for your help!

Share this post


Link to post
Share on other sites

I tried El Capitan and Sierra OSX versions with different Geforce GTX Cards and Nvidia drivers to find out what the cause might be -

but in the end this "oldschool" approach brought back rendering functionality:

Make a new file > Open > tick "Add to project" and "All on". That file then renders fine in Thea again. 

(We found a bad object that caused the Thea error in the log, but it does not seem its also the cause of the GPU stopping). 

Maybe if Thea/FZ Support find out more they will add it here, for now it seems (to me) that it was not related to Thea (or GeForce/hardware/drivers/OSX/prefs).

Share this post


Link to post
Share on other sites

R2,

 

Yes, if you have a file that is not rendering properly, please send it to Solid Iris so they can help (and if they need us to adjust something, they can let us know)... 

Share this post


Link to post
Share on other sites

Guess I spoke to soon... this keeps happening on and off with my files.

 

There seems to be an issue between Thea and FormZ when accessing the RAM of the GPU (as this also gives Thea log errors sometimes).

This shows when using Thea darkroom, and is related to FZs display settings:

When I start a rendering coming from full shaded, often the GPU stops or does not even start in.

Reducing shadow quality and texture resolution in full shaded options seem to free up the Ram Thea needs for darkroom.

Same goes for shaded work mode. Even wireframe setting seem to have an impact here.

 

And resolution in darkroom is also to be considered, sometimes I can not render cpu/gpu at "FormZ window" size but I can at -say- 1024/xx resolution.

(I am using an apple 30" (2560 x 1600) as my main screen)

 

This all is not clearly reproducable but I have now tested two different files, and changing shaded settings and darkroom resolution settings without saving or quitting sometimes renders using devices=2, sometimes not (or shortly after start falling back to devices=1).

 

But switching to wirframe prior to using darkroom is not a clear solution as sometimes it will still not work (going from 1280 to 1024 to 800 to 768... in darkroom) Then I switch between shaded and full shaded a few times and suddenly darkroom works at 1600 again....

 

(Or: I place one of Theas trees in a new file: it renders on cpu only. I surface scatter the tree 50 times on a plane: it renders 50 trees in 2 minutes....using devices=2) But the next day the same file does not work. ("out of memory- additional memory required 50MB"

 

Maybe this is helpful somehow.

Thx

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×