Jump to content
AutoDesSys Forums
Sign in to follow this  
Anwar

formZ Still SLOW...

Recommended Posts

Hello,

 

I recently upgraded my formZ 6.6 to 8.5 and I am finding that it is still abysmally slow at some things.  First, I am running on a reasonably powerful PC:

 

-Core i7 6700HQ Quad Core CPU (2.6-3.5GHz)

-32GB RAM

-NVIDIA 1070 Graphics with 8GB RAM

-1TB SSD + 2TB HDD

-Windows 10

 

This is a "VR" ready PC!

 

Even with these specs certain things which should be speedy are slow.  Most notably, I have several model files with facetted geometry which contains 10,000 - 100,000+ faces.  When attempting to move these objects the whole system freezes and I eventually have to kill formZ.  I can't even move some objects!

 

Why is it still this slow? I'd hate to think would it would be like to use a CAD underlay...

Share this post


Link to post
Share on other sites

Dear Anwar,

 

formZ 8 should be faster than v6 in general but if you have a case where something is not as  fast as you would like, please send and email to support@formz.com and include a file (or a link to a file) where you observe this and we will test it and see what we can suggest.

 

Note that if you are noticing this when you are drawing or moving objects, certain Object Snaps like the Intersection and / or Key Point Snaps can be a bit computationally intensive, so turn off these snaps if they are not specifically needed.

 

Display Options like Silhouette Edges can also make things a little slower, so you can also try turning this option off to see if it makes things faster for you.

 

If you still have issues, please send a file so we can test with it here and see what else we can do.

Share this post


Link to post
Share on other sites

Hi Anwar,

 

Yes, you can upload them via any internet service like Dropbox, or you can upload them here:

 

ftp.formz.com

name = dropbox

password = i87gdl

 

If you upload to our dropbox, please send us an email with the name of the archive once the upload is complete so we know to check it.

 

Thanks in advance.  ;)

Share this post


Link to post
Share on other sites

the interface is slower but the program does a ton more. Think of it as it lost some Torque but doubled the horsepower. I had a hard time adjusting my 6.X workflow but once I got it figured it I wouldn't go back.

 

Couple of suggestions:

-turn off the selection preview on bigger files.

- Keep the workplane locked when possible. Bigger files can really slow down if you're continuously moving that interactive plane around.  Smaller files it's not a big deal.  

-Try to clear out any 2D imported geometry (CAD files) when you're done with them.  They really slow things down.

-I also try not to boolean as much together as I would of in past versions.  The Reshape tools (while fantastic) really take a hit on more complex geometry. It's like Z runs out of memory on certain large objects and it can take a second or 2 to catch the preview up.  (I have a Titan X 12gb card so that's not the problem)  

- the insert "check box" gets REALLY slow when dealing with even moderate geometry. if it's acting slow go back to boolean'ing out geometry like in 6.X.  

 

And finally when it gets really noticeable grab all your geometry and drop it in a new file. I don't know why usually works for me.  Good luck!  

 

almost forgot.... tune your display options.  Turn off what you're not using.  that was a big one.

Edited by archigraphica

Share this post


Link to post
Share on other sites

the interface is slower but the program does a ton more. Think of it as it lost some Torque but doubled the horsepower. I had a hard time adjusting my 6.X workflow but once I got it figured it I wouldn't go back.

 

 

Actually the opposite is true.  Think of it as it double the Torque but lost some HP.   Torque does the work, and HP is just a nice number for marketing to use.  HP is just a function of Torque.

Share this post


Link to post
Share on other sites

Dear Anwar,

 

formZ 8 should be faster than v6 in general but if you have a case where something is not as  fast as you would like, please send and email to support@formz.com and include a file (or a link to a file) where you observe this and we will test it and see what we can suggest.

 

Note that if you are noticing this when you are drawing or moving objects, certain Object Snaps like the Intersection and / or Key Point Snaps can be a bit computationally intensive, so turn off these snaps if they are not specifically needed.

 

Display Options like Silhouette Edges can also make things a little slower, so you can also try turning this option off to see if it makes things faster for you.

 

If you still have issues, please send a file so we can test with it here and see what else we can do.

 

Hi Anwar,

 

Did these suggestions -- and those by Archigraphica help with your file -- and if not, did you have a chance to send a file where you are seeing this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×