Jump to content
AutoDesSys Forums
Andre Conlledo

Palettes not displaying properly

Recommended Posts

HI Z

 

My monitor configuration never changes, I have two relatively hi res monitors, one landscape, one portrait.

 

Reset Workspaces, does work but, I loose my customized workspace, so I have to recreate it every time the clipping occurs.

 

If I create a new workspace and give it a name "barts workspace,"  export workspaces, then import this custom workspace it does not fix the clipping issue.

CORRECTION: this IS working now, it did not in the past. 

 

I can still recreate the clipping by invoking the tool manager, dragging an icon up to the tool dock and removing it.

see attached, full screen custom workspace ( both monitors ) tool dock icons clipped.

 

I can now easily fix this by resetting all workspaces and importing a saved workspace.

 

When my palettes all disappear, the only thing that works is going down the palette drop down and checking the palettes i want one by one ( is there a way to toggle more than one without closing the drop down?)

 

this is totally a hunch but I seem to have issues like this when I have another graphics app running at the same time. often AutoCAD or Illustrator - just a hunch.

 

Bart

post-225-0-40580900-1478626555_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Bart,

 

Glad the Reset is now working for you.  If you .can configure it as you like, but it changes later, perhaps you should adjust the settings (once you have it set up as you like) to not save any future changes.  You can do this by going to the Workspace Menu: Workspace Manager -- and unchecking Save Between Sessions.  Then quit and relaunch.

 

We have found a computer where we can reproduce the shortened palettes as you describe.  Thanks for your report, we will get this corrected.   In this case if you remove these Palettes from the Tool Dock and then "wave" the Tool Manager tool icon over the palette, that should also fix it for you in case that is easier. ;)

Share this post


Link to post
Share on other sites

Tried moving the Input Palette out of the Tool Dock and waving the Tool Manager palette over it but it changes nothing. I would rather not create a separate user on this computer -- Is there anything else I can test?

Share this post


Link to post
Share on other sites

Hi Andre,

 

Wave the Tool Manager tool icons (from the top center of the palette) over the Input or other palettes.

 

Beyond that, we are not sure what to suggest...

Share this post


Link to post
Share on other sites

Yeah, I tried that. Moving the icons (not the palette as I said before) - my bad. That doesn't do anything for the the Input Palette but I can see the other palettes changing.

 

On the other palettes esentially what that does is:

  • If broken it'll repair them
  • It not broken it'll break them

Share this post


Link to post
Share on other sites

We will have an update in the not too distant future, but you can download a clean "already updated" version from here if you like:

 

www.formz.com/upate

 

Does that help -- or can you use one of the multiple work-arounds noted above to get around this issue?

Share this post


Link to post
Share on other sites

I have a related issue, I'm quite used to some occasional weirdness with the palette sizes/palette names not displaying in full etc.  I can live with this. But I had to re-set my preferences today for another matter and I am trying to adjust the size of the INPUT palette within FormZ.   It will not extend past a certain point, meaning I can tab across to 'width' OK, but I cannot see past the first digit of 'length'.. Not ideal as I can longer read the dimension I am inputting.

 

I have tried the following with no luck:

 

1) Re-set workspace,

2) Adjust font size

3) Right click on palettes/settings/tool palette settings/change tool Icon size.  This works on most other palettes but not on the Input palette.

4) Adjust preferences/try using old preferences.

 

I cannot drag this palette out large enough to use.  Have you any other ideas to try?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi Pointer,

 

Which operating system, and what is the resolution(s) of your monitor(s)?

 

And can you post a small JPG showing the Input Palette so we can see if there are any other clues there.

Share this post


Link to post
Share on other sites

Hi Tech,

 

I run FormZ Pro 8.5.6 on a PC running Windows 8.1 Pro.

 

I have two monitors, a 4k one as my main work monitor running at 3840 x 2160 and another at 2560 x 1440.  I have used this setup since August 2015 with no real problems.  At first it took some time to adjust FormZ to the 4k screen and set everything up so that text was legible etc. We have three workstations set up like this.  We had to disable display scaling on high DPI settings to get it to work OK.

 

I think I have tried all my usual 'go-to' methods to get around this issue, but I just cannot seem to get the Input palette to extend!  Hopefully a screen grab is below:

 

post-261-0-45921800-1484833151_thumb.jpg

 

Share this post


Link to post
Share on other sites

as you can see I dragged the palettes out of the ToolPalette

 

that worked for me 

 

iMac 27"

10.12.2

fZ 8.5.6

post-19-0-26292200-1484836561_thumb.png

Share this post


Link to post
Share on other sites

Hi Pointer,

 

That palette should not need to expand any further, but if you start doing an operation that has these options (like with a rectangle, vector line, move command, etc), the palette will automatically expand:

 

post-5-0-77565700-1484836505_thumb.jpg

 

So to clarify, when you first get the rectangle (or other) tool, the "length and width" fields will not show until after you have clicked to start drawing the shape.

 

Is this not working for you and / or are there other specific steps that allow you to see the issue?

Share this post


Link to post
Share on other sites

Hi tech,

 

You describe what I would normally expect to happen, unfortunately it is not working like this for me.  It did previous to me re-setting FormZ to the basic preferences this morning.

 

When I start an operation such as drawing a rectangle etc Length appears OK and I can see the word 'width' but beyond that I cannot extend the palette far enough to see the digits!  I have even tried reducing the number of trailing zeros in the hope that I can expand the width of the palette.

 

There are also display issues with other palettes, e.g Display Tools,Navigation Tools etc.  I cannot enlarge any of these enough to display their full content, which I can live with as I don't really use them.  But the Input palette is critical to my workflow.

 

Thanks

 

Edited by pointer

Share this post


Link to post
Share on other sites

See screen - shot below.  I have tried to maximise all of these individual palettes and this is the result.  None of them display their full content.

post-261-0-38494600-1484837553_thumb.jpg

Share this post


Link to post
Share on other sites

Pointer,

 

The Input Palette will not expand more than you show because it should not need to be any larger.  Do you have a case where this is cutting off information, or doing something else incorrectly?

Share this post


Link to post
Share on other sites

Hi Tech,

 

Sorry if I am not explaining myself very clearly.  The palette cuts of the 'Width' input.  Therefore I cannot see what dimension I am entering or snapping to! it only displays the word 'width' and then cuts the numeric entry off.  I cannot tab across etc to see the input.

 

I use this all the time, it was OK until I reset the preferences this morning.  I will try and take a shot of this to help explain.

Share this post


Link to post
Share on other sites

My screen shots are not playing ball - here is a photo to help.

I have managed to show the content of the three palettes below the Input palette by setting the icon size to the minimum setting.

post-261-0-99910200-1484838442_thumb.jpg

Share this post


Link to post
Share on other sites

I found a work around this morning, the Input palette now displays the full information as you can see below.  I started up using a set of preferences from a colleague's machine, this partially restored the length of the palette.  After this I adjusted my various settings and preferences to my regular set up and hey presto the input palette is back to normal.

post-261-0-61465400-1484904762_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Andre,  Yes, my colleague is running the exact same set up as me (same PC and 2 x screens etc). I just copied his pref file, then used that as a base to get mine back to where I used to have it. There are still a few issues with some palettes but this is what I am used to.  The Input palette was my main concern and this is now OK. 

Share this post


Link to post
Share on other sites

Thanks Pointer! Your solution worked for me too. 

 

I reinstalled W10 and the issue was still present but after using the formZ preference file from a different computer I now have my input palette fully visible. The other palettes are bugged but I can work around that.

 

 

Share this post


Link to post
Share on other sites

I'm having a similar experience on a Mac, the tool dock always opening deeper than when saved as a work space.

Followed advice regarding toggling save between sessions, saving a work space upon opening a new file, eletedprefs etc.

Any help most welcome as constantly readjusting palettes upon opening FormZ.

 

Thanks Andrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×