Jump to content
AutoDesSys Forums
polifilo

material alignment issues

Recommended Posts

how do i change an objects attributes so it's assigned material turns a corner consistently?  

similarly, when 2 objects are in the same plane with the same material, how do i get their patterns to align (or, why aren't they aligning)?

Share this post


Link to post
Share on other sites

polifilo,

 

Welcome to the forum!

 

Without seeing your objects, I would suggest UV mapping in the first case. In the second, you could join the two objects (they don't need to touch), then use one map across both.

 

Hope this helps.

 

Joe

Edited by jsiggia

Share this post


Link to post
Share on other sites

thanks, Joe.  I am using the material parameters menu to create the material, but not mapping a texture per se.  therefore, the UV mapping doesn't apply, correct?  

as for joining, i realize that is a solution, but i was hoping to keep the objects separate.   

This has never been an issue in previous versions of FormZ, but i recently upgraded and now the material attributes don't seem as inuitive.  

Share this post


Link to post
Share on other sites

Hi Polifilo,

 

Welcome to the forum!  

 

The Map Texture, Edit Texture, and / or Copy Attributes tools can be used to adjust the mapping of images on your objects.  Right click on the Edit Texture tool in particular and check out the Manual and Video options that describe how these work for full details.

 

Also check out this "Tip" for a more direct answer:

 

http://www.formz.com/support/tips/tip65.html

 

Specifically, see the alternate tip near the end if you want to keep the objects separate.  

 

Does that help?  ;)

Share this post


Link to post
Share on other sites

On geometry where you want a texture map to turn a corner seamlessly you need to change its mapping to CUBIC and then put the center of the map on the corner somewhere. 

To get mapping seamlessly across two objects they need to be joined first.  Then still use cubic. 

 

I really wish Form.z used Cubic as its default mapping so that I don't have to go in and change each object manually.  This used to be the case back in 6.7.

Share this post


Link to post
Share on other sites

Andrew,

 

The project rendering options dialog has default settings for the project. You can specify Cubic there, but I've never had to change this, it has always been set to cubic.

 

Joe

Share this post


Link to post
Share on other sites

Copy Attributes tools can be used to adjust the mapping of images on your objects. 

Hello Tech.

As I checked many times Copy Attributes mostly don`t align material pattern say on the corner of the cube as they are producing pattern justification to same coordinate (own 0,0,0) and pattern should   have 0 point at corner in order to guarantee alignment.

Here Attributes from the left object where copied to the right one:

post-46-0-26098900-1460148667_thumb.png

 

And here is the misalignment on 3D wall:

post-46-0-26098900-1460148667_thumb.png

 

So the only manual method with Edit on face option is the way.

Best,

Anton

post-46-0-48259200-1460148859_thumb.png

Share this post


Link to post
Share on other sites

Joe-

 

The Project rendering options dialog does show CUBIC as the default there, but when when you draw any new object in FormZ 8, it automatically maps as FLAT.   Perhaps it's a bug?

 

 I agree with Andrew, CUBIC should be able to be set as the default as it was in v6 and before.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×