Jump to content
AutoDesSys Forums
Sign in to follow this  
Chris lund

DXF Export not working.

Recommended Posts

I usually keep my settings set,  however, I was not getting circles (parametric) to export to my other software (PatternSmith)    which I have never had an issue with before.  So, I started to play with my settings.   NOW, Everything Triangulates.

 

I am just exporting flat patterns.   

 

Even Round Tripping the files does not work.

 

Version 6.5.3 works without issue.   older versions of 8.x worked. without issue.  (I did have other issues, but those were remedied by chucking the preferences and templates)   I sure would hate to have to chuck all my preferences Again.

 

post-9803-0-46128700-1455599754_thumb.png

post-9803-0-22467700-1455599772_thumb.png

Edited by Neurascenic

Share this post


Link to post
Share on other sites

Hi Chris,

 

Facetted objects will become triangulated if you Export as Solids and do not have the Export Facetted Objects as ACIS Objects option checked.  Please check that option to avoid the triangulation.  Alternately, you can export as Polylines without triangulation (but then you will only have lines, not surfaces -- which is good for cutting files, but not for rendering, etc).  If you export with these options, does that give you want you want?

 

post-5-0-68077900-1455637891_thumb.jpg

 

(The only thing you might want to change for general exports is the DWG Version -- which you can set to an earlier version if your software doesn't support the recent versions.)

 

Hi Andy,

 

Yes, there is an issue with the Export Groups as Blocks option.  Please avoid that option for now and you should get good results.  Thanks for your report, we will get that corrected.

Share this post


Link to post
Share on other sites

Tech,  I only use Polylines as PatternSmith is dedicated to cutting and not rendering.  AND, they are coming out as Faceted.

With PolyLines the "Export Facetted Objects As ACIS Objects" is not an option.

 

 

Your Options do not work, as PatternSmith rejects those objects (ignores them)

 

Here is what Works for me in 6.x  and what was working for me in 8.5 prior to the newest version...    These settings are Triangulating.

post-9803-0-25089200-1455684108_thumb.png

post-9803-0-95850000-1455684364_thumb.png

Share this post


Link to post
Share on other sites

Hi Andy,

 

Yes, there is an issue with the Export Groups as Blocks option.  Please avoid that option for now and you should get good results.  Thanks for your report, we will get that corrected.

 

Yes -- was that different from your previous report?

 

(Thanks again for your report...)

Share this post


Link to post
Share on other sites

Hi Chris,

 

Yes, the ACIS Objects option only applies to when exporting as Objects.

 

If you don't want it to be Triangulated, if you Uncheck the Triangulate All Facetted option, does that help?

Share this post


Link to post
Share on other sites

Hi Chris,

 

If you import the file back into formZ, do you see the problem there too?

 

If so, please send the original .FMZ file so we can test with this here.

 

Also, just to confirm, v6.7 (and 8.5.2) are both working properly with the same file and Pattern Smith?

Share this post


Link to post
Share on other sites

No, this does not work.   Even if I round Trip it back into fZ,  the patterns are triangulated.

 

Attached;

   image of my settings, just to make sure I am following directions

 

Share this post


Link to post
Share on other sites

No, this does not work.   Even if I round Trip it back into fZ,  the patterns are triangulated.

 

Attached;

   image of my settings, just to make sure I am following directions

   Round Trip File of the .dxf 

   the original.

 

File does not Matter, it happens to everything.

post-9803-0-63869600-1458074353_thumb.png

post-9803-0-65440800-1458074354_thumb.png

post-9803-0-68875500-1458074355_thumb.png

Edited by Chris lund

Share this post


Link to post
Share on other sites

So,  Blowing out the Preferences folder (Library/Preferences/autodessys)     Corrects the problem.

 

blowing this out every time I have a problem isn't a good solution though.  it takes a long time to rebuild all the custom settings.

Share this post


Link to post
Share on other sites

Hi Chris,

 

Hmmm, that's strange.  Perhaps there is some other option set somewhere that you haven't identified.  Once you Rename the autodessys folder and it fixes it, you can try restoring parts (reloading Prefs, Workspaces, Templates, Shortcuts, etc).  Most likely all of those can be reloaded, but if not, if you can send that part, we can investigate it...

Share this post


Link to post
Share on other sites

Hi Chris,

 

Thanks for uploading your files, we will get this corrected.  For now if you choose Export Objects & Facetted as ACIS, then Export as Polylines, that should work around the issue if you want to load those older files.

Share this post


Link to post
Share on other sites

Not quite right.

 

Does not export smooth circles properly.    6.7 does fine.    If I round trip them, they look ok (with the ACIS option)   but my other software does not read them.   Again, it reads 6.7 exported files just fine.

 

Now, I have a real problem.  I try to back save the project to a 6.7 file   and 6.7 crashes upon read.  so, I have no options but to be late with the project.  Awesome!

Share this post


Link to post
Share on other sites

Worked around it in the other software...   what a PIA,  fz does a much better job at dealing with repetitive tasks, I totally hate doing it in Pattern Smith!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×