Jump to content
AutoDesSys Forums
Sign in to follow this  
AsOne

8.5 and Shaded Full shadows

Recommended Posts

I know you mentioned that improvement in Shaded Full shadows was on your radar screen when 8.0 came out.  However, I want to follow up and see if anything will happen with 8.5?

 

Here is a screen shot of what the issues I am having trying to use version 8 vs. version 7. 

 

Version 7 shadows are crisp and reliable.  

Version 8 shadows have jagged and wavy edges and are not suitable for professional work.

Version 8 shadows with soft shadow is passable, but not desirable in all cases.

 

If the shadows shown are not what is to be expected please let me know and I will upload my files for you to look at.  I have tested various files on two different mac computers (one Mac Mini with Intel 4000 integrated graphics and one MacbookPro with AMD ATI Radeon discrete graphics) with similar results. 

 

I have NOT upgraded as a result of this issue alone and I find it hard to believe it is not being addressed in 8.5.

 

post-31-0-81237400-1432684392_thumb.png

post-31-0-62795100-1432684401_thumb.jpg

post-31-0-23680600-1432684417_thumb.png

post-31-0-87998500-1432685176_thumb.png

Share this post


Link to post
Share on other sites

Hi Paul,

 

We are sure you can get better results than what you show in v8.  If not, can you send the file so we can try it here?

 

 

Share this post


Link to post
Share on other sites

I uploaded two files:  ASONE-shadows 1.fmz and ASONE-shadows 2.fmz

 

If this is the case of the crap Intel Graphics 4000 card please let me know and I will find a way to upgrade my cpu so I can upgrade to v8.  In the ASONE-shadows 2.fmz file I also have an issue where the shadow is not being cast onto the ground plane drawn.  Receives shadows is turned on.  Shadows are cast on this object just fine in v7.  I will test these files again tonight on my MacBook Pro that has a better video card.

 

I have tried multiple setting and find that anything but Shadow Map "Very Large" is useless.  I'm not sure why small, medium, large are even options, because at least on my machine the shadow performance is so poor I can't see any use for the settings.  Massive setting crashes my machine, which I believe I reported in the beta testing.

 

On a side note I also can't open files back saved in FormZ Free to v7.  It saves them, but they won't open in v7.  Simply nothing happens.  Either from double clicking the file or choosing File: Open.  I also am uploading the back saved file.  I have experienced this on multiple files.

 

 

Edited by ASONE

Share this post


Link to post
Share on other sites

Hi Paul,

 

Thanks for uploading your files.

 

The shadows look pretty good in the file as you have uploaded it (a lot better than the images you show in your previous post).  We did a few subtle tweaks to the settings to get this:

 

post-5-0-32385100-1432757914_thumb.jpg

 

The ground Plane has Receive Shadows turned off.  You can see them above because we turned this back on (but left off the Cast Shadows -- as that improves the shadow quality).

 

In the case of your file #2, you may also need to turn off the Cast Shadows for a few of the "entourage" buildings that are off in the distance to get nice crisp shadows:

 

post-5-0-21176200-1432758616_thumb.jpg

 

The smaller size maps work well for product design, but for larger models where you are only viewing part of it, larger maps are required so you don't "see their pixels."

 

The Intel 4000 HD graphics is the bare minimum that can support the display modes in formZ v8, and while we would expect that the Massive setting would not work, it should not crash.  We have tested this here and have not been able to reproduce that, but we will continue to investigate this to see if we can find a case / computer where it happens.

 

formZ Free is not supposed to be able to (can not) save files back to versions prior to 8.0, so thanks for bringing the fact that we offer the option to our attention, we will get that corrected.

Share this post


Link to post
Share on other sites

Thanks a lot for testing and reporting back on this issue.  Much appreciated!

 

From "far away" the shadows at the exact settings you have are better.  However, close up they still are not very good at all and a definite downgrade from v7.  Even SketchUp Make 2015 is much better up close.  Obviously all the other new settings are really, really nice (live AO, multi sampling, shadow darkness), but the edge quality is still poor and a shame that I have to use soft shadow to produce it.  True in reality that sometimes shadows are soft, but sometimes a nice crisp shadow is desired.  They also end up with a slight "blurry" quality when soft which is not always desired.  Attached is a comparison set of images.

 

At a minimum it would be helpful that in the documentation a Soft Shadow of approximately 20-40, ground plane with Receives Shadows set to OFF, and Shadow Map size = Very Large minimum is required to produce acceptable edge quality.  Those are not intuitive or obvious settings upon learning v8.  It should look great right out of the box IMHO.  At the end of the day it would be great if the edges were crisp without having to use Soft Shadows.  If I downloaded FormZ Free and tried to use the shadows...as a new user I would be highly disappointed. 

 

Perhaps there is something about my cpu that is causing the Massive setting to not work and/or these bad shadow edges. If Massive solves the issues I will look into trying another cpu to see if I can get it to work.

 

Ok, I understand about the map size.  
 
I am still not getting shadows cast on that ground plane and have toggled Receives Shadows on/off and restarted.  ?
 
Again I will try later with my other computer to see if it works better with the Radeon graphics.  I don't recall much difference.

post-31-0-16595600-1432763121_thumb.png

post-31-0-31538500-1432763131_thumb.png

post-31-0-76474200-1432763156_thumb.png

post-31-0-76820600-1432763594_thumb.png

post-31-0-38730200-1432764376_thumb.png

post-31-0-62159500-1432764384_thumb.png

post-31-0-47918400-1432764392_thumb.png

post-31-0-01840400-1432764402_thumb.png

post-31-0-50874100-1432764486_thumb.png

post-31-0-28274600-1432764493_thumb.png

Share this post


Link to post
Share on other sites

I wouldn't say disappointed, but I agree that it could be better. What keeps me from complaining is all of the added functions like AO and 2x sampling. Plus being able to create animations in full shaded mode. Although, soon I will post a thread with issues regarding this very feature. :P

 

Allan

Share this post


Link to post
Share on other sites

A few more examples  (Macbook Pro 2011, AMD Radeon 6770M graphics):

 

Massive also causes this cpu to crash every time.  

 

I think you can see from the stair images that using soft shadow does not alway help.  For me these shadows are not suitable for professional work.  I would not show this to a client.

post-31-0-40553800-1432786480_thumb.png

post-31-0-54870000-1432786523_thumb.png

post-31-0-43695300-1432786536_thumb.png

post-31-0-83962500-1432786573_thumb.png

post-31-0-75213900-1432786585_thumb.png

post-31-0-50577600-1432786598_thumb.png

post-31-0-33330200-1432786610_thumb.png

post-31-0-02243000-1432787430_thumb.png

Edited by ASONE

Share this post


Link to post
Share on other sites

Paul,

 

Here is what we get.  Perhaps you just need to adjust your settings.

 

post-5-0-03480600-1432816946_thumb.jpg

 

post-5-0-32268300-1432817281_thumb.jpg

 

Please upload the file set exactly as it would cause the crash with the Massive Shadows, and also showing the bad shadows that you are getting so we can help further.

Share this post


Link to post
Share on other sites

This is not a setting problem.  This is a problem with the antialiasing of the shadow edges.  Soft Shadow is a workaround, not a fix in my opinion.  It also does not work in all cases as I have illustrated.  

 

This is a serious issue for me as 75% of my output is from the Shaded Full render engine.  I use it for elevations, 3D views, Interior Elevations, Axon views, etc.   When I see the free version of SketchUp is better (without any special workaround or settings) I know there is an issue.  I expect a lot more from FormZ.  This is an important and basic function of any architectural modeling software.  I don't have time to model in v8, back save (over and over and over), and render in v7 - especially for a default base render option.  That should not even be a consideration.  Until it is fixed I cannot and will not upgrade.  Even as much as I want to support FormZ and am using the software on every single project.

 

In general I find tech support to be top notch and one of the reasons I love using FormZ.  So sorry to sound irritated (I know you guys work hard at responding to issues and improving the software), but the fact that you are not acknowledging this is an issue is upsetting.  I cannot believe this level of performance is acceptable and find it really hard to believe that it is not being addressed in version 8.5.

 

Here is a link to the old thread on the same topic (not started by me) http://www.formz.com/forum/old/messages/16/95419.html

 

Massive setting crashes no matter the other settings.  I just can't get it to work on my Mac Mini or my Macbook Pro.  

 

Both my computers have these shadows issues and I can only conclude it is not caused by the Intel Graphics 4000 card.  Even it is was - basic default level shadows with that card should still work fine.  I have no issues at all with SketchUp Make or FormZ v7.  The file I have uploaded should be all you need.  Simply look around closely at the shadows as my views illustrate.  I find it hard to believe you can't see what I'm seeing.  I also played around with all the settings, including a variety of soft shadow options, and nothing even comes close to producing a decent shadow up close...as shown in the attached views.

 

post-31-0-28229700-1432831595_thumb.pngpost-31-0-00515500-1432831611_thumb.pngpost-31-0-03829100-1432831626_thumb.png  

Edited by ASONE

Share this post


Link to post
Share on other sites

asone,

i get the same poor results as you have shown in your examples with v8 and it is really really dissapointing with these ugly shadows...for now i turn off the shadows completely, and i cant believe that i have to fiddle around like autodessys did to get a mediocre clean shadow in 2015.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×