Jump to content
AutoDesSys Forums
Sign in to follow this  
dmuller

Unwanted faces, help with removal

Recommended Posts

I'm still very much on a learning curve with FormZ and have recently upgraded from Jr. to Pro to enjoy all the additional features. My modelling is definitely improving all the time however there are some things I still struggle with and one of those is the ubiquitous missing faces/ holes which throw up all sorts of errors when trying to further model.

 

I've tried using the Object Doctor but understand that it isn't a panacea for all modelling ills. So, I turn to the greater FormZ community to lend a hand and try and explain how I go about fixing this particular problem.

 

The file is attached. Or can be downloaded here: https://www.dropbox.com/sh/qyuv4tpo09wcr3e/AAA5gkfEo7fdybQ9s2ICa8lha?dl=0

 

Inside you should find a small but complex box. At the front of this, just above the sweeping face that is above the protruding tube is a series of unwanted faces in the model, they're embedded inside the shape (I can see that buy using the clipping planes) but simply deleting it causes all sorts of knock-on effects, none of them desirable! It manifests itself a a short, horizontal line in the containing face.

 

How, do I go about removing these and tidying this shape up to become a solid model again? Help is greatly appreciated!

Edited by dmuller

Share this post


Link to post
Share on other sites

Hi David,

 

We assume that you want to get rid of this “line” in the center of this image, right?

 

 

If so, zoom in close and you will see that there is a gap here:

 

 

 

And nearly coincident points here:

 

 

Pick this top face, 

 

 

and Reshape it down, snapping to the bottom point here:

 

 

 

Finally, Fix the remaining issues with the Object Doctor:

 

 

Is that what you want?

 

box2.fmz.zip

Share this post


Link to post
Share on other sites

Hi, thanks for your prompt reply. Yes, I noticed the issues with uploading also.

 

That isn't quite what I wanted, also, the resultant shape you provided does not allow those faces to be reshaped any longer, so I cannot drag a face across to close the gap. The actual result I wanted to achieve is to simply remove that thin face completely and close the surface, keeping the same shape and flow as desired.

 

I appreciate your help though. :)

Share this post


Link to post
Share on other sites

Actually, what you suggested worked, kind of. I managed to zoom right in, grab that face and reshape upward. This left a tiny artefact on the left (minute). I was unable to reshape, extrude or delete this so I simply created a bigger shape over the top and used the boolean tool to erase it. Then just reshaped the exterior faces back to the original shape.

 

Fingers crossed it will export okay.

Share this post


Link to post
Share on other sites

Hi David,

 

Oops, it does look like we uploaded an older version of the file than we intended.  With that file, just Reshape that left face to the right, then reshape the "bottom face of the sliver" up.  That will seal the gap.

 

However there are still issues with your object whereby parts that should be flat are very slightly off.  For example, if you pick the top and bottom points in either the inside or the outside of the J shape, you will see that not only are their Z coordinates different (in the Pick Options: Info), but their X values are different too -- indicating a slight warping of the surface -- which will prevent some reshaping operations on the surface in that area.

Share this post


Link to post
Share on other sites

You can see that the X value of these points on the large face on the right side are not equal if you pick them and look in the Info tab.

 

Checking each of these points, you will see that the top segment has been moved 0.004mm to the left.  Move it, snapping to its midpoint, perpendicular to the YZ Plane, and then snap that to one of the lower points to make them the same.

 

I haven't checked all the other faces, but that is one basic way to check and fix them...

Share this post


Link to post
Share on other sites

Unfortunately there are a lot of other places with problems.  If you are moving parts of objects, you should be very careful to maintain planarity -- and use grid snaps, objects, numeric entry, or other methods to make sure that flat things are flat -- and don't just eyeball it...

post-5-0-96047900-1430340854_thumb.jpg

Share this post


Link to post
Share on other sites

I went ahead and remade that obj. from the ground up, paying particular attention to what you advised. That was good advice and something I will take with me.

 

The results are much better, no problems faces or zero length doodads. However, I have one issue and that is at the front of the circular tube. One export as an STL FormZ adds a face that isn't present on the model, I've tried all sorts to try and fix that but have drawn a blank.

 

Any chance you could have one more look please?

 

Thanks,

 

David.

 

 

cube.fmz.zip

Share this post


Link to post
Share on other sites

I've just managed to fix this by chopping 5mm off the end, making a new cyclinder 5mm long and adding a taper to the end of that, then aligning the rotation of the faces and a boolean to join the two.

 

Odd that this appeared on the first attempt though, I was REALLY meticulous this time round.

Edited by dmuller

Share this post


Link to post
Share on other sites

Hi David,

 

Yes, this object is much  better -- I don't see any issues with it at all.

 

Even when I export to STL, the resulting import seems to be fine:

 

post-5-0-83971800-1430926782_thumb.jpg

 

Where is the problem that you are seeing?

 

In general, these Display Options work very well for Smooth objects being exported to STL:

 

post-5-0-64680500-1430926905_thumb.jpg

 

(Just pick your object, click the Attributes Tab of the Pick Options, change the Basic Attributes to Display Resolution, click Scheme, and then choose Facetting Schemes from the list.)  You can use what ever angle number you like (use the largest value you can where you don't see any facetting in the resulting print).

 

Does that help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×