Jump to content
AutoDesSys Forums
Sign in to follow this  
davidhard

not so smooth reflections

Recommended Posts

could someone please help me figure out why this might be happening with Maxwell? (see attachments). I have the display resolution all the way at 100% for all of my objects. Usually, that gets things to render relatively smoothly. But for some reason, I'm getting some really weird reflections. I am using an .HDR image to light my scene and give me reflections in the glass and ceramics. Background is turned off and the Alpha channel is embedded.

post-322-0-11802300-1428618012_thumb.png

post-322-0-13572800-1428618033_thumb.png

post-322-0-81157200-1428618044_thumb.png

post-322-0-08059900-1428618056_thumb.png

Share this post


Link to post
Share on other sites

Please post a small formZ project file (fmz) which reproduces the problem, along with all relevant dependencies such as image maps, MXMs, etc.

 

Also, Please run the command Extensions> Maxwell Render > Forum and post the resulting text here, so we can check your system info.

Share this post


Link to post
Share on other sites

Actually, One more step involved. First I changed the Display Resolution setting from "Simple" to Surface Analysis under Schematic. Then converted it to a facetted object.

Share this post


Link to post
Share on other sites

Surface Analysis is going to give you a HUGE number of polygons.  Perhaps Simple ~75% would be better...

 

You can also play with the Polygon Mesh tool on the Smooth object to see directly the effects of the detailed / advanced / expert settings...

Share this post


Link to post
Share on other sites

David,

 

Yes, Rob is correct that the Surface Analysis is intended only for when you need an extreme number of facets to represent the shape.  If that is the only object that you are rendering, that should be fine, but if it is a small part in a larger scene, then that is likely way overkill that will unnecessarily make larger files and slower renders.

 

Also, it should not be necessary to manually facet objects.   Perhaps Pylon can shed some light on this (and let us know if this is anything we need to help address).

Share this post


Link to post
Share on other sites

Yup. Tried the Poly mesh tool. Still looks like garbage. The only way I was able to get it to render smooth was to give it as many facets as I could. And even then, It's still not perfect. I'm still noticing poor reflections that I have to go back and photoshop out. They're just not as bad as before.

Share this post


Link to post
Share on other sites

Hi David,

 

'Simple' Display resolution is fine for most purposes when rendering. However, with complex forms that are highly reflective or refractive, and are close to the camera, you will need to use the expert options. Better than 'Surface Analysis' are the settings below:

 

post-32-0-47185400-1428683895_thumb.png

 

You can set this up as a Faceting Scheme.  You do not need to convert the object to faceted after applying this scheme in Display Resolution. Minimum Grid Lines U and Minimum Grid Lines V may be set to lower values, at the expense of reduced quality at the 'fringes' where the side wall meets the top rim.

 

We will contact formZ tech support and see if the ACIS meshing can be improved in cases like these.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×