Jump to content
AutoDesSys Forums
TwoSheaStl

Non Uniform Scaling / World Axis

Recommended Posts

Is there a way to keep the x, y, and z constant for ALL objects in relation to the "world" axis.

 

If I draw a square (for example) and then flip the object, the X, Y, and Z are maintained within the square. Is there a way to have it reset so that the bottom, top, and sides of the square are the same as the "world" axis?

 

Thanks!

 

Shea

Share this post


Link to post
Share on other sites

Hi Shea,

 

Welcome to the forum.  Unfortunately, we are not sure if we are understanding your question (?).  Do you want to use the Edit Axes tool to edit the axes of objects?

Share this post


Link to post
Share on other sites

Say I draw a square that's 2ft x 2ft x 2ft…

 

There is a designated X, Y, and Z under NON-UNIFORM SCALING. If I turned that square on it's side to the left, the Z would now be on the side. So if I went in to make the square 3ft tall using the Z axis, it would grow from the side and not the bottom. I want the X, Y, and Z to match the world axis at all times, no matter how I flip the object…

 

Does that make sense?

 

Thanks!

 

Shea

Share this post


Link to post
Share on other sites

Hi Shea,

 

Oh, ok, now we understand.  You want to use the Transform Tool: Scaling options relative to World, not the Object axes.

 

We will see if we can add an option for this.  For now, this occurs relative to the axes of the object, which you can see during the transform process.  (Just like the World Axes, the Z will be the Blue axis, the X will be the Red axis, and the Y will be the Green axis.  You can also use the Transform Tool: Transform Controller to change this temporarily for this object, or the Edit Axes tool to change it permanently for the object.)

Share this post


Link to post
Share on other sites

I agree with Shea.  

 

It's very confusing that objects can have their own Axes that are not the same as the World Axes.  You think you're scaling the height (which should always be Z), but it turns out you are scaling the width or length???  

 

Is there a way we can just set it so All Objects, Existing, and New, use only the World Axes?  That's always how it had been in v6, or at least it was the only option we used, unknowingly?  There used to be some options for Relative / Absolute, as well as World Space / Reference Plane in the Prompt dialog that may have controlled this before.  Not sure, I just remember that we always used Relative and World Space.   I hoping the fix is as simple as that for v8?

 

Thanks!

 

Share this post


Link to post
Share on other sites

In FZ 6, when it came to editing shapes numerically, the Z axes was always the third input line. Now one has to look back and forth between their shape to determine which input to edit.

 

Also, when opening past projects I worked on in 6, my axes's are all over the place within shapes. I have to reset the axis on almost every shape…

 

It would be nice to have an option to where the axes's were always in the same place no matter how you rotated the object. 

Share this post


Link to post
Share on other sites

Hi Shea,

 

Oh, ok, now we understand.  You want to use the Transform Tool: Scaling options relative to World, not the Object axes.

 

We will see if we can add an option for this in the future.  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×