Jump to content
AutoDesSys Forums
Justin Montoya

performance test Comments

Recommended Posts

Hi Anton,

 

We just found a case whereby the Maxwell Render Plugin can potentially cause RenderZone to not show in the Imager.  Thanks for helping to bring this to our attention, we will get this corrected.

 

Do you have this Maxwell Render Plugin loaded?  If so, if you Quit formZ and Imager, and add an Underscore ("_") to the beginning of the name of the folder:

 

post-5-0-87132400-1419025736_thumb.jpg

 

Does RenderZone then reappear when you relaunch the Imager?

Share this post


Link to post
Share on other sites

My cpu usage does not go above 50% when rendering from the imager.  It shows in the prefs to use all 40 cores but does not appear to be.  It appears to not be rendering with virtual cores.

Edited by asmithey

Share this post


Link to post
Share on other sites

Hi Aaron,

 

There are diminishing returns to using multiple cores in the same machine, as the overhead to manage all the cores can exceed their benefit at some point.  You would probably be better off generating 2 renderings on 2 separate computers with fewer processors...

 

You might want to experiment with limiting the number of processors in the Imager (or formZ) Preferences.  We have seen some cases with certain computers and files where using 6 or 8 for OS X, or 16 on Windows can give faster results than using all cores, especially when they are virtual and not actual cores...

Share this post


Link to post
Share on other sites

Some time ago I recorded the following speed using FormZv7 

 

13:35      Xeon     3.5 Ghz   2013 MacPro 6 Core              OSX 10.9.5           v7  

 

I've just upgraded to v8.5 and the performance test file is taking longer to render?

 

16.59      Xeon     3.5 Ghz   2013 MacPro 6 Core              OSX 10.9.5           v8.5  

(Using all 12 Virtual cores)

 

16.40      Xeon     3.5 Ghz   2013 MacPro 6 Core              OSX 10.9.5           v8.5  

(Using just 6 Virtual cores)

Edited by bluemonkey

Share this post


Link to post
Share on other sites

Hi BlueMonkey,

 

That's strange.  If you run the v7 test again now, do you still get the faster time you note above, or is it now rendering the same speed as v8.5? 

 

(Is it the version change that is causing the issue, or is it something else that changed on your computer?)

Share this post


Link to post
Share on other sites

3D works with your MacPro 2010 need to use only 6 processors in preferences. I have same computer & same issues (a long time problem). This may be a question we should ask the LightWorks rendering engine company.

Any one know if the Current 2013 Mac Pro 12 core has same problem?

Share this post


Link to post
Share on other sites

Thanks for you replies - How many virtual cores should I set? 12 virtual (using 6 real cores) or 6 virtual (using 3 real cores)?

 

Using v7 test gives a similar time to the original between 13:30 and 13:40.

When I watch whats happening in the activity monitor:

with v8 there are a few peaks and troughs in the CPU load graph

with 7 it's flat across the top

 

V7 seems to use all 12 virtual cores, whereas V8 gives the same result using 6 virtual cores as it does using 12 virtual cores?

 

I will try and do some more detailed experiments later and post the results, however if you have any suggestions in the mean time would be a great help.

Share this post


Link to post
Share on other sites

It shouldn't be happening, but it IS happening to many of us Tech! 

 

v7 is faster rendering than v8.   It's even more noticeable when you have more than 6 CPUs /12 threads.  Sure you can set the preferences to use less cores than we have (12c/24t) and get some of the speed back, but that just proves that the v8 rendering engine is very poorly optimized, and even after doing that, it's still slower than v7.  We need to be able to use as many CPU threads as we can to speed up the renderings!

 

This should be fixed via a free update before anyone is asked to pay for another 'upgrade' in FormZ.  

Share this post


Link to post
Share on other sites

So I tried the performance test file again. - preferences set to all cores

Using v7 on OSX 10.9.5 on mac pro 3.5 GHz 6 core I still get times between 13:30 and 13:40

Using v8.5 on OSX 10.9.5 on mac pro 3.5 GHz 6 core I got time of 16:45

 

In a fit of madness and clouded judgement I updated OS to El Capitan and now get

Using v8.5 on OSX 10.11.2 on mac pro 3.5 GHz 6 core I got time of 23:59???

(I've tried this several times and get similar results)

 

So I then tried it on a PC

Using v8.5 on Windows 10 on PC i7 4 GHz 4 core I got time of 09:36???

 

I compared the images from the PC and MacPro and they are identical.

 

I'm obviously doing something wrong with my Mac. Any suggestions would be welcome.

Edited by bluemonkey

Share this post


Link to post
Share on other sites

Hi BlueMonkey,

 

Yes, the OSX handling of the "extra cores" can cause longer render times currently.  If you set the # cores to the actual number (6) and run the test, do you again get the ~13 minute time?

 

Windows has always handled the multiple cores faster, and also renders a little faster in general with the same hardware, so it is not surprising that you would get 9:36 with a slightly faster computer.

Share this post


Link to post
Share on other sites

So I set the preferences to 6 cores

 

Using v8.5 on OSX 10.11.2 on mac pro 3.5 GHz 6 core I got time of 16:53

 

Still longer than v7

 

just out of curiosity I tried 4 cores but it goes back up to 21:44

Share this post


Link to post
Share on other sites

Hmmm, it is not surprising that 4 cores would be slower than 6 cores (with a 6 core machine) but it is surprising that 8.5 is a few minutes slower than v7.  We will run some more tests and investigate this further.  Hopefully Lightworks (makers of the RenderZone engine) can improve this for the future.

Share this post


Link to post
Share on other sites

Many thanks for looking into this one - look forward to a solution - I much prefer working on my mac (may just have to use the PC for heavy rendering duties)

 

Keep up the good work!

Share this post


Link to post
Share on other sites

This is not a problem with how OSX handles multiple cores/threads!  If it were, then why does every other multi-platform rendering engine compare very closely in speed on both OSX and Windows???   Check out Maxwell's Benchwell results and see for yourself!  (http://www.maxwellrender.com/benchwell)

 

Lightworks needs to understand that OSX is a profitable platform for FormZ and it's users demand at least similar performance to the other platforms.   How can AutoDesSys continue to supply RenderZone as the default engine when it is so severely handicapped on OSX?   Please get this resolved by working with Lightworks ASAP, as it is extremely unfair to charge for your new products when your past/current product is not even fully functioning!  

Share this post


Link to post
Share on other sites

Justin,

 

If I recall correctly, this issue only occurred after an OS X update, and did not occur with previous versions of the OS.  Granted it has been awhile since that OS was released, but it was Apple's change, not Lightworks' change that caused the delay with the many cores...  Hopefully Lightworks can get this adjusted in the not too distant future.  If there was anything we could do to make this happen faster, we would do it -- and we are working with other rendering providers to offer more rendering options to formZ users in the near future.   ;).

Share this post


Link to post
Share on other sites

MacPro early 2009 (4,1)


 


2 x 2,26 GHz Quad-Core Intel Xeon


 


MacOS 10.10.5


 


12 GB 1066 MHz DDR3 ECC


 


formZ 8.5.0.2


 


00:28:02


 


Andrea


Edited by Andy

Share this post


Link to post
Share on other sites

Update:

 

So Earlier I noted the following test times:

Using a Mac Pro 3.5 GHz 2013 6 core

- V7 on OSX 10.9.5 - time 13:35

- V8.5 on OSX 10.9.5 - time 16:40

- V8.5 on OSX 10.11.2 - time 16:53

 

 

So I upgraded to 8.5.3

- v8.5.3 on OSX 10.11.2 - time 35 mins and I'm only up to scanline 1100 of 3300? - Is there something wrong with my render zone ?

 

Share this post


Link to post
Share on other sites

Hi Bluemonkey,

 

That is strange that the time would have changed from what you recorded before.  If you go to the Edit Menu: Prefs -- and set the number of Processors to 6, does that help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×