Jump to content
AutoDesSys Forums
Sign in to follow this  
thecadman

Bump shader error ?

Recommended Posts

I have made a suspended ceiling by using the grid shader

 

The colour of this transfers to Maxwell fine

However the bump map which is also the grid shader does not translate and I am left with the FormZ logo producing the bump!

 

If it translates the shader for the colour, why can't it translate it for the bump?

 

 

post-5909-0-01157500-1421489598_thumb.png

Share this post


Link to post
Share on other sites

Maxwell can translate the bump. Perhaps the link to the bump file is broken. Go to the materials 'Shaded' representation, click on the bump map, and reload it. (The Maxwell plugin automatically translates the "Shaded" representation of the material, not the "Renderzone" representation.)

 

If this does not help, please send a file which reproduces the issue, along with any dependencies, such as MXMs, HDRIs, bitmap textures, IES, etc. to the address show in the thumbnail below.

post-32-0-56609500-1421704676_thumb.jpg

We will investigate why this might be happening.

 

 

Share this post


Link to post
Share on other sites

I could send the file but it is simply a material that uses the grid shader as its colour texture and the same grid shader in the bump channel.

The colour is represented fine and translates whereas the bump channel reverts to the FormZ logo

I presume if the one can be translated on the fly then so can the other.

 

Share this post


Link to post
Share on other sites

Steve,

 

That is a Renderzone procedural texture. The Maxwell plugin does not know anything about Renderzone settings; renderzone is a separate rendering plugin. (Likewise, Renderzone is not aware of the Maxwell plugin and its settings.)

 

Maxwell is aware of formZ's integrated 'Shaded' renderer, however, and will approximate its settings, guided by a material "hint," when the Translate Shaded option is enabled. See http://support.nextlimit.com/pages/viewpage.action?pageId=16810295

 

In this case, it looks like the Renderzone plugin is not reporting the bump map correctly to the Shaded renderer-- note the black preview where the texture should be-- so Maxwell is using the default autodessys logo instead:

post-32-0-80905400-1421810053_thumb.png

 

If you click on the folder icon and load another texture from disk, you will see that the Maxwell will map it into the bump channel properly.

Share this post


Link to post
Share on other sites

Hi there

 

thanks for looking at this and getting a result so quickly!

 

I have downloaded the latest plugin and am now getting good results in the bumps that match the ceiling grid.

 

In order to get reasonable results I have to set the Grid amplitude and background amplitude to -9999 and +9999 respectively.

 

I attach a render that shows both maxwell and Renderzone with these settings

 

Any comments ? Any chance of being able to translate the bump into a displacement?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×