ankara escort çankaya escort Setting render resolution for Maxwell - Maxwell Render Plugin - AutoDesSys Forums

Jump to content


Photo

Setting render resolution for Maxwell


  • Please log in to reply
4 replies to this topic

#1 allanjl

allanjl

    Advanced Member

  • Members
  • PipPipPip
  • 167 posts
  • LocationUSA

Posted 23 July 2018 - 03:31 PM

Greetings all,

 

When rendering in maxwell, I used to send my files to Studio from FormZ, make adjustments then render to maxwell. I have found that in maxwell version 4.2.x this work flow is no longer reliable (studio will crash repeatedly).

 

So lately I have been using maxwell's plugin the way it was intended, namely sending the render job directly from formZ. One disadvantage I've found is that maxwell will render to match whatever resolution you set your image size in formZ. This is not a very good solution when you have a very big model, and you want to test render.. You have to set your screen resolution small then send it to render. Of course, since you're also modelling, then the screen resolution cannot be small... So I find myself going back and forth between large and smaller screen resolutions.

 

I know what you're thinking: That's what fire is for!... Well, not really. If you use fire, it cannot handle complex scenes, (it's just too slow) and you cannot really see what's going on.

 

Well, maybe you get the picture. I find myself wishing to have a place to set the render resolution without affecting my screen resolution when sending the job to render in maxwell. Maybe this is already something in the works? If so, great! If not, maybe it should be considered?

 

Thanks,

 

Allan 


  • Brantheat likes this

#2 setz

setz

    Advanced Member

  • Members
  • PipPipPip
  • 444 posts

Posted 24 July 2018 - 01:06 AM

If you use Scenes you can set up various screen resolutions and switch between them quickly.

 

First you create a new Scene, I name mine with the screen resolution I will be using. Double click on the name of the scene in the scene palette and the options window will pop up.  Deselect all the options except for “Image Options". Return to the Scenes Palette, select the scene and then while it is selected go to Display/Image Options and set the desired resolution for your Maxwell render.  I usually then Right Click on that scene, duplicate it and name it "Full Screen" or something similar.  (Duplicating an existing Scene allows you to avoid having to redo the “Image Options" only setting and saves a little time).  Then, with the "Full Screen" scene selected return to the Display/Image options dialog and set it for "Use Window Size".  In this way you can one-click switch between different screen resolutions for rendering and full screen for modeling.

 

An additional tip is to open up a new modeling file, set up a few different resolutions, (I use 1024x2048 and 2048x4096 and 4096x4096) and then save that empty file as your template file.   That way every time you open a new file, those scenes will be there ready to go rather than having to set them up for each new project.

 

Alternatively, you can open a second window, set it for the render and switch to it for your render and then back to the previous full screen window for modeling.

Attached Thumbnails

  • Screen Shot 2018-07-23 at 10.41.03 PM.png


#3 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 429 posts
  • LocationIreland

Posted 24 July 2018 - 02:32 AM

In addition to Setz suggestions, you could try leaving your screen resolution in FormZ to what ever your preferred final size is.

Then when you want to do a test render, in the Display Options > Maxwell > Image > Scale, set it to 50% or 25% for example.

It's easy to just switch it back when you are doing your final image.

 

Des



#4 pylon

pylon

    Moderator

  • Moderators
  • 796 posts
  • LocationLos Angeles

Posted 24 July 2018 - 08:21 AM

Hi Allan,

 

For test renders, we created the "Scale" control. It enlarges / reduces your specified image size at render time, maintaining proportions. As Des says, set it back to 100% for your final rendering.

 

http://support.nextl...Options | Image

 

Regarding the crash in Studio, have you checked your plugin log after export for warnings? If there are warnings about the presence of illegal characters in formZ entities, fix those first and see if this resolves the issue.

 

Attached Thumbnails

  • formZ___Render_Options___Image_-_Maxwell_Render_V4_Documentation_-_Next_Limit_support_site.png
  • formZ___Render_Options___Image_-_Maxwell_Render_V4_Documentation_-_Next_Limit_support_site.png
  • img.png
  • img.jpg


#5 allanjl

allanjl

    Advanced Member

  • Members
  • PipPipPip
  • 167 posts
  • LocationUSA

Posted 25 July 2018 - 11:58 PM

Thank you all! The scale control works great. 

 

Regarding Studio, the file was last worked on in studio, then saved. After it would crash studio when trying to open it again. If I get a chance, I'll send it to next limit.

 

Thanks again!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users