Jump to content


Photo
- - - - -

Improved shadows


  • Please log in to reply
12 replies to this topic

#1 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 27 April 2018 - 03:18 PM

I know I have mentioned this before, but even on Massive settings I still get poor shadows in Shaded Full.  Here is a trellis I am drawing:

 

Screen Shot 2018-04-27 at 2.14.47 PM.png

 

A close up of the shadows:

 

Screen Shot 2018-04-27 at 2.14.34 PM.png

 

The shadows make the wood beams look like corrugated metal.  Soft shadow helps a bit, but often it then shrink the size of the shadow.  I would prefer shadows that are crisp and accurate.


FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#2 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 27 April 2018 - 04:08 PM

There is something going on with Shaded Full shadows I can't figure out. Their quality worsens as I continue to work on the model.  I looked back at my original images I sent to the client a month ago and the shadows were much more crisp.  What could I have done to ruin the shadow quality?

 

The only thing I have done to the file is change the column location and add more options for the small wood slats.  I used the clone copy method to create the slats.  Other than that I have not changed the file really.  All the ground objects are set to not cast shadows. 

 

I also copied all the objects to a new file - same poor shadows.

 

1801-EXT outside door.jpg

 

 


Edited by ASONE, 27 April 2018 - 04:09 PM.

FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#3 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 27 April 2018 - 04:21 PM

I opened the older file with the good shadows.  It still has good shadows.  I deleted the old trellis elements, leaving the house and site (grass, fence, patio, etc) in the file. I copied the newly drawn trellis from the file with bad shadows...and the bad shadows now exist in the old file.  Therefore I can only conclude there is something about the actual objects themselves that is creating poor shadows.  

 

I also redrew the trellis slats in the new file (with and without cloning copy checked) and still get bad shadows.  


Edited by ASONE, 27 April 2018 - 04:22 PM.

FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#4 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 27 April 2018 - 04:24 PM

Close up of the shadows in the old file:

 

Screen Shot 2018-04-27 at 3.23.56 PM.png

 

very nice and crisp.  

 

 

If I copy both the old and new trellis elements into the old file I have good quality shadows with the old trellis and poor quality shadows with the new trellis.  Good and poor shadows exist in the same file.

 

I am on v8.6.1. Mac OS 10.12


Edited by ASONE, 27 April 2018 - 04:37 PM.

FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#5 vva

vva

    Advanced Member

  • Members
  • PipPipPip
  • 60 posts
  • LocationBielefeld, Germany

Posted 28 April 2018 - 12:10 PM

hi all,

 

have you controlled the size of the shadow map

it is in the "Display Options" 

 

vva



#6 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 30 April 2018 - 10:44 AM

Yes shadows are set to Massive setting.


FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#7 Justin Montoya

Justin Montoya

    Advanced Member

  • Members
  • PipPipPip
  • 437 posts

Posted 30 April 2018 - 12:39 PM

Interesting problem!  Especially since it sounds like it is specific to the new object geometry if the old geometry still shows clean shadows in the same file!

 

My first inclination would be to select all the new geometry and look at the new object geometry Attributes > Display Resolution.

 

Can you confirm that you have the Display Resolution turned up to 100% for all the new objects?  

 

For some reason FormZ only uses 50% as the default, and that can cause some issues.  Also remember, if you have had to reset your preferences lately, this would also default back to 50%.  

 

I think the default Display Resolution should be 100% for all objects, and I'll reach out to Support about that.

 

Curious if you tried saving out the Shaded Full image from FormZ yet?  I have found that even though they will sometimes look 'jagged' inside of FormZ, once saved out at a high resolution, they will look nice and 'crisp' for the client images.  



#8 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 30 April 2018 - 03:47 PM

These are just facetted objects.  A rectangle extruded to create a "wood beam".  I can't seem to find any Display Resolution option under Attributes.  How would I set Display Resolution?

 

Yes the saved out Shaded Full image is jagged.  Looks exactly as on my monitor which is a 2015 iMac i7 quad core.  

 

I have also tried restarting the cpu, toggling all the Display options.  

 

I have also had this problem on more than one file, finally I decided to report it. 

 

I will upload the file this week to support.

 

 


FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#9 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 30 April 2018 - 04:39 PM

These are just facetted objects.  A rectangle extruded to create a "wood beam".  I can't seem to find any Display Resolution option under Attributes.  How would I set Display Resolution?

 

Yes the saved out Shaded Full image is jagged.  Looks exactly as on my monitor which is a 2015 iMac i7 quad core.  

 

I have also tried restarting the cpu, toggling all the Display options.  

 

I have also had this problem on more than one file, finally I decided to report it. 

 

I will upload the file this week to support.

 

 


FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 


#10 vva

vva

    Advanced Member

  • Members
  • PipPipPip
  • 60 posts
  • LocationBielefeld, Germany

Posted 01 May 2018 - 04:48 AM

hi asone,

 

today I had the same problem 

I have two kinds of shadows in one file:

the "good shadow" is from an old file and the" jigsaw-shadow" is from an object that was copied from actual file (built with formZ 8.6.1 - iMac 10.13.4)

 

screen 2018-05-01.jpg

 

vva



#11 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 417 posts
  • LocationIreland

Posted 01 May 2018 - 06:28 AM

Sometimes a large object such as a ground plane can affect the shadow quality.

It might not fix you problem but you could try (assuming you have large ground objects) turning off "casts shadows" in attributes. All objects are set to cast shadows by default.

As long as you leave "Receives Shadows" on, it should help.

Also try to keep your model near the origin 0,0.

 

If that doesn't help or is not the cause, why not render it in Renderzone or something else?



#12 snow

snow

    Advanced Member

  • Members
  • PipPipPip
  • 112 posts

Posted 01 May 2018 - 10:17 AM

Are you using 8.6.1?  Try turning on the Advance Open GL option in the Preferences.

 

I think by default formZ tries to run on the lowest amount of resources possible so users with old machines still have access to the program. 



#13 ASONE

ASONE

    Advanced Member

  • Members
  • PipPipPip
  • 403 posts
  • LocationBoulder, Colorado, USA

Posted 02 May 2018 - 11:51 AM

Yes, 8.6.1.

 

Advanced Open GL checked did not make a difference.

 

All my models are typically near 0,0,0.

 

However, it does seem to be related to other objects casting shadows.  Not only ground objects and that is a problem.

 

I copied only the trellis to a new file with a flat ground plane drawn.  When the ground plane (just a simple 2D rectangle) has cast shadows on I get jagged lines, when it is off I get good shadows.  I also tried selecting all objects and turning off cast shadows for all objects.  Then I turned on only the trellis beams and this solved the problem.  Of course I need to go through the model and turn back on shadows for the other objects one by one to locate the problem objects.  A very time consuming process.  I hope for some improvement in this regard in v9, because it is VERY difficult and time consuming to figure out which object is causing the problem in a fully built model.  

 

The problem is that it is not limited to objects on the ground.  I have a very simple low wall built next to the trellis and toggling "cast shadows" on/off greatly effects the jagged edge of the shadow.  The wall would cast a shadow in real life so I need it turned on.  Some objects, including those on the ground seem to have no effect on shadows.  Others have a great effect.  I find no reason why some do and some do not yet.  At times I have walls and roofs that also effect the shadow edge, but I need these to cast shadows!  

 

Certainly I could use Renderzone, but what it is the point of offering Shaded Full it if does not work to its full potential?  I have so many uses for Shaded Full that Renderzone, Maxwell, and V-Ray will not solve.  I export all my building elevations, sections, and basic 3D views with Shaded Full - it is far too time consuming and unnecessary to use a proper render engine for that.  I do live walk throughs at client meetings (on laptop and iPad) and I send clients Shaded Full animations for review of design work.  Not finished, fully rendered animations, but rather quick videos during the design process so we can make decisions on the direction of the architectural design.  I don't have time to do that in anything but Shaded Full.  For someone only delivering rendered images via Renderzone, Maxwell, or VRay this shadow thing is not an issue.  For me, as an architect doing design work using FormZ for everything but floor plans and notes, this is a huge issue.

 

Shadows is a really basic part of the program and they should just work.  They have been broken since v8 came out.  That is a long time!!!  I have posted to the forum numerous times.  "Massive" shadow setting was added in response at some point (thank you Support for listening!!!), but the problems persist in another form.  

 

I would honestly rather have v7 shadow quality back.  The edges were not as good as the Massive shadow setting in v8, but at least they were consistent and worked.  There were no random objects that caused all the shadows to go haywire in the entire model.  

 

I echo once again many of the comments that I hope v9 brings stability and consistency to the program, rather than just a bunch of new tools.  We also need improved communication between FormZ and other programs to streamline our workflows.  

 


Edited by ASONE, 02 May 2018 - 11:54 AM.

FormZ PRO v8.5.  2017 iMac 4.0 GHz quad core i7 24MB RAM and a 2015 Macbook Pro quad core i7 16MB RAM, Modern Architecture in Boulder and Denver Colorado www.ASONEarchitecture.com 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users