Jump to content


Photo

Clipping Plane & MaxwellZ


  • Please log in to reply
6 replies to this topic

#1 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 362 posts
  • LocationIreland

Posted 14 November 2017 - 09:26 AM

I remember using clipping planes with Maxwell in the past which worked well, but I can't get it to work in a project I'm working on at the moment.

I'm using Maxwell 4.1.1.1 and MaxwellZ 4.1.1.1.

Basically I have a few buildings and I'm trying to render say one of them with the camera set inside another. Using a clipping plane to obscure the building the camera is in.

BTW, I am using "exclude from clipping planes" for some elements and buildings because I want some to be still visible.

But every time I try a render, the "clipped" building is still rendering in Maxwell (inside a room).

Maybe there is a setting I've forgotten about for this? I've looked around but can't find a control so I assume it's automatic when the clipping plane is active?

 

 

Thanks,

 

Des


  • Ententpaype likes this

#2 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 362 posts
  • LocationIreland

Posted 14 November 2017 - 10:07 AM

CORRECTION!

 

I have in fact previously use Clip Hither/Yon which worked perfectly with Maxwell. Which is what I should have said in my previous post..

So I haven't used clipping planes with Maxwell before, how do I get it to work?

 

Thanks,

 

Des

 

 



#3 Gary

Gary

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 14 November 2017 - 02:20 PM

Hello Des,

 

Over time using Z clipping planes with Maxwell went from reasonably reliable to buggy for me. I seem to remember clip hither yon working reasonable well. As an alternate to Z clipping planes you can create your own planes and designate them with the "Render Boolean (Clipping Object)" attribute. See here:

 

http://support.nextl...s and Modifiers

 

Thanks,

 

Gary



#4 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 362 posts
  • LocationIreland

Posted 14 November 2017 - 04:16 PM

Thanks Gary, I eventually used the hide from camera option in Maxwell attributes on the building in question. I needed the reflections on the visible building.

It'd be nice however to have the quicker option of using clipping planes, they can be used for scenarios where the hidden geometry is not parallel with the camera as in Clip/Hither Yon.

The Hide from camera worked though when used in conjunction with copy attributes.

 

I will try the Render Boolean option in future to see the results.

 

Cheers,

 

Des



#5 Gary

Gary

    Advanced Member

  • Members
  • PipPipPip
  • 79 posts

Posted 14 November 2017 - 11:32 PM

Hey Des,

The difference I think I remember is Z clipping planes really clip the geometry for the rendering (lighting and reflections will be different) whereas the Maxwell render Boolean just effect the camera view and object visibility.

Gary

#6 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 15 November 2017 - 08:56 AM

Hi Des,

 

Gary is correct on both counts. As of now, renderers must render the mesh as presented by formZ. Clipping worked correctly when first introduced in formZ, but something was changed in more recent versions such that render meshes presented to the Maxwell plugin, are actually not clipped, or are clipped incorrectly. We have previously reported this to ADS with supporting videos and a simple example file. (There is also no SDK access to clip planes, so the plugin can't check to see if a clip plane might be active and perhaps handle the clip itself. )

 

Options:

 

1. Create one or more Render Boolean objects in your formZ project. These work non-destructively like formZ clip planes, except that light does not pass though the excised surfaces.

 

2. Use the 'Make Permanent' option of formZ's clip plane.

 

 



#7 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 362 posts
  • LocationIreland

Posted 16 November 2017 - 03:06 AM

Thanks for the insights guys. I will certainly experiment in the future with Render Boolean option.

As mentioned I did get what I wanted by hiding the objects from the camera in Maxwell attributes, I was just trying to find a lazy way of achieving the same results.

 

Cheers,

 

Des

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users