Jump to content


Photo

Printing to PDF from FormZ Layout 8.5

pdf formz layout pdf fail pdf not working

  • Please log in to reply
5 replies to this topic

#1 Cronze

Cronze

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 29 August 2017 - 09:42 AM

Hi guys,

 

Long time listener; first time caller!  :)

 

I have searched the FormZ forums extensively. Though I could find similar topics, I could not find this specific issue.

 

I have recently upgraded to FormZ and FormZ Layout 8.5.7. I am running MAC OSX (10.12.15). I have just finished drawing my new workshop in a layout project in six sheets in A3 format. I now require these drawings in PDF format for shire/county planning approval.

 

Printing landscape A3 PDFs sounds reasonably straight forward, right? Well.. I have no end of trouble and to no avail. I have tried, but not limited to:

1. Print - > print settings - > save to PDF. Nothing happens... literally nothing. No PDF creation. FormZ just closes the print dialogue. 

2. Tried a number of specific PDF writer printer drivers available in the App Store, including 'PDF Printer'. PDF Printer is not too bad, but I can only get a portrait orientation which crops half the drawing! I presume this to be a limitation of the free or 'lite' version. I am a little reluctant to part with $30 for the full version unless I know it'll fix my problem.

3. Attempted to export to a number of different formats including DWG, DWF and PS and opening these exported files in various other viewers. However, this just created a jumbled mess of objects, lines, splines and other miscellaneous garbage which makes no sense whatsoever. Also, dimensions failed to hop across to these exported formats.

 

The point is though, because the PDF function is built in to both OS and FormZ, one shouldn't have to buy PDF software or export to any other format for the sake of creating a PDF. It should just work.

 

Has anybody out there experienced problems creating a PDF in FormZ Layout 8.5?  And if so, how did you work around it?

 

Thanks heaps,

 

 


  • Brantheat, JerodMl and Cronze like this

#2 malcineurope

malcineurope

    Member

  • Members
  • PipPip
  • 24 posts

Posted 30 August 2017 - 02:21 AM

I have tried this and get the same result, nothing!. I can print the image to pdf but all I get then is a black rectangle. An alternative is to print to pdf in FormZ. If you use a b&W render then you get vector lines. You can print to scale but this needs to be checked. See Workaround for Layout? ...anybody use it this way?



#3 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 31 August 2017 - 10:00 AM

Here is our workflow for printing from Layout to a PDF:

 

1.  File > Print
2.  Click on Print Settings
3.  change the paper size to A3
4.  Click Save
5.  Click Print
6.  In the drop-down menu on the lower left part of the dialogue go to Save As PDF…
7.  Click save and PDF file is generated in the desired location.

 

**EDIT:  The last arrow (#7) pointing to "Print" is not necessary.  After you Click "Save" in the dialogue from Step 6 and the print processes, the entire print dialogue should disappear.

Attached Thumbnails

  • Screen Shot 01.jpg
  • Screen Shot 02.jpg
  • Screen Shot 03.jpg

  • Cronze likes this

#4 Cronze

Cronze

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 07 September 2017 - 08:16 AM

Hello FormZ Tech!

 

Thanks for the update and for awhile this solution was working. However, now FormZ 8.5 Layout crashes 100% of time when either trying to print normally (i.e. on a physical ink printer) or electronically to PDF. I noticed that it stopped working after accidentally selecting the 'Open the PDF in Preview' option. These are the things I have attempted to find a solution including, but not limited to:

1. Reinstalled FormZ 8.5;

2. Tried to 'save-to-PDF' in other programs apart from FormZ. All programs I tested produced a PDF - no problems. Therefore, I have concluded that the problem must be isolated to FormZ; and

3. Tried various option settings, but no matter what is selected, it still crashes.

 

Any guidance from anybody right now would certainly be most appreciated!

 

Thanks,

 

Cronze.



#5 Cronze

Cronze

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 08 September 2017 - 11:19 AM

Hello to those interested,

 

I found the bug!

 

It turned out that I had used too many characters in a 'note' using the dimension toolbar. If you are experience printing crash issues, my I suggest that you follow these steps:

  1. put dimensions and notes in one or two layers
  2.  turn off these layers
  3. try to print/save to PDF. If this works, then you know it'll be dimension issue, and I suspect that like me, you have used the 'notes' tool in the 'dimension toolbar' to create a long string of text.
  4. transfer, or in my case I had to re-type, the 'notes' text into text using the '.Text' tool. 
  5. (Optional) Manipulate the '.text' to make it look like the original 'notes' text. (I'm not sure why the .Text tool can only produce outlined text and this feature or lack thereof is ridiculous. Could we please have a solid .Text  option in a later release? - but anyways...)
  6. (Optional) Put the '.Text' into the notes and dimensions layer
  7. Print or save to PDF in the usual fashion.

I have sent some suggestions for future releases to the good people at FormZ. These include a warning or character count down to alert the user that he/she has exceeded the allowable character limit.

 

Considering that this thread is not well subscribed I suspect these tips will fall on deaf ears. But if you have experienced a printing crash issue and this thread has helped you solve it, then go us!

 

Regards,

 

Cronze.


  • Alan Cooper and Cronze like this

#6 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 11 September 2017 - 10:22 PM

Bronze,

 

We found the problem with large notes and it has been fixed. It will be included in the next update (coming later this month).






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users