Jump to content


Photo

Loss of visibility of snap points?


  • Please log in to reply
11 replies to this topic

#1 Spacer

Spacer

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 18 May 2017 - 07:04 AM

Hi,

 

I imported a SKP file that I am now cleaning up.

 

I seem to have lost the snapping visibility. colored green and red points no longer show when I hover near an object to move it, for example.

 

Snap Tools are active and seem to be toggeling correctly on and off.

 

Anyone know how to get this visibility back?

 

Thanks you!

 

Best,

 

Peter

 

 

 

 


  • qapedkat, dapedkat, Brantheat and 5 others like this

#2 Tech

Tech

    Moderator

  • Moderators
  • 3,963 posts

Posted 18 May 2017 - 09:03 AM

Spacer,

 

Make sure the object(s) and/or layer(s) are all marked as snap-able in their respective list palettes.  Does that help?



#3 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 333 posts
  • LocationBend Oregon

Posted 18 May 2017 - 11:25 AM

I often have this problem when importing and attempting to use Sketchup models.  I have found that using object doctor on a non snapable object often fixes this problem.  It also tends to close openings (missing faces) at the same time which tends to ruin the geometry further.  In those cases I find it easier to just rebuild the object.



#4 Spacer

Spacer

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 19 May 2017 - 05:50 AM

Hi, yeah I rebuilt a lot- still the sluggishness is exasperating...

 

when I creat a new object all is snappy and filled with snap points and grids, etc.. on the other forms, this is not the case.

 

thanks anyway

 

PO



#5 Tech

Tech

    Moderator

  • Moderators
  • 3,963 posts

Posted 19 May 2017 - 09:04 AM

Peter, 

 

How large is the model you are importing?  Is it importing far away from the origin?  Is there a lot of problem geometry with your imported objects?  These can all contribute to the "sluggishness" you are experiencing.  If you post your file or send it to support@formz.com, it would be much easier for us to help diagnose the problem... 



#6 Justin Montoya

Justin Montoya

    Advanced Member

  • Members
  • PipPipPip
  • 292 posts

Posted 19 May 2017 - 01:03 PM

I wonder if Spacer has too many 'Snaps' turned ON?  I think we have all seen major slow downs when leaving ON, Snap to Intersection and Snap to Perpendicular.  Those seem to be particularly bad in terms of sluggishness when left check ON.  Perhaps their programming could be tweaked to be more responsive?  IDK, but for now I think you will find that just turning on the Snaps you are actually using will keep things much snappier!



#7 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 333 posts
  • LocationBend Oregon

Posted 20 May 2017 - 12:02 AM

I stand by my original assessment.  I use a lot of Sketchup crap models and I run into this constantly.  Get rid of anything that you don't need in the model.  Then use the geometry as a template to create good geometry that Form.z can actually work with.  I am running into this right now on two models that were built in Sketchup.  I have a flat plane (door) that I can not snap to no matter what I try. I can not even click on it to texture map it correctly.  I then extrude that plane 1/2" and suddenly my snaps all work and I can map it.  Go figure. 



#8 Bo Atkinson

Bo Atkinson

    Advanced Member

  • Members
  • PipPipPip
  • 152 posts
  • LocationMaine USA

Posted 20 May 2017 - 05:37 AM

I get this problem intermittently with my purely formZ models... I find it happens most often from one side of an object or the other side of the object.  I wish formZ had an instant-view-reversal....

 

However the easy solution for this is to momentarily switch to wire frame render, after my eye has fixated upon the offending point. So as not to become confused with the lost location-- Select the point there, then switch back to my shaded renders.



#9 Spacer

Spacer

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 21 May 2017 - 01:41 AM

Hi fellows,

 

Thanks for all the responses.

 

The model is large, but not ungodly.. the snaps are not always all on- usually point and edge only. not far from origin at all- I moved it all ASAP.

 

Sometimes it seems that snap works better in axonometric rather than perspective mode - but of course as is often the case, I am just trying to get this job out the door,and not performing controlled tests (I know I should,but;;;etc..)

 

Onc eI get my job dponce, I'll try to do some more tests and identify the conditions.

 

Best-

 

Peter

 

 

 



#10 Tech

Tech

    Moderator

  • Moderators
  • 3,963 posts

Posted 22 May 2017 - 09:16 AM

Peter, 

 

Thanks for the input.  Whenever you get a chance to reproduce the problem and document the steps it takes to reproduce--or simply send a file where it is currently not working properly--we would be more than happy to take a look at the issue and fix it  :)



#11 kac

kac

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Posted 05 June 2017 - 09:02 PM

I had that sluggishness importing an iges. Yes running the obj doc on it helps. Also try copy pasting the object into a fresh FZ project file and save that new file out.

I try to run wiht minimal snap options on and this also helps on complex shapes.

 

I really wish FZ had the snapping like MOI has and align tools like MOI. Snapping becomes vague in FZ on complex scenes over time here. 

In old Amapi Pro you could hold down a modifyer key to invoke snapping which also worked well. Was easy to position objects quickly. They also had a lay on tool that allowed you to pick a region of one shape and snap it to another ie point, face, edge, centroid etc,



#12 Tech

Tech

    Moderator

  • Moderators
  • 3,963 posts

Posted 08 June 2017 - 03:07 PM

kac, 

 

Can you be specific about the snapping issues you are experiencing?  Ideally, it is best practice to only have one or two snap types enabled until another snap type is required for the modeling process.  For example, keep Snap to Points and Snap to Key Points on, keep the rest off unless you are trying to snap to the center of an object, then turn on that specific option for the required amount of time.

 

There isn't a "right" and "wrong" way to use snaps, but this strategy would be filed under the "best practice" strategy.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users