Jump to content


Photo

GPU wont render


  • Please log in to reply
7 replies to this topic

#1 Andyb

Andyb

    Advanced Member

  • Members
  • PipPipPip
  • 127 posts

Posted 24 January 2017 - 09:29 AM

Hi Guys,

 

I cant get the GPU render to work at all, unless I use a demo scene file and turn off multilight.

 

From Form Z (display options) I have changed the setting to GPU. When I hit render it vozolizes but then nothing happens and it just hangs at 0SL saying "computing".

 

if I turn it back to CPU it works fine.

 

If I open the file in Studio the GPU fire will work but when hitting render, it hangs again and nothing happens.

 

Any ideas?

 

Windows 10

NVIDIA GeForce GTX 1060 6GB


  • DeanAmbiree, Lizaitala, Vilmaundumb and 1 other like this

#2 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 25 January 2017 - 09:19 AM

Hi Andy,

 

Multilight is not supported in GPU mode (due to the large amount of memory required by that feature).

 

Have you tried rendering the same scene at a lower resolution - say 400x600, just for testing?

 

If you have a scene that will render in CPU mode but not in GPU, please use the Package for Renderfarm command, and then send the resulting MXS and dependencies to Next Limit. (I suggest starting a help ticket through the customer portal.) They are working hard to correct any irregularities found in the GPU engine.

 

 



#3 Andyb

Andyb

    Advanced Member

  • Members
  • PipPipPip
  • 127 posts

Posted 25 January 2017 - 01:53 PM

Hi Ben

 

If I reduce the resolution then it works, and its great when it works, but I do need the higher resolutions. I guess Ill hang fire on the gpu engine... I did notice that the lighting is different though... Is that to be expected? I'm guessing not...

 

cheers...



#4 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 25 January 2017 - 04:28 PM

Hi Andy,

 

Memory is limited in the current generation of graphics cards, so images may sometimes need to be made smaller with GPU rendering. (CPU is limited only by the amount of memory in your computer.)

 

The image may look different because additive materials are not implemented on in GPU rendering yet. If this is not it, please send the scene to Next Limit and provide them with an explanation of what is different. As I understand it, Next Limit's goal is to improve the GPU engine until its results are identical to the CPU version (although in some cases, a lower resolution might be required on GPU due to card memory limitations).

 

 



#5 Andyb

Andyb

    Advanced Member

  • Members
  • PipPipPip
  • 127 posts

Posted 25 January 2017 - 05:18 PM

I see, thanks!



#6 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 26 January 2017 - 08:35 PM

Wow.  I guess I finally got my answer to why it never worked for me.  At least I now have a shiny new expensive graphics card that might work some day. Reducing resolution is not an option for me as my clients blow up my images very large to put on job site signs.  5000 pixels wide is a minimum FYI.


  • David Lemelin likes this

#7 Andyb

Andyb

    Advanced Member

  • Members
  • PipPipPip
  • 127 posts

Posted 27 January 2017 - 07:24 AM

I hope they get this sorted, the GPU is way faster than the CPU engine. The maximum I have been able to do is 1K square at 150dpi.

 

 


  • David Lemelin likes this

#8 Andrew West

Andrew West

    Advanced Member

  • Members
  • PipPipPip
  • 356 posts
  • LocationBend Oregon

Posted 27 January 2017 - 01:54 PM

I have not tested the limit of resolution but I did just test the speed difference between GPU and CPU.  I created three spheres and added a sky dome for the test. 

Using CPU (dual 10 core Xeon 2.6GHZ with 64 GB ram) it took 1Min 36Sec.

Using Nvidia 1080 GTX with 8GB memory it took 40 Sec. 

So now I eagerly await the time when I can render a full res scene at 1/3 the expense............. when they figure out the resolution issue.


  • Andyb likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users