Jump to content


Photo

can't get glass looking clear - too much noise, HELP please.

glass noise

  • Please log in to reply
11 replies to this topic

#1 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 03 May 2015 - 01:19 PM

Hi, 

i am quite new to using Maxwell and have produced some nice results so far, but i am really really struggling with getting my glass to look clear.

 

i am rendering an interior shop view, with no outside light, and everything else looks ok, but the glass is still really 'noisy' at SL20, other things i have tried everything looks fine at SL18.

 

i have changed the white ceiling to be 'off' white (240,240,240), i have turned off loads of the reflections (black unitry and the floor), i have tried upping the lighting, lowering the lighting, changing the camera settings, but NOTHING i do seems to help.

 

as i said i am quite new to maxwell (not formZ), so i may well be doing something fundamentally wrong, but for the life on me i have no idea what.

 

any help MUCH appreciated.

 

thanks

 

Andrew

Attached Thumbnails

  • a.png
  • b.png

  • RudyItapsut and Minaabilk like this

#2 rob

rob

    Advanced Member

  • Members
  • PipPipPip
  • 239 posts

Posted 03 May 2015 - 08:12 PM

Did you try the architectural glass?



#3 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 04 May 2015 - 03:17 AM

Hi Rob,

 

thanks for the tip, I have tried using "glassfastinterior_9803.mxm", which does get rid of the noise, but is a bit too see through, it is almost as if there is nothing there, is there a way of tweaking this material so it is a bit more visible and also to add back in the edges of the glass?

 

thanks



#4 Des

Des

    Advanced Member

  • Members
  • PipPipPip
  • 362 posts
  • LocationIreland

Posted 04 May 2015 - 04:06 AM

As Rob said, use an AGS glass and you can turn up the reflectivity.

Make sure you have plenty of light sources in the model, sometimes I use a large emitter behind the camera (acts like a flash). Also, keep the emitter geometry very low.

The glass not clearing up could be due to the light sources behind the glass. If you use AGS, you will get reflections, but not caustics.

 

And look for tips on interior rendering on the maxwell support site as well.

 

Des



#5 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 04 May 2015 - 10:04 AM

You can edit your glassfastinterior_9803.mxm in the MXED editor that comes with the Maxwell render suite.

 

Alternately, in MXED, create a new AGS preset material, save that, and use it in your formZ project as a referenced MXM.

http://support.nextl...xwell Materials

 

 

 



#6 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 05 May 2015 - 02:00 PM

I have spent another long day trying different settings, i have re lit the whole model making sure no emitters are overlapping anything, i have tried and failed to amend glassfastinterior_9803.mxm material, i don't understand as it has 4 layers how do i add more detail to the glass so it still has defined edges, the same goes for the AGS preset glass, this seems to work fine if i didn't need to see the edges.

 

is there a simple way of adding the glass edge to the AGS glass without turning it back into high grade glass.

 

it is so frustrating, this is the last thing i need to get right!

 

any ideas welcome, 

 

thanks



#7 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 05 May 2015 - 03:24 PM

Please post a small section of your project that is set up to render, and we will see what can be done.

 



#8 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 05 May 2015 - 03:50 PM

Please post a small section of your project that is set up to render, and we will see what can be done.

 

can you clarify what you mean by small section?



#9 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 05 May 2015 - 03:56 PM

A section of your formZ project that exhibits the problem, as a FMZ file. Include all necessary file dependencies such as MXMs, textures, etc.



#10 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 05 May 2015 - 04:02 PM

is this OK?

 

https://www.dropbox....9hdBZIYaMa?dl=0

 



#11 letsknow

letsknow

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 May 2015 - 05:44 AM

found the solution, thanks to Fernado and to Steve for their Help. 

 

i needed to hide them from global illumination in the forms pick attributes - maxwell attributes, the original glass was OK the lights were OK!



#12 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 20 May 2015 - 07:47 AM

Hi,

Sorry we missed that you posted a sample file... not sure how that happened.

Can you post the file again? We have recently made some adjustments to the plugin and are interested to see if these would help with the situation you experienced.

Thanks.







Also tagged with one or more of these keywords: glass, noise

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users