Jump to content


Photo

Option to turn off "smoothing" on object level inside formZ?


  • Please log in to reply
5 replies to this topic

#1 roenning

roenning

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 November 2014 - 05:25 AM

Hello, it would be great if one could set "smoothing" values inside formZ - as an attribute option. Could this be made possible? For now I export my scene to Studio, select the objects that I want Maxwell to treat as facetted and uncheck "smoothing". If one could set this once and for all inside the formZ model there would be no need for that ekstra via Studio step. Does this make sense?

 

Regards,

 

Hans Petter Rønning

 

 


  • BabybyphiB likes this

#2 Tech

Tech

    Moderator

  • Moderators
  • 4,110 posts

Posted 21 November 2014 - 08:44 AM

Hi Hans,

 

Sure, you can do that in formZ.  You can set this at a Project Level via the Display Menu: Project Rendering Options: Smooth Shading tab, and you can also set this per object(s) by selecting the desired object(s), clicking the Attributes Tab of the Pick Options, and changing the Basic Attributes to Smooth Shading.  Then any options you set there will be applied to all selected objects.

 

Does that help?



#3 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 21 November 2014 - 11:17 PM

Yes, the Smooth Shading attribute is transferred to Maxwell. The 2 spheres below have an identical number of faces; only the smooth shading option differs.

Attached Thumbnails

  • Screen Shot 2014-11-21 at 8.12.14 PM.png


#4 roenning

roenning

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 22 November 2014 - 10:13 AM

Thanks for your quick reply. What I would like to do inside formZ is to uncheck the smoothing option marked in the attached image. Is there a way to do this? (If I do not uncheck this, reflections and edges on some facetted objects gets somewhat bulky and unprecise.)

 

Regards,

 

Hans Petter Rønning

Attached Thumbnails

  • studio_screen.jpg


#5 roenning

roenning

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 23 November 2014 - 12:32 PM

Hello again, I finally figured out how this work. What you describe above works just the way I want it to (that is to render correctly directly from formZ). :) Exporting to Studio confused me on this - as I then get smoothing checked and with a default value of 60 on all objects no matter what...



#6 pylon

pylon

    Moderator

  • Moderators
  • 743 posts
  • LocationLos Angeles

Posted 24 November 2014 - 10:29 AM

Yes, that setting in Studio is only to explictly override whatever the plugin has set for the smoothing attribute of the object; it does not report the existing smooth setting. But this is not an issue, as it should be WYSIWYG from formZ to Maxwell.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users